Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
gregamy Absent Member.
Absent Member.

Re: SP2 install error unresolved dependencies

Any resolution? I've got the same issue...

Greg Amy GroupWise Admin Hartford (CT) Hospital
0 Likes
Knowledge Partner
Knowledge Partner

Re: SP2 install error unresolved dependencies

On 02/12/2009 09:54, Anders Bengtsson wrote:

> I've also got loads of deps..... cannot even create the answer
> pass-file for auto installation.


You can only create the password answer file after successfully running
through 'rug up -t patch -g recommended && rug ping -a' - if you get
errors at this stage then you haven't got the necessary patches in place
to create the file.
--
Simon
Novell Knowledge Partner (NKP)

------------------------------------------------------------------------
Do you work with Novell technologies at a university, college or school?
If so, your campus could benefit from joining the Novell Technology
Transfer Partners (TTP) group. See www.novell.com/ttp for more details.
------------------------------------------------------------------------
0 Likes
Knowledge Partner
Knowledge Partner

Re: SP2 install error unresolved dependencies

On 03/12/2009 19:46, ckazzi wrote:

> Hi I think I am getting the same error. I have tried to completed remove
> all my update channels and add them back but still get an error.
>
> If I type zypper refresh I get this error. If you get anywhere with
> Novell please let me know. Thanks.
>
> I have successfully upgraded 2 OES2 SP1 servers to SP2 but I am seeing
> updates available when I click to update I get an error. I have tried
> typing zypper refresh and get this error.
>
> Restoring system sources...
> Parsing metadata for OES2-SP2-Online...
> Parsing metadata for SUSE Linux Enterprise Server 10 SP3...
> Parsing metadata for OES2-SP2-Updates...
> Parsing metadata for Novell Open Enterprise Server 2 SP2...
> Parsing metadata for OES2-SP2-Pool...
> Parsing RPM database...
> 1 Problems:
> Problem: patch:product-oes2-sp2-0-0.noarch[OES2-SP2-Online] cannot be
> installed due to missing dependencies
>
> Problem: patch:product-oes2-sp2-0-0.noarch[OES2-SP2-Online] cannot be
> installed due to missing dependencies
> There are no installable providers of product-oes2-sp2-script.sh ==
> 0-0 for patch:product-oes2-sp2-0-0.noarch[OES2-SP2-Online]
> Solution 1: do not install product-oes2-sp2
> do not install patch:product-oes2-sp2-0-0.noarch[OES2-SP2-Online]
> Solution 2: Ignore this requirement just here
> number, (r)etry or (c)ancel> c


zypper is not the correct command to use when patching OES2 Linux
servers - rug should be used as per documentation.

HTH.
--
Simon
Novell Knowledge Partner (NKP)

------------------------------------------------------------------------
Do you work with Novell technologies at a university, college or school?
If so, your campus could benefit from joining the Novell Technology
Transfer Partners (TTP) group. See www.novell.com/ttp for more details.
------------------------------------------------------------------------
0 Likes
Knowledge Partner
Knowledge Partner

Re: SP2 install error unresolved dependencies

On 02/12/2009 19:08, Thomas Reiß wrote:

> avoid/remove the OES2-SP1 Channels on OES2SP2 Servers.
>
> I have a lot of trouble with new Serverinstallation's when thy available.
> Now i always remove these channels/installsources in Novell Customer
> Center.
>
> Here they comes back, whyever...


After a successful online upgrade from OES2 SP1 to SP2 you should have
SLES10 SP3 and OES2 SP2 channels and the SLES10 SP2 and OES2 SP1 ones
will have automagically disappeared.

You will be left though with two SLES10 SP2 and OES2 SP1 media channels
(i.e. if you did a network install via HTTP you will still see
references to those) so you need to manually fix those yourself after
the upgrade if you want access to the media.
--
Simon
Novell Knowledge Partner (NKP)

------------------------------------------------------------------------
Do you work with Novell technologies at a university, college or school?
If so, your campus could benefit from joining the Novell Technology
Transfer Partners (TTP) group. See www.novell.com/ttp for more details.
------------------------------------------------------------------------
0 Likes
Knowledge Partner
Knowledge Partner

Re: SP2 install error unresolved dependencies

ckazzi;1899454 wrote:
Hi I think I am getting the same error. I have tried to completed remove all my update channels and add them back but still get an error.

If I type zypper refresh I get this error. If you get anywhere with Novell please let me know. Thanks.

I have successfully upgraded 2 OES2 SP1 servers to SP2 but I am seeing updates available when I click to update I get an error. I have tried typing zypper refresh and get this error.

Restoring system sources...
Parsing metadata for OES2-SP2-Online...
Parsing metadata for SUSE Linux Enterprise Server 10 SP3...
Parsing metadata for OES2-SP2-Updates...
Parsing metadata for Novell Open Enterprise Server 2 SP2...
Parsing metadata for OES2-SP2-Pool...
Parsing RPM database...
1 Problems:
Problem: patch:product-oes2-sp2-0-0.noarch[OES2-SP2-Online] cannot be installed due to missing dependencies

Problem: patch:product-oes2-sp2-0-0.noarch[OES2-SP2-Online] cannot be installed due to missing dependencies
There are no installable providers of product-oes2-sp2-script.sh == 0-0 for patch:product-oes2-sp2-0-0.noarch[OES2-SP2-Online]
Solution 1: do not install product-oes2-sp2
do not install patch:product-oes2-sp2-0-0.noarch[OES2-SP2-Online]
Solution 2: Ignore this requirement just here
number, (r)etry or (c)ancel> c

I have the same issue. There is more info on this in the NOWS SBE forum. See this thread: New Simba Patch

I wondering if this is affecting all OES2 SP2 upgrades...

After applying the updates on my server I noticed that OES2 was no longer activated. I had no problem re-activating it. Once I verified I had the correct repos, I reran zypper. I still have issues but perhaps this info may provide some clues.
_____
Kevin Boyle - Knowledge Partner - Calgary, Alberta, Canada
Who are the Knowledge Partners?
If you appreciate my comments, please click the Like button.
If I have resolved your issue, please click the Accept as Solution button.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.