Highlighted
Absent Member.
Absent Member.
1822 views

Setting up Pure ftpd

I am running 6 Suse oes2 servers and one windows 2008r2
for zcm server that I just setup a couple of weeks ago.
These servers are up and in operation now.
Everything seems to be working great except for ftp. I have not
done any configurations on pure ftpd until today.

I am having problems getting pure ftpd to work.

1. I can login to my account but students cant.
When I login I simply use my user name. i.e. jdoe and it works.
when I do the same for students I get
"503 Login Authentication failed"
I have tried "jsmith" and "jsmith.students" same results.
My account is in a admin context and the student in the "students" context.
Faculty are in the "faculty" context.

2 Even When I can login I cant get my user home dir in EDIR.

3. Every time I login successfully or Un-successfully I have to restart
pure ftpd. If I just simply press enter at the login name same thing
happens. I have to restart ftp.

Thanks
Dave.
Labels (2)
0 Likes
10 Replies
Highlighted
Absent Member.
Absent Member.

Re: Setting up Pure ftpd

On topic 3
after successfully or unsuccessfully logging in and trying again
when at console typing
"ftp 191.16.17.253"
I get the error
"Connected to 192.16.17.253."
"Connection closed by remote host."
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: Setting up Pure ftpd

dmiller wrote:

> I am having problems getting pure ftpd to work.


Does this help?
https://www.novell.com/support/kb/doc.php?id=3503915

Try searching the knowledgebase:
https://www.novell.com/support/

--
Kevin Boyle - Knowledge Partner
If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below...
_____
Kevin Boyle - Knowledge Partner - Calgary, Alberta, Canada
Who are the Knowledge Partners?
If you appreciate my comments, please click the Like button.
If I have resolved your issue, please click the Accept as Solution button.
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Setting up Pure ftpd

I have been studying this link.
But I am worried why when any attempt to login again(same user or different user) as soon as I type "ftp 192.17.16.253" I get connection closed by host.
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: Setting up Pure ftpd

dmiller wrote:

>
> I have been studying this link.
> But I am worried why when any attempt to login again(same user or
> different user) as soon as I type "ftp 192.17.16.253" I get connection
> closed by host.


Have you checked the logs for any clues?

You might get a packet trace at the server (WireShark?). That would
tell you exactly what is happening.



--
Kevin Boyle - Knowledge Partner
If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below...
_____
Kevin Boyle - Knowledge Partner - Calgary, Alberta, Canada
Who are the Knowledge Partners?
If you appreciate my comments, please click the Like button.
If I have resolved your issue, please click the Accept as Solution button.
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Setting up Pure ftpd

This may sound stupid buy my work with oes2 is limited. I've been with NetWare for the last 17 years.
Is "Pure Ftpd" the same as "Novell Pure Ftpd"? I looked in System Services and see that Pure-ftpd in not enable.
It doesn't seem to make any differences though. The results are still the same.

Where are the ftp error logs located?
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: Setting up Pure ftpd

dmiller wrote:

> This may sound stupid buy my work with oes2 is limited.


No, not stupid at all. Everyone goes through a learning curve on a new
system. Until you have been working with OES for a while, things can
sometimes be a bit overwhelming.

There are some good resources listed in the sticky post. Have a look:
http://forums.novell.com/showthread.php?t=465099


> I've been with NetWare for the last 17 years.


That's good! You should already be familiar with many of the OES
services.


> Is "Pure Ftpd" the same as "Novell Pure Ftpd"?


Sort of...

Pure Ftpd will run on SLES. Novell Pure Ftpd may be tweaked a bit to
work better with OES. Generally speaking, when you see two similar
components and one has the Novell prefix, you want to install the
Novell version on an OES system.


> I looked in System
> Services and see that Pure-ftpd in not enable.
> It doesn't seem to make any differences though. The results are still
> the same.


Take a look at the TID to which I referred you in my previous post:
https://www.novell.com/support/kb/doc.php?id=3503915

> For OES 2 and 11, regardless of support pack:
>
> The first step that is needed (aside from the prerequisites mentions
> above) is to tell Yast's OES configuration to install "Novell FTP".



> Where are the ftp error logs located?


The main log file on a OES/SLES system is /var/log/messages. There lots
of other log files in /var/log and sub-directories. This is always a
good place to begin troubleshooting.


--
Kevin Boyle - Knowledge Partner
If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below...
_____
Kevin Boyle - Knowledge Partner - Calgary, Alberta, Canada
Who are the Knowledge Partners?
If you appreciate my comments, please click the Like button.
If I have resolved your issue, please click the Accept as Solution button.
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Setting up Pure ftpd

>1. I can login to my account but students cant.
> When I login I simply use my user name. i.e. jdoe and it works.
> when I do the same for students I get
> "503 Login Authentication failed"
> I have tried "jsmith" and "jsmith.students" same results.
> My account is in a admin context and the student in the "students" context.
> Faculty are in the "faculty" context.

If all the users are "lum enabled" and some work but not others, then possibly one difference is whether the user's lum-enabled-group is associated with the workstation object for this OES system. LUM users don't get access to every server. Just the ones where this association has been made.

>2. Even When I can login I cant get my user home dir in EDIR.

The default for pure-ftpd is to take people to their posix (local linux) home directory. Even in pure-ftpd enhanced for OES, the ability to be put in an NCP(edir) home directory was not added until OES 11 SP1. On OES 2 (SP3 plus all updates) the best you can do is reach your posix home dir first, then CD (or make other reference) to NCP locations as with syntax format like: cd //server_name/vol_name/directory

>3. Every time I login successfully or Un-successfully I have to restart
> pure ftpd. If I just simply press enter at the login name same thing
> happens. I have to restart ftp.

This sounds like something has mis-set the PassivePortRange in /etc/pure-ftpd/pure-ftpd.conf.

The following sounds like a good match for your symptom:
Support | Pure-ftpd: first connection works, second connection fails

You might also see this one:
Support | FTP connections not working after 'FTP Migration" from NetWare to OES
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Setting up Pure ftpd

P.S. Another explanation on #1 might be that your user has a shell set, but the students do not. Pure-ftpd (or rather pam, via the /etc/pam.d/pure-ftpd configuration) checks for a shell setting, and if it is not there, login will fail. This is a common FTP check in the linux world, despite the fact that FTP doesn't actually use said shell.
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Setting up Pure ftpd

upon further work and much fustration I have more info on my situation.

I fixed the issue with ftpd not starting the second time. I found that going to the yast ftpd config causes that prolem.
always edit the config file manually.

my account appears to be the only account that can ftpd login. But still I cannot access my edir home folder. It always goes to "/home". I even created a user "batman" in my context and added them to the lum group and manyually enabled the user.
they still canot login. But in their Unix Profile they have /home/batman as the home directory.

I type "id dmiller" and I get
uid=1000(dmiller) gid=100(users) groups=100(users), 16(dialout),33(video)

for batman I get
uid=603(batman) gid=604(lum_admins) groups = 604(lum_admins)

for abott
uid=604(abbot) gid=604(lum_admins) groups=604(lum_admins)

dmiller and batman are in the admins context. abott is the student context.
they are all in the LUM_ADMINS group

when in yast ldap client config it appears we cannot disable ldap logins. I select the radial button and save the config but it still reappears enabled when I go back to the yast config.


thanks
Dave.
0 Likes
Absent Member.
Absent Member.

Re: Setting up Pure ftpd

>my account appears to be the only account that can ftpd login. But still I cannot access my edir home folder. It always goes to "/home"
<snip>
>I type "id dmiller" and I get
> uid=1000(dmiller) gid=100(users) groups=100(users), 16(dialout),33(video)

That "dmiller" appears to be a local user, not a eDir user. Is it possible you have "dmiller" existing in /etc/passwd, besides in eDir? (If so, delete or remark the line from /etc/passwd, for dmiller.) I'm guessing that during SLES install you had the system create that user. The first local, non-system user that a SLES adminstrator creates typically gets UID 1000, and then local user numbers increment from there. eDir lum accounts start around UID 600.

So I'm guessing that what is really happening is that you have a local user who can login (but therefore his home is not in the place you expect, because it's not even the eDir account which you think it is). And so far it sounds like *no* eDir users can login (since this dmiller isn't really an eDir user). I suspect, then, that /etc/pam.d/pure-ftpd is not correctly configured for pam_nam (lum) logins. The "Novell FTP" pattern usually alters that file is such that local users CANNOT login, and only eDir can. And it sounds like you're getting the opposite (which may mean that the standard /etc/pam.d/pure-ftpd is still there, not altered by "Novell FTP" install pattern).

Can you supply your /etc/pam.d/pure-ftpd here?

Or you may want to run through the "Novell FTP" pattern (did you do this originally?). In Yast, Open Enterprise Server, OES Install and Config, "Novell FTP" should be checked. That will alter various pure-ftpd configuration in preparation for being LUM aware and using the extra features that OES has added.

Darcy
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.