Anonymous_User Absent Member.
Absent Member.
5270 views

Slow Novell login prompt, when wireless card enabled

I've seen numerous postings about this issue, but haven't found a
solution as of yet. When any of my wireless DELL laptops boot up (with
the wireless card set to the "enabled" state), it takes about 2 minutes
for the Novell client screen to appear. With the wireless card
disabled, it takes only 10 seconds to get from the XP splash screen to
the Novell client screen.

This is an issue with Dell TrueMobile wireless adapters with the latest
drivers, and Intel Pro wireless adapters with the latest drivers. That
compromises 100% of my wireless adapters.

All laptops are using Novell client version 4.91.0.20050216. IP is the
only protocol binded on the workstations. There is no Zenworks in this
environment.

Here are the things I have tried so far:

1) disabled the "Bad Server Name Cache"
2) set "Bad Address Cache Timeout" to 0
3) switched from using the built-in Windows wireless service to the
DELL Wireless utility (and disabled the Wireless Zero Configuration
afterwards)
4) done a Swahili rain dance in my cubicle

The Novell login prompt still takes 2 full minutes to come up unless:
a) I disable the wireless card before shutting down the system
b) uninstall the Novell client


This is not an issue on my wired clients...only laptops with wireless
cards that are enabled. Thanks for any advice.
Labels (1)
0 Likes
19 Replies
Anonymous_User Absent Member.
Absent Member.

Re: Slow Novell login prompt, when wireless card enabled

bump

Chris Wilson wrote:

> I've seen numerous postings about this issue, but haven't found a
> solution as of yet. When any of my wireless DELL laptops boot up
> (with the wireless card set to the "enabled" state), it takes about 2
> minutes for the Novell client screen to appear. With the wireless
> card disabled, it takes only 10 seconds to get from the XP splash
> screen to the Novell client screen.
>
> This is an issue with Dell TrueMobile wireless adapters with the
> latest drivers, and Intel Pro wireless adapters with the latest
> drivers. That compromises 100% of my wireless adapters.
>
> All laptops are using Novell client version 4.91.0.20050216. IP is
> the only protocol binded on the workstations. There is no Zenworks
> in this environment.
>
> Here are the things I have tried so far:
>
> 1) disabled the "Bad Server Name Cache"
> 2) set "Bad Address Cache Timeout" to 0
> 3) switched from using the built-in Windows wireless service to the
> DELL Wireless utility (and disabled the Wireless Zero Configuration
> afterwards)
> 4) done a Swahili rain dance in my cubicle
>
> The Novell login prompt still takes 2 full minutes to come up unless:
> a) I disable the wireless card before shutting down the system
> b) uninstall the Novell client
>
>
> This is not an issue on my wired clients...only laptops with wireless
> cards that are enabled. Thanks for any advice.


0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Slow Novell login prompt, when wireless card enabled

Chris, could you please try and install the Novell Client as "IPX Only"
and as "IP Only" and see if you have the same results with each?

I suspect there is a "DependOnService" that is waiting for something to
initialize and causing the delay.

By installing the Client in each configuration, we should be able to
determine if a service related to IPX or IP is causing the issue.
(I would suspect that IPX only is less likely to see the issue.)

In addition, does your Wireless card get an IP Address before or After
logging into Winodws?
(Try pinging with Wireless NIC before and after the Windows Logon.)

I am curious if configuring the NIC to get an address before vs after
logon has an effect.

Sorry for being slow in responding.


Chris Wilson wrote:
> bump
>
> Chris Wilson wrote:
>
>> I've seen numerous postings about this issue, but haven't found a
>> solution as of yet. When any of my wireless DELL laptops boot up
>> (with the wireless card set to the "enabled" state), it takes about 2
>> minutes for the Novell client screen to appear. With the wireless
>> card disabled, it takes only 10 seconds to get from the XP splash
>> screen to the Novell client screen.
>>
>> This is an issue with Dell TrueMobile wireless adapters with the
>> latest drivers, and Intel Pro wireless adapters with the latest
>> drivers. That compromises 100% of my wireless adapters.
>>
>> All laptops are using Novell client version 4.91.0.20050216. IP is
>> the only protocol binded on the workstations. There is no Zenworks
>> in this environment.
>>
>> Here are the things I have tried so far:
>>
>> 1) disabled the "Bad Server Name Cache"
>> 2) set "Bad Address Cache Timeout" to 0
>> 3) switched from using the built-in Windows wireless service to the
>> DELL Wireless utility (and disabled the Wireless Zero Configuration
>> afterwards)
>> 4) done a Swahili rain dance in my cubicle
>>
>> The Novell login prompt still takes 2 full minutes to come up unless:
>> a) I disable the wireless card before shutting down the system
>> b) uninstall the Novell client
>>
>>
>> This is not an issue on my wired clients...only laptops with wireless
>> cards that are enabled. Thanks for any advice.

>



--
Craig Wilson
Novell Product Support Forum Sysop
Master CNE, MCSE 2003, CCN
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Slow Novell login prompt, when wireless card enabled

Thanks for the reply, Craig.

1) All of my Novell clients are installed as "IP Only", and I
specifically checkmark that box that says "Remove IPX if present", to
avoid any of these potential conflicts of protocols fighting.

2) It doesn't seem to matter whether or not the laptop gets an IP
address before Windows logon. Most of them do NOT get an IP address
before login (you need to login to "workstation only", then login to
Novell). However, I recently had the same thought as you, and
downloaded/installed the DELL wireless utility, which "kicks off" the
wireless service before login. My wireless laptop now gets an IP
address before logging into Windows (I don't need to do "workstation
only" anymore). However, it STILL takes a full 2 minutes for the
Novell login box to appear beforehand. Then, it takes maybe 15
additional seconds for it to get an IP address and successfully login.
The 15 seconds is fine and pretty much expected, as I know it needs to
negotiate with the wireless access point to get an IP and authenticate.
But I still can't figure out why it "halts" for 2 minutes before the
Novell login pops up to begin with.

Will installing the client as "IPX only" prohibit my ability to login
to the server? I'm under the impression that our environment is IP
only...but I could be wrong.

3) An additional note: out of a suggestion from a colleague, I
uninstalled the "Client for Microsoft Networks" from the Network
Connections, and that totally solved the delay on the next boot.
Unfortunately, without that, I can no longer access the other Windows
workgroup computers/servers, which have some shares that I need to
access occasionally. (We are not in a domain, rather a workgroup). As
soon as I put the Client for Microsoft Networks back again, the 2
minute login delay reappeared.

Hope this info is enough to lead to some more ideas and possible
solutions. Seems like Microsoft and Novell clients are at war with
each other.

Thanks
Chris

craig wilson wrote:

> Chris, could you please try and install the Novell Client as "IPX
> Only" and as "IP Only" and see if you have the same results with each?
>
> I suspect there is a "DependOnService" that is waiting for something
> to initialize and causing the delay.
>
> By installing the Client in each configuration, we should be able to
> determine if a service related to IPX or IP is causing the issue. (I
> would suspect that IPX only is less likely to see the issue.)
>
> In addition, does your Wireless card get an IP Address before or
> After logging into Winodws? (Try pinging with Wireless NIC before
> and after the Windows Logon.)
>
> I am curious if configuring the NIC to get an address before vs after
> logon has an effect.
>
> Sorry for being slow in responding.
>
>
> Chris Wilson wrote:
> > bump
> >
> > Chris Wilson wrote:
> >
> > > I've seen numerous postings about this issue, but haven't found a
> > > solution as of yet. When any of my wireless DELL laptops boot up
> > > (with the wireless card set to the "enabled" state), it takes
> > > about 2 minutes for the Novell client screen to appear. With the
> > > wireless card disabled, it takes only 10 seconds to get from the
> > > XP splash screen to the Novell client screen.
> > >
> > > This is an issue with Dell TrueMobile wireless adapters with the
> > > latest drivers, and Intel Pro wireless adapters with the latest
> > > drivers. That compromises 100% of my wireless adapters.
> > >
> > > All laptops are using Novell client version 4.91.0.20050216. IP
> > > is the only protocol binded on the workstations. There is no
> > > Zenworks in this environment.
> > >
> > > Here are the things I have tried so far:
> > >
> > > 1) disabled the "Bad Server Name Cache"
> > > 2) set "Bad Address Cache Timeout" to 0
> > > 3) switched from using the built-in Windows wireless service to
> > > the DELL Wireless utility (and disabled the Wireless Zero
> > > Configuration afterwards)
> > > 4) done a Swahili rain dance in my cubicle
> > >
> > > The Novell login prompt still takes 2 full minutes to come up
> > > unless: a) I disable the wireless card before shutting down the
> > > system b) uninstall the Novell client
> > >
> > >
> > > This is not an issue on my wired clients...only laptops with
> > > wireless cards that are enabled. Thanks for any advice.

> >


0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Slow Novell login prompt, when wireless card enabled

Yes, IPX only will likely make the laptop unable to logon to the network.

However, this is just a test.

Different Client services are loaded when you do an IPX install verses
an IP install. This will help confirm whether on of the Novell IP
related services is causing the delay. This is not a test of
functionality but rather trying to isolate which part of the client is
causing the delay.


Chris Wilson wrote:

> Will installing the client as "IPX only" prohibit my ability to login
> to the server? I'm under the impression that our environment is IP
> only...but I could be wrong.
>


--
Craig Wilson
Novell Product Support Forum Sysop
Master CNE, MCSE 2003, CCN
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Slow Novell login prompt, when wireless card enabled

Hi,

Not sure if this will help or not but when I see this problem in my
environment, I usually end up deleting all the wireless connections
that have accumulated after connecting to a wireless device. For
whatever reason, after a certain magical #, the login takes that 2
minutes to appear after hitting the ctrl - alt - delete. Once deleting
them and just keeping the 3 or 4 they really need, it seems to speed up.

I havent seen anyone else mention this and am wondering if it only
works here or not....

Jason
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Slow Novell login prompt, when wireless card enabled

We have come across some Dell Latitude 520s which hang on the login
script forever (I have let them sit for an hour or two with no progress).

This is what I have discovered in some testing.

When it gets to the hanging login script, if you go to task manager and
force explorer.exe to run, the login script immediately runs and
everything is peachy.

If at the hung login script I go to a command prompt and type "slpinfo
/all", the out address is reported as 224.0.1.35. If I kick-off
explorer.exe and the login script runs and I again try "slpinfo /all"
the out address has changed to 224.0.1.22, which is what my desktop reports.

Weird.

Chris Wilson wrote:
> Thanks for the reply, Craig.
>
> 1) All of my Novell clients are installed as "IP Only", and I
> specifically checkmark that box that says "Remove IPX if present", to
> avoid any of these potential conflicts of protocols fighting.
>
> 2) It doesn't seem to matter whether or not the laptop gets an IP
> address before Windows logon. Most of them do NOT get an IP address
> before login (you need to login to "workstation only", then login to
> Novell). However, I recently had the same thought as you, and
> downloaded/installed the DELL wireless utility, which "kicks off" the
> wireless service before login. My wireless laptop now gets an IP
> address before logging into Windows (I don't need to do "workstation
> only" anymore). However, it STILL takes a full 2 minutes for the
> Novell login box to appear beforehand. Then, it takes maybe 15
> additional seconds for it to get an IP address and successfully login.
> The 15 seconds is fine and pretty much expected, as I know it needs to
> negotiate with the wireless access point to get an IP and authenticate.
> But I still can't figure out why it "halts" for 2 minutes before the
> Novell login pops up to begin with.
>
> Will installing the client as "IPX only" prohibit my ability to login
> to the server? I'm under the impression that our environment is IP
> only...but I could be wrong.
>
> 3) An additional note: out of a suggestion from a colleague, I
> uninstalled the "Client for Microsoft Networks" from the Network
> Connections, and that totally solved the delay on the next boot.
> Unfortunately, without that, I can no longer access the other Windows
> workgroup computers/servers, which have some shares that I need to
> access occasionally. (We are not in a domain, rather a workgroup). As
> soon as I put the Client for Microsoft Networks back again, the 2
> minute login delay reappeared.
>
> Hope this info is enough to lead to some more ideas and possible
> solutions. Seems like Microsoft and Novell clients are at war with
> each other.
>
> Thanks
> Chris
>
> craig wilson wrote:
>
>> Chris, could you please try and install the Novell Client as "IPX
>> Only" and as "IP Only" and see if you have the same results with each?
>>
>> I suspect there is a "DependOnService" that is waiting for something
>> to initialize and causing the delay.
>>
>> By installing the Client in each configuration, we should be able to
>> determine if a service related to IPX or IP is causing the issue. (I
>> would suspect that IPX only is less likely to see the issue.)
>>
>> In addition, does your Wireless card get an IP Address before or
>> After logging into Winodws? (Try pinging with Wireless NIC before
>> and after the Windows Logon.)
>>
>> I am curious if configuring the NIC to get an address before vs after
>> logon has an effect.
>>
>> Sorry for being slow in responding.
>>
>>
>> Chris Wilson wrote:
>>> bump
>>>
>>> Chris Wilson wrote:
>>>
>>>> I've seen numerous postings about this issue, but haven't found a
>>>> solution as of yet. When any of my wireless DELL laptops boot up
>>>> (with the wireless card set to the "enabled" state), it takes
>>>> about 2 minutes for the Novell client screen to appear. With the
>>>> wireless card disabled, it takes only 10 seconds to get from the
>>>> XP splash screen to the Novell client screen.
>>>>
>>>> This is an issue with Dell TrueMobile wireless adapters with the
>>>> latest drivers, and Intel Pro wireless adapters with the latest
>>>> drivers. That compromises 100% of my wireless adapters.
>>>>
>>>> All laptops are using Novell client version 4.91.0.20050216. IP
>>>> is the only protocol binded on the workstations. There is no
>>>> Zenworks in this environment.
>>>>
>>>> Here are the things I have tried so far:
>>>>
>>>> 1) disabled the "Bad Server Name Cache"
>>>> 2) set "Bad Address Cache Timeout" to 0
>>>> 3) switched from using the built-in Windows wireless service to
>>>> the DELL Wireless utility (and disabled the Wireless Zero
>>>> Configuration afterwards)
>>>> 4) done a Swahili rain dance in my cubicle
>>>>
>>>> The Novell login prompt still takes 2 full minutes to come up
>>>> unless: a) I disable the wireless card before shutting down the
>>>> system b) uninstall the Novell client
>>>>
>>>>
>>>> This is not an issue on my wired clients...only laptops with
>>>> wireless cards that are enabled. Thanks for any advice.

>



--
Jeremy Mlazovsky
Senior System Engineer - Enterprise Desktop
UDit-Central Hardware Systems & Network Storage
University of Dayton

http://forge.novell.com/modules/xfmod/project/?udimage
http://vmpconfig.sourceforge.net/
http://regeditpe.sourceforge.net
0 Likes
Anonymous_User Absent Member.
Absent Member.

One fix found

I found that the people who setup these machines never ran SysPrep or
anything to prepare the machine for imaging.

SysPrep wouldn't run on the image for some reason, but I ran
SysInternal's free NewSID and after a reboot it works.

Jeremy Mlazovsky wrote:
> We have come across some Dell Latitude 520s which hang on the login
> script forever (I have let them sit for an hour or two with no progress).
>
> This is what I have discovered in some testing.
>
> When it gets to the hanging login script, if you go to task manager and
> force explorer.exe to run, the login script immediately runs and
> everything is peachy.
>
> If at the hung login script I go to a command prompt and type "slpinfo
> /all", the out address is reported as 224.0.1.35. If I kick-off
> explorer.exe and the login script runs and I again try "slpinfo /all"
> the out address has changed to 224.0.1.22, which is what my desktop
> reports.
>
> Weird.
>
> Chris Wilson wrote:
>> Thanks for the reply, Craig.
>>
>> 1) All of my Novell clients are installed as "IP Only", and I
>> specifically checkmark that box that says "Remove IPX if present", to
>> avoid any of these potential conflicts of protocols fighting.
>>
>> 2) It doesn't seem to matter whether or not the laptop gets an IP
>> address before Windows logon. Most of them do NOT get an IP address
>> before login (you need to login to "workstation only", then login to
>> Novell). However, I recently had the same thought as you, and
>> downloaded/installed the DELL wireless utility, which "kicks off" the
>> wireless service before login. My wireless laptop now gets an IP
>> address before logging into Windows (I don't need to do "workstation
>> only" anymore). However, it STILL takes a full 2 minutes for the
>> Novell login box to appear beforehand. Then, it takes maybe 15
>> additional seconds for it to get an IP address and successfully login.
>> The 15 seconds is fine and pretty much expected, as I know it needs to
>> negotiate with the wireless access point to get an IP and authenticate.
>> But I still can't figure out why it "halts" for 2 minutes before the
>> Novell login pops up to begin with.
>>
>> Will installing the client as "IPX only" prohibit my ability to login
>> to the server? I'm under the impression that our environment is IP
>> only...but I could be wrong.
>>
>> 3) An additional note: out of a suggestion from a colleague, I
>> uninstalled the "Client for Microsoft Networks" from the Network
>> Connections, and that totally solved the delay on the next boot.
>> Unfortunately, without that, I can no longer access the other Windows
>> workgroup computers/servers, which have some shares that I need to
>> access occasionally. (We are not in a domain, rather a workgroup). As
>> soon as I put the Client for Microsoft Networks back again, the 2
>> minute login delay reappeared.
>>
>> Hope this info is enough to lead to some more ideas and possible
>> solutions. Seems like Microsoft and Novell clients are at war with
>> each other.
>>
>> Thanks
>> Chris
>>
>> craig wilson wrote:
>>
>>> Chris, could you please try and install the Novell Client as "IPX
>>> Only" and as "IP Only" and see if you have the same results with each?
>>>
>>> I suspect there is a "DependOnService" that is waiting for something
>>> to initialize and causing the delay.
>>>
>>> By installing the Client in each configuration, we should be able to
>>> determine if a service related to IPX or IP is causing the issue. (I
>>> would suspect that IPX only is less likely to see the issue.)
>>>
>>> In addition, does your Wireless card get an IP Address before or
>>> After logging into Winodws? (Try pinging with Wireless NIC before
>>> and after the Windows Logon.)
>>>
>>> I am curious if configuring the NIC to get an address before vs after
>>> logon has an effect.
>>>
>>> Sorry for being slow in responding.
>>>
>>>
>>> Chris Wilson wrote:
>>>> bump
>>>>
>>>> Chris Wilson wrote:
>>>>
>>>>> I've seen numerous postings about this issue, but haven't found a
>>>>> solution as of yet. When any of my wireless DELL laptops boot up
>>>>> (with the wireless card set to the "enabled" state), it takes
>>>>> about 2 minutes for the Novell client screen to appear. With the
>>>>> wireless card disabled, it takes only 10 seconds to get from the
>>>>> XP splash screen to the Novell client screen.
>>>>>
>>>>> This is an issue with Dell TrueMobile wireless adapters with the
>>>>> latest drivers, and Intel Pro wireless adapters with the latest
>>>>> drivers. That compromises 100% of my wireless adapters.
>>>>>
>>>>> All laptops are using Novell client version 4.91.0.20050216. IP
>>>>> is the only protocol binded on the workstations. There is no
>>>>> Zenworks in this environment.
>>>>>
>>>>> Here are the things I have tried so far:
>>>>>
>>>>> 1) disabled the "Bad Server Name Cache"
>>>>> 2) set "Bad Address Cache Timeout" to 0
>>>>> 3) switched from using the built-in Windows wireless service to
>>>>> the DELL Wireless utility (and disabled the Wireless Zero
>>>>> Configuration afterwards)
>>>>> 4) done a Swahili rain dance in my cubicle
>>>>>
>>>>> The Novell login prompt still takes 2 full minutes to come up
>>>>> unless: a) I disable the wireless card before shutting down the
>>>>> system b) uninstall the Novell client
>>>>>
>>>>>
>>>>> This is not an issue on my wired clients...only laptops with
>>>>> wireless cards that are enabled. Thanks for any advice.

>>

>
>



--
Jeremy Mlazovsky
Senior System Engineer - Enterprise Desktop
UDit-Central Hardware Systems & Network Storage
University of Dayton

http://forge.novell.com/modules/xfmod/project/?udimage
http://vmpconfig.sourceforge.net/
http://regeditpe.sourceforge.net
0 Likes
smbober Absent Member.
Absent Member.

Re: Slow Novell login prompt, when wireless card enabled

What is your Wireless Zero Config Service set to? If it is manual, try automatic. If it is automatic, set it to manual. sean.m.bober at seagate com if you care to close the loop as I probably won't be checking back anytime soon.
0 Likes
smbober Absent Member.
Absent Member.

Re: Slow Novell login prompt, when wireless card enabled

smbober;1551814 wrote:
What is your Wireless Zero Config Service set to? If it is manual, try automatic. If it is automatic, set it to manual. sean.m.bober at seagate com if you care to close the loop as I probably won't be checking back anytime soon.

I see that you already did some wireless config things. How about this. Uninstall any other wireless managers such as Cisco's, Intel's Pro Set, or Odyssey's, then play with the wireless zero config service startup types.
0 Likes
darryl82 Absent Member.
Absent Member.

Re: Slow Novell login prompt, when wireless card enabled

Hi,

anyone get any further with this issue?
0 Likes
LurveLeif Absent Member.
Absent Member.

Re: Slow Novell login prompt, when wireless card enabled

darryl82;1805201 wrote:
Hi,

anyone get any further with this issue?


Hi

We have the exact same problem at our place, I'd love to see a solution on this.
0 Likes
Marcel_Cox Absent Member.
Absent Member.

Re: Slow Novell login prompt, when wireless card enabled

I'm not sure this is even "one" issue. It might actually be different issues that just produce similar symptoms. All in all, to help you find out what the problem might be and how to solve it, we need information on your environment:

- what client OS and Novell client are you using?
- what kind of servers are you using?
- what protocol are you using to access the server?
- if you are using IP, what does your name resolution setup look like? Are you using a Directory Agent? If yes, how does the client find your DA?
- are you accessing your server through wireless, or is it just th fact that wireless is enabled that causes the delay?
0 Likes
LurveLeif Absent Member.
Absent Member.

Re: Slow Novell login prompt, when wireless card enabled

Marcel_Cox;1806588 wrote:
I'm not sure this is even "one" issue. It might actually be different issues that just produce similar symptoms. All in all, to help you find out what the problem might be and how to solve it, we need information on your environment:

- what client OS and Novell client are you using?
- what kind of servers are you using?
- what protocol are you using to access the server?
- if you are using IP, what does your name resolution setup look like? Are you using a Directory Agent? If yes, how does the client find your DA?
- are you accessing your server through wireless, or is it just th fact that wireless is enabled that causes the delay?


On my behalf it's:
Windows XP Professional SP3 with all the latest critical/security patches
4.91 SP3 pka, but have tried with latest version too (4.91. SP5 and ALOT (sigh) of different patches, both beta and not beta)
IP only
DNS server is through our AD domain (we use both AD and eDir)
SLP delievered through DCHP, this is working fine
We also have contextless login setup

And as stated, wireless on or off (via radiobutton) has nothing with delay. It's just very slow on laptops, not on our PCs. We use the same methods for installing (during the sysprep process with answer file) on laptops and PCs.
0 Likes
Knowledge Partner
Knowledge Partner

Re: Slow Novell login prompt, when wireless card enabled

LurveLeif,
> We have the exact same problem at our place, I'd love to see a solution
> on this.
>

Have you tried getting a packet trace, all the way from bootup?

- Anders Gustafsson (Sysop)
The Aaland Islands (N60 E20)


Novell has a new enhancement request system,
or what is now known as the requirement portal.
If customers would like to give input in the upcoming
releases of Novell products then they should go to
http://www.novell.com/rms

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.