wrossing Absent Member.
Absent Member.
1065 views

Strange Transfer ID issue between OES2sP3 to OES11SP2

I'm sure it is something simple but when I do a Precheck for the Transfer ID, it comes back and says "Platform not supported" The product version is blank for the source. Here is the message.

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
014-05-02 09:27:03,192 INFO - ServerIDSwap:migedir:eDirectory migration utility for Linux
2014-05-02 09:27:03,192 INFO - ServerIDSwap:migedir:Version: 2.0 for OES Linux 2.0
2014-05-02 09:27:03,192 INFO - ServerIDSwap:migedir:Copyright (c) 2007, Novell Inc. All rights reserved.
2014-05-02 09:27:03,192 INFO - ServerIDSwap:migedir:
2014-05-02 09:27:03,192 INFO - ServerIDSwap:migedir:Creating the eDirectory migration file locations...
2014-05-02 09:27:03,193 INFO - ServerIDSwap:migedir:Get the source server administrator credentials -
2014-05-02 09:27:03,193 INFO - ServerIDSwap:migedir: Enter adminDN(e.g: cn=admin.o=administrators): Enter pas
sword:
2014-05-02 09:27:03,193 INFO - ServerIDSwap:migedir:Source server, x.x.1.196 is reachable.
2014-05-02 09:27:03,193 INFO - ServerIDSwap:migedir:Product Version:
2014-05-02 09:27:03,193 INFO - ServerIDSwap:migedir:eDirectory migration is not supported on this platform, Pr
oduct Version: . The supported platforms are NetWare and OES Linux.
2014-05-02 09:27:03,193 INFO - ServerIDSwap:migedir:
2014-05-02 09:27:03,193 INFO - ServerIDSwap:migedir:stty: standard input: Invalid argument
2014-05-02 09:27:03,194 INFO - ServerIDSwap:migedir:stty: standard input: Invalid argument
2014-05-02 09:27:03,194 INFO - ServerIDSwap:migedir:stty: standard input: Invalid argument
2014-05-02 09:27:03,194 INFO - ServerIDSwap:migedir:
2014-05-02 09:27:03,194 INFO - ServerIDSwap:migedir:*****************Command output end***********************
***********
>>>>>>>>>>>>>>>>

Notes:
NSS File transfer went fine

Checked firewalls, ssh, lum - all good
ndstrace on Auth, Ldap no errors (looks like it just hits NCP port quick and comes back with the above message)

What am I missing? Thanks for any ideas...
Labels (2)
0 Likes
1 Reply
Knowledge Partner
Knowledge Partner

Re: Strange Transfer ID issue between OES2sP3 to OES11SP2

wrossing;2317701 wrote:
I'm sure it is something simple but when I do a Precheck for the Transfer ID, it comes back and says "Platform not supported" The product version is blank for the source. Here is the message.

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
014-05-02 09:27:03,192 INFO - ServerIDSwap:migedir:eDirectory migration utility for Linux
2014-05-02 09:27:03,192 INFO - ServerIDSwap:migedir:Version: 2.0 for OES Linux 2.0
2014-05-02 09:27:03,192 INFO - ServerIDSwap:migedir:Copyright (c) 2007, Novell Inc. All rights reserved.
2014-05-02 09:27:03,192 INFO - ServerIDSwap:migedir:
2014-05-02 09:27:03,192 INFO - ServerIDSwap:migedir:Creating the eDirectory migration file locations...
2014-05-02 09:27:03,193 INFO - ServerIDSwap:migedir:Get the source server administrator credentials -
2014-05-02 09:27:03,193 INFO - ServerIDSwap:migedir: Enter adminDN(e.g: cn=admin.o=administrators): Enter pas
sword:
2014-05-02 09:27:03,193 INFO - ServerIDSwap:migedir:Source server, x.x.1.196 is reachable.
2014-05-02 09:27:03,193 INFO - ServerIDSwap:migedir:Product Version:
2014-05-02 09:27:03,193 INFO - ServerIDSwap:migedir:eDirectory migration is not supported on this platform, Pr
oduct Version: . The supported platforms are NetWare and OES Linux.
2014-05-02 09:27:03,193 INFO - ServerIDSwap:migedir:
2014-05-02 09:27:03,193 INFO - ServerIDSwap:migedir:stty: standard input: Invalid argument
2014-05-02 09:27:03,194 INFO - ServerIDSwap:migedir:stty: standard input: Invalid argument
2014-05-02 09:27:03,194 INFO - ServerIDSwap:migedir:stty: standard input: Invalid argument
2014-05-02 09:27:03,194 INFO - ServerIDSwap:migedir:
2014-05-02 09:27:03,194 INFO - ServerIDSwap:migedir:*****************Command output end***********************
***********
>>>>>>>>>>>>>>>>

Notes:
NSS File transfer went fine

Checked firewalls, ssh, lum - all good
ndstrace on Auth, Ldap no errors (looks like it just hits NCP port quick and comes back with the above message)

What am I missing? Thanks for any ideas...


What is the source and target server OS?
Specifics like:
Source server is: NetWare 6.5 SP7, or OES2 SP3 32-bit Linux
Target Server is: OES11, or OES2 SP3

Normally the above only happens if you are using an older unpatched OS (on the source) or an unpatched version of the OS on the target (I think pre-OES11).

Also, if you ask this in the OES Migration forum you may get a faster/better answer (sometimes the developer checks there).

But the only time I've gotten the above error is either:
The source (ie, ancient version of NetWare) wasn't patched to the proper level
or
There WAS a bug in OES2 something (OES2 SP2 or SP3, can't remember which) where the miggui wasn't properly detecting the source OS. I THOUGHT that was fixed in OES11 and up, but not 100% sure.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.