MichaelJacobs Absent Member.
Absent Member.

TREE missing, Login possible Only After Netscan!

A wonderfully bizarre set of symptoms

I noticed a backup hadn't arrived on Friday night, from one of my customer sites.

Tried logging on to the relevant workstation and found it offline

I'm due on site Monday, it’ll wait.

On site. Workstation unresponsive. Forced a reboot.

Can’t login to Network. Specifically, can’t see the Tree, or Context, or Server.

Login Computer Only, fire up the OES Login screen. Still no Tree, Context or Server.

Perform a netscan. Both servers are right where I expect. (we have a backup server on the same Tree)

Back to the login form. Still no tree. Try Context. Yup, that’s there. And Server? Yup.

Try logging in despite absence of tree. Succeed.

Do a bit of checking and maintenance and it looks like the problem was caused by my setting the firewall rules a bit too harshly and then not being there to give relevant permissions. Sort all that out and decide to reboot to check that we’re now behaving normally.

Again, no Tree, Context or Server so login Computer only and find I have to repeat the steps above. Specifically, until I perform and netscan and force the system to accept that the Servers are still connected, I cannot see Tree, Context or Server. Post netscan I can see Context and Server and login successfully.

That’s a behaviour I’ve never come across before and haven’t a clue how to troubleshoot. It is probably worth mentioning that the other dozen or so workstations on site are still able to see the Tree as expected, so it’s only my own workstation that has suddenly decided the Tree doesn’t exist but the Context and Server do.

Labels (1)
1 Reply
Knowledge Partner Knowledge Partner
Knowledge Partner

Re: TREE missing, Login possible Only After Netscan!

Do you mean you can't BROWSE for e.g. a tree? Locating a tree this way requires a functional SLP offset, i.e. either
- at least one functional DA configured on the client
- accurate DA info handed out by means of DHCP
- client being able to find a working DA with accurate information via multi-/broadcast (depending on client config)
with the third option being rather undesired, merely being some sort of last resort.

If the server side offset doesn't fit, the client lacks proper config or some sort of firewalling interferes you won't be able to browse for a tree. You might still be able to browse for a context if you e.g. "help" the client by specifying a server's IP address in the tree field.
As for the "things work after netscan" phenomenon: this might be simply a matter of time, if e.g. an address slips into bad address cache 'cause it can't be reached at startup it might "work" magically 5 minutes later (default timeout is 300secs).
I'd check SLP offset on both server and client (including "slpinfo /a" on the latter) first and for sure start a testride on the WS with all sorts of firewalling switched off.
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.