Big news! The community will be moving to a new platform April 21. Read more.
Big news! The community will be moving to a new platform April 21. Read more.
Absent Member.
Absent Member.
2795 views

Unable to add a service using DNS/DHCP managment console

Novell DHCP running on OES11 SP2. I have 2 DHCP servers running.

After adding a third one, I see it in the management console. Naturally without service running on it. If I start it with rcnovell-dhcp, i have the following error in /var/log/rc. dhcp.log:

-------------------------------------------------------
LDAPS session successfully enabled to 172.17.xxx.xxx:636
Error: No dhcp service is associated with the server dn cn=oessal,ou=DNSDHCP,o=BIEL
Configuration file errors encountered -- exiting
-------------------------------------------------------

This is normal as no service is associated with this server.

My problem is to add a new service using the DHCP/DNS management console.

I define a new service, but nothing happens if I click the create button. Defining a current or the new DHCP server in the field does not change anything.
Labels (1)
0 Likes
20 Replies
Absent Member.
Absent Member.

BBZBiel;2405052 wrote:
Novell DHCP running on OES11 SP2. I have 2 DHCP servers running.

After adding a third one, I see it in the management console. Naturally without service running on it. If I start it with rcnovell-dhcp, i have the following error in /var/log/rc. dhcp.log:

-------------------------------------------------------
LDAPS session successfully enabled to 172.17.xxx.xxx:636
Error: No dhcp service is associated with the server dn cn=oessal,ou=DNSDHCP,o=BIEL
Configuration file errors encountered -- exiting
-------------------------------------------------------

This is normal as no service is associated with this server.

My problem is to add a new service using the DHCP/DNS management console.

I define a new service, but nothing happens if I click the create button. Defining a current or the new DHCP server in the field does not change anything.


More infos about this case:

It seems the management console is guilty about this:

If I try to move a directory agent up or down in the list (option 78 in dhcp configured options), nothing happens if I click the Up or Down button.

This problem is independent of the platform (using the managment console on windows 7 or SLES11 SP3)

Anybody having the same problems using the console?
0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

In article <BBZBiel.72h7dz@no-mx.forums.microfocus.com>, BBZBiel wrote:
> I define a new service, but nothing happens if I click the create
> button. Defining a current or the new DHCP server in the field does not
> change anything.


Make sure you only have one Locator object in the tree. Multiples can
cause this sort of confusion.



Andy of
http://KonecnyConsulting.ca in Toronto
Knowledge Partner
http://forums.novell.com/member.php/75037-konecnya
If you find a post helpful and are logged in the Web interface, please
show your appreciation by clicking on the star below. Thanks!

___
“i’ve sworn an oath of solitude til the blight is purged from these lands”
Andy of Konecny Consulting in Toronto
Knowledge Partner Profile
If you find a post helpful, click the Like button below. Thanks!
0 Likes
Absent Member.
Absent Member.

I have only one locator object.

The managment console works well for DNS and most of the DHCP.
Till now the only 2 things I cannot do is to create a new service and modify the order of the directory agents (option 78). Clicking the button "create" for service or "up" / "down" for directory agent does not change anything

konecnya;2405358 wrote:
In article <BBZBiel.72h7dz@no-mx.forums.microfocus.com>, BBZBiel wrote:
> I define a new service, but nothing happens if I click the create
> button. Defining a current or the new DHCP server in the field does not
> change anything.


Make sure you only have one Locator object in the tree. Multiples can
cause this sort of confusion.



Andy of
http://KonecnyConsulting.ca in Toronto
Knowledge Partner
http://forums.novell.com/member.php/75037-konecnya
If you find a post helpful and are logged in the Web interface, please
show your appreciation by clicking on the star below. Thanks!
0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

Hi.

Am 31.08.2015 um 08:36 schrieb BBZBiel:
>
> Novell DHCP running on OES11 SP2. I have 2 DHCP servers running.


Please make sure you patch up the servers running DHCP, and then
download and instal the latest Management Console from their http
welcome page.

Does it still fail?

CU,
--
Massimo Rosen
Novell Knowledge Partner
No emails please!
http://www.cfc-it.de
CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
0 Likes
Absent Member.
Absent Member.

The management console has the version OES11 SP2 2013 2.0.4. I think it's the latest release. The windows and the SLES console show me the same version.

mrosen;2405396 wrote:
Hi.

Am 31.08.2015 um 08:36 schrieb BBZBiel:
>
> Novell DHCP running on OES11 SP2. I have 2 DHCP servers running.


Please make sure you patch up the servers running DHCP, and then
download and instal the latest Management Console from their http
welcome page.

Does it still fail?

CU,
--
Massimo Rosen
Novell Knowledge Partner
No emails please!
http://www.cfc-it.de
0 Likes
Absent Member.
Absent Member.

Maybe i miss a point. The new DHCP server runs in a different subnet.

Exemple:
----------------------------------------------
DHCP1 address 10.10.10.2 (vlan10)

DHCP2 address 10.10.11.2 (vlan11)

The router has the following definitions for each VLAN:

vlan 10
ip address 10.10.10.1 255.255.255.0
ip helper-address 10.10.10.2

vlan 11
ip address 10.10.11.1 255.255.255.0
ip directed-broadcast
ip helper-address 10.10.10.2
------------------------------------------------------

Are the definitions for each subnet correct?

I have tried to use the management console on subnet10 en subnet 11 without success about creating a new service.
0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

Hi.

Am 03.09.2015 um 15:26 schrieb BBZBiel:
>
> The management console has the version OES11 SP2 2013 2.0.4. I think
> it's the latest release.


I do not think that version ever gets updated. The question is, when did
you patch your servers the last time, and when did you (re)instal the
management console? The most current one is hardly 2 months old.


CU,
--
Massimo Rosen
Novell Knowledge Partner
No emails please!
http://www.cfc-it.de
CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
0 Likes
Absent Member.
Absent Member.

The servers were patched yesterday and the management console reinstalled.

Nothing changed

mrosen;2405494 wrote:
Hi.

Am 03.09.2015 um 15:26 schrieb BBZBiel:
>
> The management console has the version OES11 SP2 2013 2.0.4. I think
> it's the latest release.


I do not think that version ever gets updated. The question is, when did
you patch your servers the last time, and when did you (re)instal the
management console? The most current one is hardly 2 months old.


CU,
--
Massimo Rosen
Novell Knowledge Partner
No emails please!
http://www.cfc-it.de
0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

Am 04.09.2015 um 08:36 schrieb BBZBiel:
>
> The servers were patched yesterday and the management console
> reinstalled.
>
> Nothing changed


Ok.

Can you try a different workstation, maybe as vanilla as possible?

If that doesn't help, we'll likely need a lan trace, in which case for
it to be useable, we temporarily need an unencrypted ldap connection to
the tree.

CU,
--
Massimo Rosen
Novell Knowledge Partner
No emails please!
http://www.cfc-it.de
CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
0 Likes
Absent Member.
Absent Member.

I have a LAN trace now:

Here some details about it:

The trace begins with the Management trace and stops after having clicked the Create button.

New DHCP Server : 172.170.101
Existing DHCP Servers: 172.16.0.101 and 102
Workstation with DNS/DCHP Console: 172.17.100.200

Existing Services: BBZCFP (for 172.16.0.101)
BBZCFP2( for 172.16.0.102)


mrosen;2405512 wrote:
Am 04.09.2015 um 08:36 schrieb BBZBiel:
>
> The servers were patched yesterday and the management console
> reinstalled.
>
> Nothing changed


Ok.

Can you try a different workstation, maybe as vanilla as possible?

If that doesn't help, we'll likely need a lan trace, in which case for
it to be useable, we temporarily need an unencrypted ldap connection to
the tree.

CU,
--
Massimo Rosen
Novell Knowledge Partner
No emails please!
http://www.cfc-it.de
0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

Hi.

Am 07.09.2015 um 14:36 schrieb BBZBiel:
>
> I have a LAN trace now:


Unfortunately, the zip file seems corrupt. Neither windows itself nor
7-zip can open it (it's only 52kb?)

CU,
--
Massimo Rosen
Novell Knowledge Partner
No emails please!
http://www.cfc-it.de
CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.