UPDATE! The community will be go into read-only on April 19, 8am Pacific in preparation for migration on April 21. Read more.
UPDATE! The community will be go into read-only on April 19, 8am Pacific in preparation for migration on April 21.Read more.
Absent Member.
Absent Member.
2770 views

Unable to load TSANDS on an OES11 server

for making a backup of the NDS on an OES11 server (using Arkeia), we tried to load the TSA tsands, unfortunately it responded: library not found.
smsconfig -l tsands
Is there anybody having tsands working on OES11 ?

Thanks,
Job Koopman
Labels (2)
0 Likes
5 Replies
Absent Member.
Absent Member.

It certainly loads fine for me. Does smsconfig -l show any others loaded, such as tsafs?

What does /etc/init.d/smdrd start show?

You can also manage this in iManager - SMS Backup and Restore
NetIQ Documentation: OES 11 SP1: Storage Management Services Administration Guide for Linux - Configuring SMDR
Maybe that will give clearer error info?

Andrew C Taubman (Sorry, support is not provided via e-mail) Opinions expressed above are not necessarily those of Micro Focus.
0 Likes
Absent Member.
Absent Member.

Hello Andrew,

/etc/init.d/novell-smdrd restart
gives the following in messages
Aug 30 16:05:38 delta smdrd[4960]: SMDR received SIGTERM. Going down.
Aug 30 16:05:38 delta smdrd[4960]: Target name DELTA successfully de-advertised from SLP
Aug 30 16:05:39 delta smdrd[4960]: Could not start TCP listener on 10.1.0.1
Aug 30 16:05:40 delta smdrd[4960]: Could not start UDS listener
Aug 30 16:05:40 delta smdrd[30310]: SMDR coming up
Aug 30 16:05:41 delta smdrd[30310]: Target name DELTA successfully advertised with SLP
Aug 30 16:05:42 delta smdrd[30310]: Loading TSA tsafs
Aug 30 16:05:42 delta smdrd[30310]: Module tsafs successfully loaded
Aug 30 16:05:42 delta smdrd[30310]: Loading TSA tsands
Aug 30 16:05:42 delta smdrd[30310]: Unable to open shared library libtsands.so
Aug 30 16:05:42 delta smdrd[30310]: Loading TSA tsaif
Aug 30 16:05:42 delta smdrd[30310]: NCSLIB: Error -1 opening /var/opt/novell/ncs/cluster.xml
Aug 30 16:05:42 delta smdrd[30310]: Module tsaif successfully loaded

The tsafs and tsaif load without problems.

The SLES11-SP1 + OES11 server is the result of a transfer ID migration from Netware 6.5, maybe something went wrong behind the scenes.
Is your server a direct install, without migration ?

Thanks,
Job Koopman
0 Likes
Absent Member.
Absent Member.

It's a fresh install, yes. When I search my OES11 server for libtsands.so I get 6 hits, 4 of which are links and the two real files are libtsands.so.0.0.0 , one in /opt/novell/lib and one in /opt/novell/lib64 .

Which brings up a point: Is your SLES11 and OES11 32bit or 64bit?

Andrew C Taubman (Sorry, support is not provided via e-mail) Opinions expressed above are not necessarily those of Micro Focus.
0 Likes
Fleet Admiral
Fleet Admiral

On 05/09/2012 00:46, ataubman wrote:

> It's a fresh install, yes. When I search my OES11 server for
> libtsands.so I get 6 hits, 4 of which are links and the two real files
> are libtsands.so.0.0.0 , one in /opt/novell/lib and one in
> /opt/novell/lib64 .
>
> Which brings up a point: Is your SLES11 and OES11 32bit or 64bit?


OES11 is 64-bit only ...

HTH.
--
Simon
Novell/SUSE/NetIQ Knowledge Partner

------------------------------------------------------------------------
Do you work with Novell technologies at a university, college or school?
If so, your campus could benefit from joining the Novell Technology
Transfer Partner (TTP) program. See novell.com/ttp for more details.
------------------------------------------------------------------------
0 Likes
Absent Member.
Absent Member.

On Wed, 05 Sep 2012 13:39:38 +0000, Simon Flood wrote:

> On 05/09/2012 00:46, ataubman wrote:
>
>> It's a fresh install, yes. When I search my OES11 server for
>> libtsands.so I get 6 hits, 4 of which are links and the two real files
>> are libtsands.so.0.0.0 , one in /opt/novell/lib and one in
>> /opt/novell/lib64 .
>>
>> Which brings up a point: Is your SLES11 and OES11 32bit or 64bit?

>
> OES11 is 64-bit only ...
>
> HTH.


you may also check if you are running GroupWise on your server and have
ConsoleOne installed here.

If this happens to be a very old version of ConsoleOne, that may be a
reason as to why tsands cannot be loaded, and simply updating to a later
version of ConsoleOne makes loading tsands also happy again

hth
Hans

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.