Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
Anonymous_User Absent Member.
Absent Member.
312 views

Upgrade to OES2018SP1 needs SLES-LTSS-12.2?

Hi,

I try to upgrade OES2018 to OES2018SP1. A local SMT-Service is fresh
mirrored, up and running.

After I run all upDATEs (include reboot), install the migration product
(which is visible at the SMT-Server), I run the final upGRADE:

# zypper dup --from OES2018-SP1-SLES12-SP3-Pool --from
OES2018-SP1-SLES12-SP3-Updates --from OES2018-SP1-Pool --from
OES2018-SP1-Updates --from OES2018-SP1-SLE-Module-Containers12-Pool
--from OES2018-SP1-SLE-Module-Containers12-Updates
Refreshing service 'SMT-http_local_tld'.
Loading repository data...
Reading installed packages...
Computing distribution upgrade...
2 Problems:
Problem: product:SLES-LTSS-12.2-0.x86_64 requires product(SUSE_SLE) =
12.2, but this requirement cannot be provided
Problem: product:SLES-LTSS-12.2-0.x86_64 requires product(SLES-LTSS) =
12.2-0, but this requirement cannot be provided

Problem: product:SLES-LTSS-12.2-0.x86_64 requires product(SUSE_SLE) =
12.2, but this requirement cannot be provided
uninstallable providers:
Open_Enterprise_Server-release-2018-1.319.x86_64[SMT-http_local_tld:OES2018-Pool]

product:SLES-12.2-0.x86_64[SMT-http_local_tld:OES2018-SLES12-SP2-Pool]
Solution 1: Following actions will be done:
install product:SLES-12.2-0.x86_64 from excluded repository
deinstallation of product:Open_Enterprise_Server-2018-0.x86_64
deinstallation of product:Open_Enterprise_Server-2018-0.x86_64
Solution 2: deinstallation of product:SLES-LTSS-12.2-0.x86_64
Solution 3: keep obsolete product:Open_Enterprise_Server-2018-0.x86_64
Solution 4: break sles-ltss-release-12.2-8.4.1.x86_64 by ignoring some
of its dependencies

Choose from above solutions by number or skip, retry or cancel
[1/2/3/4/s/r/c] (c):

Ooops, any hints?

# zypper se -t product
Refreshing service 'SMT-http_local_tld'.
Loading repository data...
Reading installed packages...

S | Name | Summary
| Type
---+--------------------------------------+---------------------------------------------------------+--------
i+ | Open_Enterprise_Server | Open Enterprise Server 2018
SP1 | product
i+ | Open_Enterprise_Server-SP1-migration | Open_Enterprise_Server
Service Pack 1 Migration Product | product
| SLES | SUSE Linux Enterprise
Server 12 SP3 | product
i+ | SLES-LTSS | SUSE Linux Enterprise Server
12 SP2 LTSS | product
| sle-module-containers | Containers module
| product

AFAIK I have never installed SLES-LTSS. This was a plain OES2018
installation before.

It i save to choose Solution 2: deinstallation of
product:SLES-LTSS-12.2-0.x86_64 ?

Bernd
Labels (2)
0 Likes
2 Replies
Anonymous_User Absent Member.
Absent Member.

Re: Upgrade to OES2018SP1 needs SLES-LTSS-12.2?

Just for the records ...

Am 05.03.19 um 14:57 schrieb nntp-user:
> Hi,
>
> I try to upgrade OES2018 to OES2018SP1. A local SMT-Service is fresh
> mirrored, up and running.
>
> After I run all upDATEs (include reboot), install the migration product
> (which is visible at the SMT-Server), I run the final upGRADE:
>
> # zypper dup --from OES2018-SP1-SLES12-SP3-Pool --from
> OES2018-SP1-SLES12-SP3-Updates --from OES2018-SP1-Pool --from
> OES2018-SP1-Updates --from OES2018-SP1-SLE-Module-Containers12-Pool
> --from OES2018-SP1-SLE-Module-Containers12-Updates
> Refreshing service 'SMT-http_local_tld'.
> Loading repository data...
> Reading installed packages...
> Computing distribution upgrade...
> 2 Problems:
> Problem: product:SLES-LTSS-12.2-0.x86_64 requires product(SUSE_SLE) =
> 12.2, but this requirement cannot be provided
> Problem: product:SLES-LTSS-12.2-0.x86_64 requires product(SLES-LTSS) =
> 12.2-0, but this requirement cannot be provided
>
> Problem: product:SLES-LTSS-12.2-0.x86_64 requires product(SUSE_SLE) =
> 12.2, but this requirement cannot be provided
>   uninstallable providers:
> Open_Enterprise_Server-release-2018-1.319.x86_64[SMT-http_local_tld:OES2018-Pool]
>
>
> product:SLES-12.2-0.x86_64[SMT-http_local_tld:OES2018-SLES12-SP2-Pool]
>  Solution 1: Following actions will be done:
>   install product:SLES-12.2-0.x86_64 from excluded repository
>   deinstallation of product:Open_Enterprise_Server-2018-0.x86_64
>   deinstallation of product:Open_Enterprise_Server-2018-0.x86_64
>  Solution 2: deinstallation of product:SLES-LTSS-12.2-0.x86_64
>  Solution 3: keep obsolete product:Open_Enterprise_Server-2018-0.x86_64
>  Solution 4: break sles-ltss-release-12.2-8.4.1.x86_64 by ignoring some
> of its dependencies
>
> Choose from above solutions by number or skip, retry or cancel
> [1/2/3/4/s/r/c] (c):
>
> Ooops, any hints?
>



Yes, choose solution 2 (two times). After this the upgrade runs without
any problem.


Bernd

0 Likes
Knowledge Partner
Knowledge Partner

Re: Upgrade to OES2018SP1 needs SLES-LTSS-12.2?

On 06.03.2019 11:16, nntp-user wrote:
> Just for the records ...
>
>
> Yes, choose solution 2 (two times). After this the upgrade runs without
> any problem.


Thanks for the report back. And yes, that channel has no business
existing on OES2018, no idea where it came from.

CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.