Anonymous_User Absent Member.
Absent Member.
1205 views

User authorisation to iFolder

Hello ,

We have situation when some users can't start using iFolder due authorization problems.
All users iFolder configuration is the same as others users in this container.
When user try to login into iFolder server first time he (she) receive message:

You are not authorized to use iFolder;

On iFolder server console we received message:

05/17/04 16:47:42 LOCATE_SERVER kreslins unprovisioned user
05/17/04 16:53:54 LOCATE_SERVER vainovsk unprovisioned user

The issue occurs with some "old" and also with some new created users in this container.

Is it any idea ?

Thank you in advance,

Valdis
Labels (1)
0 Likes
7 Replies
Anonymous_User Absent Member.
Absent Member.

Re: User authorisation to iFolder

Valdis Jaunzeikars,
> Is it any idea ?
>

Can we get an LDAP trace when this happens?

- Anders Gustafsson, Engineer, CNE6, ASE
NSC Volunteer Sysop (http://support-forums.novell.com)
Pedago, The Aaland Islands (N60 E20)
Using VA 4.52 build 277 (32-bit) on Windows 2000 build 2195

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: User authorisation to iFolder

Hello Anders,

Here you are small fragment from ldap trace:


Search request:
base: "OU=LSC,O=LATSHIP"
scope:2 derefence:0 sizelimit:0 timelimit:10 attrsonly:0
filter: "(cn=kishkurn)"
attribute: "cn"
Sending search result entry "cn=Kishkurn,ou=LSC,o=LATSHIP" to connection 0xc304a560
Sending operation result 0:"":"" to connection 0xc304a560
DoBind on connection 0xbe76aa60
DoBind: name = 'cn=Kishkurn,ou=LSC,o=LATSHIP', client version = 3, method = 0x80
Sending operation result 0:"":"" to connection 0xbe76aa60
DoSearch on connection 0xc304a560
Search request:
base: "cn=Kishkurn,ou=LSC,o=LATSHIP"
scope:0 derefence:0 sizelimit:0 timelimit:20 attrsonly:0
filter: "(objectClass=iFolderUser)"
DDCReadStream failed in WGetLDAPStreamValue, err = -649
Sending search result entry "cn=Kishkurn,ou=LSC,o=LATSHIP" to connection 0xc304a560
Searching "": NDS error:-649 returned.
LDAPSearchToCB failed, err = -649
Sending operation result 80:"":"NDS error: insufficient buffer (-649)" to connection 0xc304a560
DoSearch on connection 0xc304a960
Search request:
base: "OU=LSC,O=LATSHIP"
scope:2 derefence:0 sizelimit:0 timelimit:10 attrsonly:0
filter: "(cn=kishkurn)"
attribute: "cn"
Sending search result entry "cn=Kishkurn,ou=LSC,o=LATSHIP" to connection 0xc304a960
Sending operation result 0:"":"" to connection 0xc304a960
DoBind on connection 0xbe76a560
DoBind: name = 'cn=Kishkurn,ou=LSC,o=LATSHIP', client version = 3, method = 0x80
Sending operation result 0:"":"" to connection 0xbe76a560
DoSearch on connection 0xc304a960
Search request:
base: "cn=Kishkurn,ou=LSC,o=LATSHIP"
scope:0 derefence:0 sizelimit:0 timelimit:20 attrsonly:0
filter: "(objectClass=iFolderUser)"
DDCReadStream failed in WGetLDAPStreamValue, err = -649
Sending search result entry "cn=Kishkurn,ou=LSC,o=LATSHIP" to connection 0xc304a960
Searching "": NDS error:-649 returned.
LDAPSearchToCB failed, err = -649
Sending operation result 80:"":"NDS error: insufficient buffer (-649)" to connection 0xc304a960
Found available monitor 0x19c
New TCP connection 0xbe76ad60, monitor = 0x19c, index = 10
DoBind on connection 0xbe76ad60
DoBind: name = 'cn=iFolder_ServerAgent,OU=LSC,O=LATSHIP', client version = 3, method = 0x80
Sending operation result 0:"":"" to connection 0xbe76ad60
DoUnbind on connection 0xbe76ad60
Found available monitor 0x19c
New TCP connection 0xbe76ad60, monitor = 0x19c, index = 10
DoBind on connection 0xbe76ad60


The same for others unauthorized users.

Best regards,

Valdis
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: User authorisation to iFolder

Valdis Jaunzeikars,
> Sending search result entry "cn=Kishkurn,ou=LSC,o=LATSHIP" to connection 0xc304a560
> Searching "": NDS error:-649 returned.
> LDAPSearchToCB failed, err = -649


OK. Here is where things go bad:
Searching "": NDS error:-649 returned.
LDAPSearchToCB failed, err = -649
Sending operation result 80:"":"NDS error: insufficient buffer (-649)" to connection
0xc304a560

I forgot to ask: what version of NetWare and servicepacks. What version of iFolder?

There seems to be a TID that matches your problem though:
http://support.novell.com/cgi-bin/search/searchtid.cgi?/10086422.htm

How is the weather in Riga BTW? I am only a couple of hundred nautical miles NNW of
you 😉 Been there once (1994).

- Anders Gustafsson, Engineer, CNE6, ASE
NSC Volunteer Sysop (http://support-forums.novell.com)
Pedago, The Aaland Islands (N60 E20)
Using VA 4.52 build 277 (32-bit) on Windows 2000 build 2195

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: User authorisation to iFolder

Hello Andres,

Thank you for so quick answer:
Our NW version is NW 6.0 with SP3, iFolder 2.1

The weather ir Riga is cold for this time cloudy, rain and about 10 C.
How you like Riga at 1994, so many are change since 1994 !!

I will try to fix problem with you recommended TID and I will inform you about results.

Thank you,

Valdis
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: User authorisation to iFolder

Valdis Jaunzeikars,
> Thank you for so quick answer:
> Our NW version is NW 6.0 with SP3, iFolder 2.1
>
> The weather ir Riga is cold for this time cloudy, rain and about 10 C.
> How you like Riga at 1994, so many are change since 1994 !!


I found Riga a very fascinating place. So much history, even if we only had one day
there. We also went out to the beach at Jurmala. Maybe I will come back some day.

> I will try to fix problem with you recommended TID and I will inform you about results.
>

Yes. Try that patch and post back your results.

- Anders Gustafsson, Engineer, CNE6, ASE
NSC Volunteer Sysop (http://support-forums.novell.com)
Pedago, The Aaland Islands (N60 E20)
Using VA 4.52 build 277 (32-bit) on Windows 2000 build 2195

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: User authorisation to iFolder

Hello Andres,

I regret to say that installation of patch had not been successful. Maybe reason was that EDIR862SP4.EXE don't exist on Novell site. I tried to install EDIR862SP6.EXE
After that problems with LDAP server occur and we roll back to our previouse state.
Unfortunately I have only iFolder log, but in LDAP trace on server console the main idea of error messages was, that new executables modules of new version can not working with NDS object (LDAP server ?, LDAP Group object ? 😞

05/18/04 21:49:49 ldap *MASTER[128.1.130.4] down
05/18/04 21:50:47 *MASTER[128.1.130.4][-1] ldap_simple_bind : Can't contact LDAP server(81)
05/18/04 21:50:47 ldap *MASTER[128.1.130.4] down
05/18/04 21:51:45 *MASTER[128.1.130.4][-1] ldap_simple_bind : Can't contact LDAP server(81)
05/18/04 21:51:45 ldap *MASTER[128.1.130.4] down
05/18/04 21:52:43 *MASTER[128.1.130.4][-1] ldap_simple_bind : Can't contact LDAP server(81)
05/18/04 21:52:43 ldap *MASTER[128.1.130.4] down
05/18/04 21:53:40 *MASTER[128.1.130.4][-1] ldap_simple_bind : Can't contact LDAP server(81)
05/18/04 21:53:40 ldap *MASTER[128.1.130.4] down
05/18/04 21:54:38 *MASTER[128.1.130.4][-1] ldap_simple_bind : Can't contact LDAP server(81)
05/18/04 21:54:38 ldap *MASTER[128.1.130.4] down
05/18/04 21:55:36 *MASTER[128.1.130.4][-1] ldap_simple_bind : Can't contact LDAP server(81)
05/18/04 21:55:36 ldap *MASTER[128.1.130.4] down
05/18/04 21:56:33 *MASTER[128.1.130.4][-1] ldap_simple_bind : Can't contact LDAP server(81)
05/18/04 21:56:33 ldap *MASTER[128.1.130.4] down
05/18/04 21:57:31 *MASTER[128.1.130.4][-1] ldap_simple_bind : Can't contact LDAP server(81)
05/18/04 21:57:31 ldap *MASTER[128.1.130.4] down
05/18/04 21:58:29 *MASTER[128.1.130.4][-1] ldap_simple_bind : Can't contact LDAP server(81)
05/18/04 21:58:29 ldap *MASTER[128.1.130.4] down
05/18/04 21:59:27 *MASTER[128.1.130.4][-1] ldap_simple_bind : Can't contact LDAP server(81)
05/18/04 21:59:27 ldap *MASTER[128.1.130.4] down
05/18/04 22:00:24 *MASTER[128.1.130.4][-1] ldap_simple_bind : Can't contact LDAP server(81)
05/18/04 22:00:24 ldap *MASTER[128.1.130.4] down
05/18/04 22:01:22 *MASTER[128.1.130.4][-1] ldap_simple_bind : Can't contact LDAP server(81)
05/18/04 22:01:22 ldap *MASTER[128.1.130.4] down

I understand that problem is in e-directory not in iFolder in itself.
Maybe installation of SP4 or latest versions of e-Directory could resolve this issue ?

Best regards,

Valdis
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: User authorisation to iFolder

Valdis Jaunzeikars,
> I regret to say that installation of patch had not been successful. Maybe reason was that EDIR862SP4.EXE don't exist on Novell site. I tried to install EDIR862SP6.EXE
> After that problems with LDAP server occur and we roll back to our previouse state.


Ah, yes. When you upgrade Edir you must make sure that "Require TLS for simple binds" is Not selected. Please see:
http://support.novell.com/cgi-bin/search/searchtid.cgi?/10080365.htm

- Anders Gustafsson, Engineer, CNE6, ASE
NSC Volunteer Sysop (http://support-forums.novell.com)
Pedago, The Aaland Islands (N60 E20)
Using VA 4.52 build 277 (32-bit) on Windows 2000 build 2195

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.