Anonymous_User Absent Member.
Absent Member.

User does not exist within specified context

Hello all

Have a strange problem that I haven't seen before. We are running
netware 6 SP5. One netware server at the site concerned, We also have
2 Windows 2003 servers that run edirectory as well. The two windows
servers are set up to provide LDAP contextless login- the novell
client is configured to query these two servers for the user's
context. These 3 servers have a replica of root and the partition with
this user object in it. We also have about 10 satellite offices with a
NW6 SP5 server each (but they don't have a replica of root or the
partition that contains this user object).

It appears that when I create a new user in edirectory, they aren't
being created properly. I made a new user object but it would not log
in, with the same message you would have got if your context was set
incorrectly or your password was wrong. Howeer the LDAP contextless
login found the object and set the context correctly. I then logged in
as myself and looked at the login results screen, and the problem user
was denied access because "The user does not exist within the
specified context". Console one and NWADMIN both show the user in the
correct context and I can edit/delete the user no problems. I tried
deleting and recreating the user with a slightly different name, same
result. I left that one there and made a user called TESTER and had
the same result as well.

The netware server doesn't seem to have a problem with its licence
(according to VERSION anyway) and all three servers that have a
replica of this partition that contains the user in question are
assingned licence objects in NWADMIN. I also have at least 4 available
user licences according to NWADMIN.

I ran DSTRACE as per on the netware
server and it appears that the servers are synchronizing each other. I have
run DSREPAIR both local database and unatended full repair on these 3
servers but no luck.

Any ideas?

Recently one of our IT staff left and we had to reset all passwords- I
didn't reset mine though, and I have made users when logged in as
myself before, withough any problems (which is what I am doing in this
case as well).

Labels (2)
1 Reply
Anonymous_User Absent Member.
Absent Member.

Re: User does not exist within specified context

I still think you have an NDS synchronization issue even though you may
not see DSTRACE errors. I suggest you run DSREPAIR on your various servers
in in DSREPAIR, you use both the options to check the tome synchronization
and to check the synchronization status. See if any errors for any of the
2 options are reported and also check the last synchronization times for
your replicas in the synchronization status.

Marcel Cox (using XanaNews
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.