Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
Anonymous_User Absent Member.
Absent Member.
3612 views

XP SP2 / 4.91 sp1 / AutoAdminLogon Doesn't work as advertised

Computer: fresh install of WinXSP, SP2 w/ all patches in workgroup mode

Client: 4.91sp1, NMAS not installed (due to TID:
http://support.novell.com/cgi-bin/search/searchtid.cgi?10083978.htm )

Objective: Have AutoAdmin login to XP and have user manually login to NDS

From TID:
http://support.novell.com/cgi-bin/search/searchtid.cgi?10052847.htm
Used these four Reg changes:
HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\WinLogon\AutoAdminLogon =
1
HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\WinLogon\DefaultPassword =
NTpassword
HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\WinLogon\DefaultUserName =
Administrator
HKLM\Software\Microsoft\WindowsNT\CurrentVersion\Winlogon\ForceAutoLogon=1

Auto-Admin works perfrectly, except it works TOO good....Upon reboot, it
logs in to the computer to the Administrator user as if the NW client wasn't
even on the machine! Only manually logging on to NDS via the big red "N" is
the only option. Even if the "Initial Client Login" option is set to On. I
verified that the GINA points to NWGINA.DLL at all times.

Updated the NWGINA.DLL from
http://support.novell.com/cgi-bin/search/searchtid.cgi?2972510.htm but still
no luck.

Once the AutoAdmin Logon and Force AutoLogon entries are removed, client32
works properly and comes up as the first login authenticator, but of course,
Auto-Admin login doesn't work.

Any help is greatly appreciated!!!

TIA,
Mike


Labels (1)
0 Likes
5 Replies
Anonymous_User Absent Member.
Absent Member.

Re: XP SP2 / 4.91 sp1 / AutoAdminLogon Doesn't work as advertised

Have you added these keys per the TID?

HKLM\Software\Novell\Login\AutoAdminLogon = 0
HKLM\Software\Novell\Login\AutoAdminQueryNDS = 1 NOTE: This has to be a
DWORD registry key. Creating it as a string will break the NDS login
completely.

--
Craig Wilson
Novell Product Support Forum Sysop
Master CNE, MCSE 2003, CCNA

Editor - http://www.ithowto.com

(Seeking Full-Time Expert? Drop me a note 😆 )


"Mike M" <nospam@nospam.com> wrote in message
news:I5ecf.2826$u%.2693@prv-forum2.provo.novell.com...
> Computer: fresh install of WinXSP, SP2 w/ all patches in workgroup mode
>
> Client: 4.91sp1, NMAS not installed (due to TID:
> http://support.novell.com/cgi-bin/search/searchtid.cgi?10083978.htm )
>
> Objective: Have AutoAdmin login to XP and have user manually login to NDS
>
> From TID:
> http://support.novell.com/cgi-bin/search/searchtid.cgi?10052847.htm
> Used these four Reg changes:
> HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\WinLogon\AutoAdminLogon
> = 1
> HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\WinLogon\DefaultPassword
> = NTpassword
> HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\WinLogon\DefaultUserName
> = Administrator
> HKLM\Software\Microsoft\WindowsNT\CurrentVersion\Winlogon\ForceAutoLogon=1
>
> Auto-Admin works perfrectly, except it works TOO good....Upon reboot, it
> logs in to the computer to the Administrator user as if the NW client
> wasn't even on the machine! Only manually logging on to NDS via the big
> red "N" is the only option. Even if the "Initial Client Login" option is
> set to On. I verified that the GINA points to NWGINA.DLL at all times.
>
> Updated the NWGINA.DLL from
> http://support.novell.com/cgi-bin/search/searchtid.cgi?2972510.htm but
> still no luck.
>
> Once the AutoAdmin Logon and Force AutoLogon entries are removed, client32
> works properly and comes up as the first login authenticator, but of
> course, Auto-Admin login doesn't work.
>
> Any help is greatly appreciated!!!
>
> TIA,
> Mike
>



0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: XP SP2 / 4.91 sp1 / AutoAdminLogon Doesn't work as advertised

Might wanna try this as an easy workaround:

http://www.novell.com/coolsolutions/tools/13525.html


--
Best Regards

Tommy Mikkelsen

IT Quality A/S
Denmark

Novell Support Forums SYSOP

Please Report back any success or failure, That way we all learn

Sorry, but no support through email

"I hate bugs".......Tommy Lee Jones, MIB

Be a GroupWiseR, go http://www.groupwiser.net
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: XP SP2 / 4.91 sp1 / AutoAdminLogon Doesn't work as advertised

I followed the MS document about using forceautologon. Interesting to note
that this entry disappears from the registry. After adding both of those
additional reg entries. It works!

Now another question has risen up: Using remote desktop, the RDP user is
presented with Windows authentication credentials to log in. This would be
confusing for them to deal with the local user name & password. Is there a
way to force RDP to use NW/NDS authentication rather than Windows auth? I
remember seeing this as an option o our Domain-level PC's with Client32
installed, but I can't find it after digging around for a while.






"craig wilson" <craig_d_wilson@yahoo.com> wrote in message
news:FEecf.2835$u%.1738@prv-forum2.provo.novell.com...
> Have you added these keys per the TID?
>
> HKLM\Software\Novell\Login\AutoAdminLogon = 0
> HKLM\Software\Novell\Login\AutoAdminQueryNDS = 1 NOTE: This has to be a
> DWORD registry key. Creating it as a string will break the NDS login
> completely.
>
> --
> Craig Wilson
> Novell Product Support Forum Sysop
> Master CNE, MCSE 2003, CCNA



0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: XP SP2 / 4.91 sp1 / AutoAdminLogon Doesn't work as advertised

> Now another question has risen up: Using remote desktop, the RDP user is
> presented with Windows authentication credentials to log in. This would be
> confusing for them to deal with the local user name & password. Is there a
> way to force RDP to use NW/NDS authentication rather than Windows auth?


For Remote Desktop, in 4.91 and later /if there is someone already
using the desktop session/, the prompt you will see at the console or
in a terminal session to let you "take over" the existing session will
only prompt for Windows credentials.

(If the session is not in use, i.e. no one is currently logged on to
or using the machine, the login dialog you see in Remote Desktop will
be "normal", i.e. allowing you to start a new Windows session logging
in with both NDS and Windows credentials.)

Some of the mechanism and discussion of "why" was recently discussed
here:
http://groups.google.com/group/novell.support.netware.client.winnt-2x-xp/browse_frm/thread/860f38f3ab9ea97b/ded275cd70afb37d

Alan Adams
alancrumbadams@drcrumb.com
(for email, remove the crumbs)
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: XP SP2 / 4.91 sp1 / AutoAdminLogon Doesn't work as advertised

Alan,

That's incredibly informative! Thank you!

The only issue with that, testing scenarios moving away from an A/D
environment, is that end users will need to know the local login account and
password. That's going to be confusing for them.

I guess the easiset path to take aside from AutoAdmin login is using ZFD
with DLU. That introduces other administrative issues, but at least the
end-user experience is simplified.



Thanks for everyone's help!
Mike


0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.