Coziroyc Absent Member.
Absent Member.
2353 views

cannot login to Netstorage

I have a NW 6.5 SP6 server that I use Netstorage on to access files over the internet. A while back I had to renew certificates since they expired after 2 years. Since that time I have not been able to login to Netstorage. I tried to uninstall and reinstall Netstorage but it did not help yet. I am trying to read what to do to configure it, etc. but I am not having much luck. Can someone point me in the right direction.
Also, if iFolder is a better option, I do have that product to, but I have never tried to use it yet.
Labels (1)
0 Likes
13 Replies
phxazcraig Absent Member.
Absent Member.

Re: cannot login to Netstorage

In article <Coziroyc.3j8ljc@no-mx.forums.novell.com>, Coziroyc wrote:
> Since that time I have not been able to login to
> Netstorage. I tried to uninstall and reinstall Netstorage but it did
> not help yet. I am trying to read what to do to configure it, etc. but
> I am not having much luck. Can someone point me in the right
> direction.


If you are still having issues, keep posting and we'll work on it.
Expired certs are usually easy to fix. There are two steps - fix the
certs in NDS, which will help apache. Then export the fixed certs to a
key file for tomcat. Use PKIDIAG to do the first part, and then follow
that with the tckeygen command. Afterwards, restart the server, or
restart apache2 and tomcat4/tomcat5. (Might have to restart NLDAP as
well).

> Also, if iFolder is a better option, I do have that product to, but I
> have never tried to use it yet.
>

Generally speaking, iFolder is not a substitute for Netstorage.
Netstorage is a web-based way to access files on servers. IFolder is a
way to synchronize some personal files across PC's, and it just happens
to have a web component (currently via Netstorage, for iFolder 2.x).

Craig Johnson
Novell Support Connection SysOp

0 Likes
Coziroyc Absent Member.
Absent Member.

Re: cannot login to Netstorage

phxazcraig;1685609 wrote:
In article <Coziroyc.3j8ljc@no-mx.forums.novell.com>, Coziroyc wrote:
> Since that time I have not been able to login to
> Netstorage. I tried to uninstall and reinstall Netstorage but it did
> not help yet. I am trying to read what to do to configure it, etc. but
> I am not having much luck. Can someone point me in the right
> direction.


If you are still having issues, keep posting and we'll work on it.
Expired certs are usually easy to fix. There are two steps - fix the
certs in NDS, which will help apache. Then export the fixed certs to a
key file for tomcat. Use PKIDIAG to do the first part, and then follow
that with the tckeygen command. Afterwards, restart the server, or
restart apache2 and tomcat4/tomcat5. (Might have to restart NLDAP as
well).

> Also, if iFolder is a better option, I do have that product to, but I
> have never tried to use it yet.
>

Generally speaking, iFolder is not a substitute for Netstorage.
Netstorage is a web-based way to access files on servers. IFolder is a
way to synchronize some personal files across PC's, and it just happens
to have a web component (currently via Netstorage, for iFolder 2.x).

Craig Johnson
Novell Support Connection SysOp


I ran the tckeygen command and I think that has fixed some ldap issues, etc. I am still not able to use Netstorage. I am using http://serverip/netstorage which is what used to work. I was wondering if there is a way to verify that Netstorage is installed properly or to find what path I should use to run it, if it has changed. In NWConfig it says I have iStorage 2.0.1 installed. I just thought of this, do I need to reinstall SP6 since I reinstalled Netstorage?
0 Likes
phxazcraig Absent Member.
Absent Member.

Re: cannot login to Netstorage

In article <Coziroyc.3je4lz@no-mx.forums.novell.com>, Coziroyc wrote:
> I just thought of this, do I
> need to reinstall SP6 since I reinstalled Netstorage?
>

I don't think it would hurt.

Personally, I'd just go to SP7, unless you have a good reason not to.
(Some known incompatibility). If you go to SP7, put on tcp681k,
nwlib6l, wsock6o and ss206 afterwards.

Craig Johnson
Novell Support Connection SysOp
*** For some iFolder tips, go to
http://www.craigjconsulting.com/ifolder.html ***

0 Likes
Coziroyc Absent Member.
Absent Member.

Re: cannot login to Netstorage

I got busy with other things so I am sorry for the long delay. I installed sp7 and I tried to find the files that you listed. I do not have Border Manager running on this machine. I reextended schema in NWConfig. 2 files I could not find out anything about or where to get them.
If I comment my second line of xsrv.nlm as below, then my web server loads fine, but Netstorage does not work. It gives the NetStorage screen with no login and says server error (possibly overload or CGI script error)

<IfModule !mod_xsrv.c>
# LoadModule xsrv_module modules/mod_xsrv.nlm

If I uncomment this line, then Apache2 fails to load and refers to a syntax error (unknown symbol) in this line.

Thanks for any help.
0 Likes
phxazcraig Absent Member.
Absent Member.

Re: cannot login to Netstorage

In article <Coziroyc.3l7cao@no-mx.forums.novell.com>, Coziroyc wrote:
> <IfModule !mod_xsrv.c>
> # LoadModule xsrv_module modules/mod_xsrv.nlm



>

This is in the netstorage folder, file xsrv.conf?

The syntax looks like it matches mine, unless you have a hidden
character on the line somehow.

There is more to that file, correct? Can you post the rest so I can
have a quick look at it?

In sys:apache2/modules is there a mod_xsrv.nlm file?



Craig Johnson
Novell Support Connection SysOp

0 Likes
Coziroyc Absent Member.
Absent Member.

Re: cannot login to Netstorage

The rest of the file is below. There is a mod_xsrv.nlm file in the sys:apache2/modules folder.

<IfModule !mod_xsrv.c>
# LoadModule xsrv_module modules/mod_xsrv.nlm
</IfModule>
#LoadModule xsrv_module modules/mod_xsrv.nlm

#

<Location /oneNet>
AllowOverride AuthConfig
AuthType Novell
AuthName "AuthXTier"
require valid-user
SetHandler XSrv
Order deny,allow
Allow from all
</Location>


# The following section makes /vo/servlet a protected resource.
<Location /vo/servlet>
AllowOverride AuthConfig
AuthType Novell
AuthName "AuthXTier"
require valid-user
Order deny,allow
Allow from all
</Location>

# The following lines makes apache aware of the location of the /NetStorage context
Alias /NetStorage "sys:/tomcat/4/webapps/netstorage"
Alias /netstorage "sys:/tomcat/4/webapps/netstorage"
<Directory "sys:/tomcat/4/webapps/netstorage">
Options +MultiViews
AllowOverride None
Order deny,allow
Allow from all
</Directory>

# The following line mounts all JSP files and the /servlet/ uri to tomcat
JkMount /NetStorage/servlet/* ajp13
JkMount /NetStorage/*.jsp ajp13

# The following section makes /NetStorage/servlet a protected resource.
<Location /NetStorage/servlet>
AllowOverride AuthConfig
AuthType Novell
AuthName "AuthXTier"
require valid-user
Order deny,allow
Allow from all
</Location>

# The following line prohibits users from directly accessing WEB-INF
<Location "/NetStorage/WEB-INF/">
AllowOverride None
deny from all
</Location>

# Use Directory too. On Windows, Location doesn't work unless case matches
<Directory "sys:/tomcat/4/webapps/netstorage/webapp/WEB-INF/">
AllowOverride None
deny from all
</Directory>

# The following line prohibits users from directly accessing META-INF
<Location "/NetStorage/META-INF/">
AllowOverride None
deny from all
</Location>

# Use Directory too. On Windows, Location doesn't work unless case matches
<Directory "sys:/tomcat/4/webapps/netstorage/webapp/META-INF/">
AllowOverride None
deny from all
</Directory>


AddLanguage zh-tw .zh-tw
AddLanguage zh-cn .zh-cn
0 Likes
phxazcraig Absent Member.
Absent Member.

Re: cannot login to Netstorage

In article <Coziroyc.3l8t2p@no-mx.forums.novell.com>, Coziroyc wrote:
> The rest of the file is below. There is a mod_xsrv.nlm file in the
> sys:apache2/modules folder.
>
> <IfModule !mod_xsrv.c>
> # LoadModule xsrv_module modules/mod_xsrv.nlm
> </IfModule>
> #LoadModule xsrv_module modules/mod_xsrv.nlm
>

Ok, this looks like it matches mine, and the above lines definitely
match.

I just don't see a syntax error in the above lines. (Can anyone else
spot something?)

Can you manually type the same thing under the commented line, and see
if it works, or if the error message moves to the new line? As in:

> <IfModule !mod_xsrv.c>
> # LoadModule xsrv_module modules/mod_xsrv.nlm

LoadModule xsrv_module modules/mod_xsrv.nlm
> </IfModule>



Hmm - I was also concentrating on the syntax error you mentioned, but
maybe what this really means is a public symbol error, and not a syntax
error at all. That is, the syntax in the file is fine, but the version
of mod_xsrv.nlm might be mismatched to some other module.

Perhaps the thing to try here would be to get an overlay CD of NW65SP7
(both product and OS cd's), and use them to reinstall Netstorage. That
should copy all the related modules together, and hopefully update any
conf files as needed.

Craig Johnson
Novell Support Connection SysOp

0 Likes
Coziroyc Absent Member.
Absent Member.

Re: cannot login to Netstorage

phxazcraig;1707904 wrote:
In article <Coziroyc.3l8t2p@no-mx.forums.novell.com>, Coziroyc wrote:
> The rest of the file is below. There is a mod_xsrv.nlm file in the
> sys:apache2/modules folder.
>
> <IfModule !mod_xsrv.c>
> # LoadModule xsrv_module modules/mod_xsrv.nlm
> </IfModule>
> #LoadModule xsrv_module modules/mod_xsrv.nlm
>

Ok, this looks like it matches mine, and the above lines definitely
match.

I just don't see a syntax error in the above lines. (Can anyone else
spot something?)

Can you manually type the same thing under the commented line, and see
if it works, or if the error message moves to the new line? As in:

> <IfModule !mod_xsrv.c>
> # LoadModule xsrv_module modules/mod_xsrv.nlm

LoadModule xsrv_module modules/mod_xsrv.nlm
> </IfModule>



Hmm - I was also concentrating on the syntax error you mentioned, but
maybe what this really means is a public symbol error, and not a syntax
error at all. That is, the syntax in the file is fine, but the version
of mod_xsrv.nlm might be mismatched to some other module.

Perhaps the thing to try here would be to get an overlay CD of NW65SP7
(both product and OS cd's), and use them to reinstall Netstorage. That
should copy all the related modules together, and hopefully update any
conf files as needed.

Craig Johnson
Novell Support Connection SysOp


I have sp7 downloaded. I will try to install it tomorrow. If that doesn't work, then I will try the Overlay cd's. I really appreciate all the help that you and others give on this site. Thanks so much.
0 Likes
Coziroyc Absent Member.
Absent Member.

Re: cannot login to Netstorage

Coziroyc;1708570 wrote:
I have sp7 downloaded. I will try to install it tomorrow. If that doesn't work, then I will try the Overlay cd's. I really appreciate all the help that you and others give on this site. Thanks so much.

I forgot that this is the server I already put sp 7 on. I will try to start downloading the NW 6.5 sp7 overlay cd's today. I also will try changing that line you mentioned first and see what that does. Thanks.
0 Likes
phxazcraig Absent Member.
Absent Member.

Re: cannot login to Netstorage

Let me know. I'll try to watch here each day. (Sometimes I get busy, or
have to travel).

Craig Johnson
Novell Support Connection SysOp

0 Likes
Coziroyc Absent Member.
Absent Member.

Re: cannot login to Netstorage

phxazcraig;1708943 wrote:
Let me know. I'll try to watch here each day. (Sometimes I get busy, or
have to travel).

Craig Johnson
Novell Support Connection SysOp


I tried to retype the line. I got the same error. Here it is in full.

Syntax error on line 3 of sys:/NetStorage/xsrv.conf
Cannot load Sys:/Apache2/modules/mod_xsrv.nlm into server: (dlfcn) Load failure including unresolved symbol

I have not downloaded the SP7 overlay yet but I will start it tonight.
0 Likes
Coziroyc Absent Member.
Absent Member.

Re: cannot login to Netstorage

phxazcraig;1708943 wrote:
Let me know. I'll try to watch here each day. (Sometimes I get busy, or
have to travel).

Craig Johnson
Novell Support Connection SysOp


I reinstalled NetStorage from the overlay dvd and it works!! Thank-you so much!! I have been fighting with this on and off for a long time. This is now a great day!
0 Likes
phxazcraig Absent Member.
Absent Member.

Re: cannot login to Netstorage

In article <Coziroyc.3llpfd@no-mx.forums.novell.com>, Coziroyc wrote:
> I reinstalled NetStorage from the overlay dvd and it works!! Thank-you
> so much!! I have been fighting with this on and off for a long time.
> This is now a great day!
>

Well, THAT'S good to hear! I wonder what the problem was? Public
symbol error messages always make me think some older NLM is trying to
load when other supporting modules are expecting a newer one. (So the
idea to reinstall Netstorage, to make sure all the same-version modules
are actually there).

Craig Johnson
Novell Support Connection SysOp

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.