Anonymous_User Absent Member.
Absent Member.
751 views

iFolder 2.1.5 on OES (SLES9) auth problem

Good day,

im experiencing problem with iFolder 2.1.5 on fresh SBS (SLES9) install.
---cut--------------------------------------------
Linux oes 2.6.5-7.147-default #1 Thu Jan 27 09:19:29 UTC 2005 i686 i686
i386 GNU/Linux
---cut--------------------------------------------


I use yast2 to configure iFolder in coexistent mode. Yast2 configuration
went fine, except i had to create reverse DNS records manually.
Objects in eDirectory iFolder_* created successfully.

I successfully connect to:
https://ifolder2_coex_ip/iFolderServer/Admin/GlobalSettings.htm
and try to auth using eDirectory admin account and it fails.
Im sure, that ifonlder yast2 contex is correct, as we use
other services and auth to ldap eDirectory works fine.
I have following error in /var/ifolder2/data/ERROR.LOG

---cut--------------------------------------------
07/29/05 16:01:53 Starting iFolder server, version 2.1.5 [05/03/01]
07/29/05 16:01:53 Configured LDAP was found ready to use.
07/29/05 16:01:53 *MASTER[10.10.10.252][-1] ldap_simple_bind : Can't
contact LDAP server(-1)
07/29/05 16:01:53 ldap *MASTER[10.10.10.252] down
07/29/05 16:01:53 LDAP initialization failed. Check LDAP and restart
apache.
07/29/05 16:01:53 iFolder Application Root: /opt/novell/ifolder/Server
07/29/05 16:01:53 iFolder Host OS: Linux 2.6.5-7.147-default
07/29/05 16:01:53 iFolder Host WebServer: Apache/2.0.49 (Linux/SuSE)
mod_ssl/2.0.49 OpenSSL/0.9.7d
07/29/05 16:02:54 Configured LDAP was found ready to use.
07/29/05 16:02:54 *MASTER[10.10.10.252][-1] ldap_simple_bind : Can't
contact LDAP server(-1)
07/29/05 16:02:54 ldap *MASTER[10.10.10.252] down
07/29/05 16:02:54 LDAP initialization failed. Check LDAP and restart
apache.
07/29/05 16:03:56 Configured LDAP was found ready to use.
07/29/05 16:03:56 *MASTER[10.10.10.252][-1] ldap_simple_bind : Can't
contact LDAP server(-1)
07/29/05 16:03:56 ldap *MASTER[10.10.10.252] down
07/29/05 16:03:56 LDAP initialization failed. Check LDAP and restart
apache.
---cut--------------------------------------------

Please, suggest problem resolution path.
Thank you in advance!
o.budnik@bms.lt

Labels (1)
0 Likes
1 Reply
Anonymous_User Absent Member.
Absent Member.

iFolder 2.1.5 on OES (SLES9) auth problem

The problem was ip address to Edirectory. Specifying hostname (not ip
address) solves the problem.


> Good day,
>
> im experiencing problem with iFolder 2.1.5 on fresh SBS (SLES9) install.
> ---cut--------------------------------------------
> Linux oes 2.6.5-7.147-default #1 Thu Jan 27 09:19:29 UTC 2005 i686 i686
> i386 GNU/Linux
> ---cut--------------------------------------------
>
>
> I use yast2 to configure iFolder in coexistent mode. Yast2 configuration
> went fine, except i had to create reverse DNS records manually.
> Objects in eDirectory iFolder_* created successfully.
>
> I successfully connect to:
> https://ifolder2_coex_ip/iFolderServer/Admin/GlobalSettings.htm
> and try to auth using eDirectory admin account and it fails.
> Im sure, that ifonlder yast2 contex is correct, as we use
> other services and auth to ldap eDirectory works fine.
> I have following error in /var/ifolder2/data/ERROR.LOG
>
> ---cut--------------------------------------------
> 07/29/05 16:01:53 Starting iFolder server, version 2.1.5 [05/03/01]
> 07/29/05 16:01:53 Configured LDAP was found ready to use.
> 07/29/05 16:01:53 *MASTER[10.10.10.252][-1] ldap_simple_bind : Can't
> contact LDAP server(-1)
> 07/29/05 16:01:53 ldap *MASTER[10.10.10.252] down
> 07/29/05 16:01:53 LDAP initialization failed. Check LDAP and restart
> apache.
> 07/29/05 16:01:53 iFolder Application Root: /opt/novell/ifolder/Server
> 07/29/05 16:01:53 iFolder Host OS: Linux 2.6.5-7.147-default
> 07/29/05 16:01:53 iFolder Host WebServer: Apache/2.0.49 (Linux/SuSE)
> mod_ssl/2.0.49 OpenSSL/0.9.7d
> 07/29/05 16:02:54 Configured LDAP was found ready to use.
> 07/29/05 16:02:54 *MASTER[10.10.10.252][-1] ldap_simple_bind : Can't
> contact LDAP server(-1)
> 07/29/05 16:02:54 ldap *MASTER[10.10.10.252] down
> 07/29/05 16:02:54 LDAP initialization failed. Check LDAP and restart
> apache.
> 07/29/05 16:03:56 Configured LDAP was found ready to use.
> 07/29/05 16:03:56 *MASTER[10.10.10.252][-1] ldap_simple_bind : Can't
> contact LDAP server(-1)
> 07/29/05 16:03:56 ldap *MASTER[10.10.10.252] down
> 07/29/05 16:03:56 LDAP initialization failed. Check LDAP and restart
> apache.
> ---cut--------------------------------------------
>
> Please, suggest problem resolution path.
> Thank you in advance!
> o.budnik@bms.lt
>


0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.