Anonymous_User Absent Member.
Absent Member.
1257 views

iFolder 2.1, NW51SP5, eDir 8.83c can't initialize users

iFolder 2.1 install on NW51SP5 with eDir 8.83c

global schema extension failed to add iFolderUser class, so I added
that via
LDAP import through C1.

But still, when I attempt to enable a user I get this error:

modifyObject: Operations error
distinguished name: cn=bkc,o=murkworks
objectClass: iFolderUser
attribute: iFolderServerName


No errors appear on the apache screen.

And when I go back to this user, it does show the user as being
'enabled'
but "not been activated by the user"

If I try to login as a user through the web interface, I get "user
account
not initialized"

When I try from the ifolder client, I get something like an invalid
password
error on the client, and on apache I get an error that (if I recall)
says
"not activated"

Just now trying the client, it works..

But, when I set the quote via Admin I get this error:

modifyObject: Operations error
distinguished name: cn=bkc,o=murkworks
objectClass: iFolderUser
attribute: iFolderQuota

But gee, the quota does appear to be set.

But.. even though the iFolder client has sync'd I still can't use the
web
interface .. "user not initialized"

I also note that the java applet login box suggests host as
"myhost:%PORT%"
and I have to backspace over %PORT% and put in 443. Where is this set?





--
Novell DeveloperNet Sysop #5

_





Labels (1)
0 Likes
7 Replies
Anonymous_User Absent Member.
Absent Member.

Re: iFolder 2.1, NW51SP5, eDir 8.83c can't initialize users

Brad Clements,
> iFolder 2.1 install on NW51SP5 with eDir 8.83c
>

That is your problem. IFolder 2.x needs eDirectory 8.6.2 or later. DS

8.83c is not enough. I am sorry that you have been bitter by DS
versioning. Please see:

http://support.novell.com/cgi-bin/search/searchtid.cgi?/10026433.htm

- Anders Gustafsson, Engineer, CNE5, ASE
NSC Volunteer Sysop (http://support-forums.novell.com)
Pedago, The Aaland Islands (N60 E20)
Using VA 4.52 build 277 (32-bit) on Windows 2000 build 2195




0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: iFolder 2.1, NW51SP5, eDir 8.83c can't initialize users

Ok, very confusing versioning!

I upgraded to 8.7 and now the client works

Novell eDirectory Version 8.7.0 SMP
NDS Version 10411.01 February 24, 2003

But, the web applet still does not work, it says "User account not
initialized"

I'm stumped


--
Novell DeveloperNet Sysop #5

_
"AndersG" <dalton@nomail.to.me> wrote in message
news:VA.00003a3e.0f056cd0@nomail.to.me...
> Brad Clements,
> > iFolder 2.1 install on NW51SP5 with eDir 8.83c
> >

> That is your problem. IFolder 2.x needs eDirectory 8.6.2 or later.

DS
> 8.83c is not enough. I am sorry that you have been bitter by DS
> versioning. Please see:
>
> http://support.novell.com/cgi-bin/search/searchtid.cgi?/10026433.htm


>
> - Anders Gustafsson, Engineer, CNE5, ASE
> NSC Volunteer Sysop (http://support-forums.novell.com)
> Pedago, The Aaland Islands (N60 E20)
> Using VA 4.52 build 277 (32-bit) on Windows 2000 build 2195
>






0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: iFolder 2.1, NW51SP5, eDir 8.83c can't initialize users

Brad Clements,
> But, the web applet still does not work, it says "User account not
> initialized"
>

OK. Start here:
IFolder simple troubleshooting steps:
1. iFolder 2.x needs eDirectory 8.6.2 or better for LDAP. It will not

work with NW 5.1 DS 8.82 for example.
2. Check that the admin name in the iFolder server config file is
correct
3. Use the clear-text LDAP port for troubleshooting
4. Have iFolder log its screen to a file (below)
5. Turn on LDAP tracing on the LDAP Server/Group Object
6. LOAD DSTRACE. Turn off everything and turn on LDAP, then try to log

in.


Note on 4:
Change startifolder.ncf to read:
LOAD ADDRESS SPACE = IFOLDER APACHE -s -f
SYS:APACHE\IFOLDER\SERVER\HTTPD.CONF

- Anders Gustafsson, Engineer, CNE5, ASE
NSC Volunteer Sysop (http://support-forums.novell.com)
Pedago, The Aaland Islands (N60 E20)
Using VA 4.52 build 277 (32-bit) on Windows 2000 build 2195




0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: iFolder 2.1, NW51SP5, eDir 8.83c can't initialize users

I am watching the iFolder (httpd) screen on the server. Accesses using
the
iFolder 'native client' show activity on the screen.

But when attempting to login with the java applet, no activity appears
on
the httpd screen.

So it seems that the iFolder web applet isn't even communicating with
the
server. I will have to fool with this later.

--
Novell DeveloperNet Sysop #5

_
"AndersG" <dalton@nomail.to.me> wrote in message
news:VA.00003a56.00218b77@nomail.to.me...
> Brad Clements,
> > But, the web applet still does not work, it says "User account not


> > initialized"
> >

> OK. Start here:
> IFolder simple troubleshooting steps:
> 1. iFolder 2.x needs eDirectory 8.6.2 or better for LDAP. It will

not
> work with NW 5.1 DS 8.82 for example.
> 2. Check that the admin name in the iFolder server config file is
> correct
> 3. Use the clear-text LDAP port for troubleshooting
> 4. Have iFolder log its screen to a file (below)
> 5. Turn on LDAP tracing on the LDAP Server/Group Object
> 6. LOAD DSTRACE. Turn off everything and turn on LDAP, then try to

log
> in.
>
>
> Note on 4:
> Change startifolder.ncf to read:
> LOAD ADDRESS SPACE = IFOLDER APACHE -s -f
> SYS:APACHE\IFOLDER\SERVER\HTTPD.CONF
>
> - Anders Gustafsson, Engineer, CNE5, ASE
> NSC Volunteer Sysop (http://support-forums.novell.com)
> Pedago, The Aaland Islands (N60 E20)
> Using VA 4.52 build 277 (32-bit) on Windows 2000 build 2195
>






0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: iFolder 2.1, NW51SP5, eDir 8.83c can't initialize users

Brad Clements,
> So it seems that the iFolder web applet isn't even communicating

with the
> server. I will have to fool with this later.


That happens when the admin name entered in he iFolder webserver
config
inclde file is incorect. Please have a look at your nw_additions.conf
file.

- Anders Gustafsson, Engineer, CNE5, ASE
NSC Volunteer Sysop (http://support-forums.novell.com)
Pedago, The Aaland Islands (N60 E20)
Using VA 4.52 build 277 (32-bit) on Windows 2000 build 2195




0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: iFolder 2.1, NW51SP5, eDir 8.83c can't initialize users

The names appear correct. I have two names in there, and I can use
either
one of them to administer iFolder users.


--
Novell DeveloperNet Sysop #5

_
"AndersG" <dalton@nomail.to.me> wrote in message
news:VA.00003a5c.00ecf0fc@nomail.to.me...
> Brad Clements,
> > So it seems that the iFolder web applet isn't even communicating

with
the
> > server. I will have to fool with this later.

>
> That happens when the admin name entered in he iFolder webserver

config
> inclde file is incorect. Please have a look at your

nw_additions.conf
file.
>
> - Anders Gustafsson, Engineer, CNE5, ASE
> NSC Volunteer Sysop (http://support-forums.novell.com)
> Pedago, The Aaland Islands (N60 E20)
> Using VA 4.52 build 277 (32-bit) on Windows 2000 build 2195
>






0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: iFolder 2.1, NW51SP5, eDir 8.83c can't initialize users

OK. So you can access using the iFolder client, the admin interface, but not the Java applet?

- Anders Gustafsson, Engineer, CNE5, ASE
NSC Volunteer Sysop (http://support-forums.novell.com)
Pedago, The Aaland Islands (N60 E20)
Using VA 4.52 build 277 (32-bit) on Windows 2000 build 2195




0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.