Highlighted
Absent Member.
Absent Member.
10171 views

iFolder 3.7 on openSUSE 11.1

Hi

Anyone installed the iFolder 3.7 client on openSUSE 11.1?

ifolder3-3.7.1.8322.1-1.i586.rpm

error: Failed dependencies:
mono(gconf-sharp) = 2.8.0.0 is needed by folder3-3.7.1.8322.1-1.i586
mono(gnome-sharp) = 2.8.0.0 is needed by ifolder3-3.7.1.8322.1-1.i586


Magnus
Labels (1)
0 Likes
31 Replies
Highlighted
Knowledge Partner
Knowledge Partner

Re: iFolder 3.7 on openSUSE 11.1

Magnus Hoglund,
> mono(gconf-sharp) = 2.8.0.0 is needed by folder3-3.7.1.8322.1-1.i586
> mono(gnome-sharp) = 2.8.0.0 is needed by

ifolder3-3.7.1.8322.1-1.i586
>

You need to install Mono http://en.opensuse.org/Mono

- Anders Gustafsson (Sysop)
The Aaland Islands (N60 E20)

Discover the Novell forums at http://forums.novell.com

Novell does not monitor these forums officially.
Enhancement requests for all Novell products may be made at
http://support.novell.com/enhancement

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: iFolder 3.7 on openSUSE 11.1

See I get the same errors when trying to install iFolder3.6 I also have Mono installed already, but my gconf-sharp2 and gnome-sharp2 are version 2.24. It is only asking for version 2.8???? I do however notice that it says gconf-sharp and not gconf-sharp2

What should we do? By the way, where is iFolder3.7 client download?



AndersG;1705038 wrote:
Magnus Hoglund,
> mono(gconf-sharp) = 2.8.0.0 is needed by folder3-3.7.1.8322.1-1.i586
> mono(gnome-sharp) = 2.8.0.0 is needed by

ifolder3-3.7.1.8322.1-1.i586
>

You need to install Mono Mono - openSUSE

- Anders Gustafsson (Sysop)
The Aaland Islands (N60 E20)

Discover the Novell forums at http://forums.novell.com

Novell does not monitor these forums officially.
Enhancement requests for all Novell products may be made at
Enhancement Request
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: iFolder 3.7 on openSUSE 11.1

Wildt,
> It is only asking for version 2.8????
>

Yes, let me ask Novell.

- Anders Gustafsson (Sysop)
The Aaland Islands (N60 E20)

Discover the Novell forums at http://forums.novell.com

Novell does not monitor these forums officially.
Enhancement requests for all Novell products may be made at
http://support.novell.com/enhancement

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: iFolder 3.7 on openSUSE 11.1

Anders, while you're at it, could you please ask Novell where one might find a link to the desired version/build of mono referenced in the OES2 SP1 documention below....thanks in advance.
***********************
2.7.1 iFolder on 64-Bit Xen VM

If you install or upgrade iFolder 3.7 in a 64-bit OES 2 SP1 Linux guest VM, you must update (patch) the server before iFolder will work. There is Mono patch that contains necessary iFolder fixes for running on a 64-bit VM.
***********************
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: iFolder 3.7 on openSUSE 11.1

BoundandDetermined,
> Anders, while you're at it, could you please ask Novell where one might
> find a link to the desired version/build of mono referenced in the OES2
> SP1 documention below....thanks in advance.
>

Sure, consider it done.

- Anders Gustafsson (Sysop)
The Aaland Islands (N60 E20)

Discover the Novell forums at http://forums.novell.com

Novell does not monitor these forums officially.
Enhancement requests for all Novell products may be made at
http://support.novell.com/enhancement

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: iFolder 3.7 on openSUSE 11.1

I'll be watching for the response. This is the only thing holding me back from upgrading to 11.1 tonight.
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: iFolder 3.7 on openSUSE 11.1

I also am looking for any progress on this issue - I'm unable to use my OpenSUSE 11.1 installation properly without iFolder, and now I've upgraded to OES 2 SP1 I'm stuck with the 3.7 client as my only option..

Richard Brown // Systems Engineering Team Leader // City College Brighton and Hove
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: iFolder 3.7 on openSUSE 11.1

The 3.7 client worked perfect on openSUSE 11.0 with these versions:
mono(gconf-sharp) - gconf-sharp2 2.22
mono(gnome-sharp) - gnome-sharp2 2.22

In openSUSE these versions seems to be 2.24

Magnus
On Sun, 21 Dec 2008 06:26:02 +0000, wildt wrote:

> See I get the same errors when trying to install iFolder3.6 I also have
> Mono installed already, but my gconf-sharp2 and gnome-sharp2 are version
> 2.24. It is only asking for version 2.8???? I do however notice that
> it says gconf-sharp and not gconf-sharp2
>
> What should we do? By the way, where is iFolder3.7 client download?
>
>
>
> AndersG;1705038 Wrote:
>> Magnus Hoglund,
>> > mono(gconf-sharp) = 2.8.0.0 is needed by folder3-3.7.1.8322.1-1.i586
>> > mono(gnome-sharp) = 2.8.0.0 is needed by

>> ifolder3-3.7.1.8322.1-1.i586
>> >

>> You need to install Mono 'Mono - openSUSE'
>> (http://en.opensuse.org/Mono)
>>
>> - Anders Gustafsson (Sysop)
>> The Aaland Islands (N60 E20)
>>
>> Discover the Novell forums at http://forums.novell.com
>>
>> Novell does not monitor these forums officially. Enhancement requests
>> for all Novell products may be made at 'Enhancement Request'
>> (http://support.novell.com/enhancement)


0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: iFolder 3.7 on openSUSE 11.1

BoundandDetermined,
> Anders, while you're at it, could you please ask Novell where one might
> find a link to the desired version/build of mono referenced in the OES2
> SP1 documention below....thanks in advance.
>

it is in the SLES 10 SP2 channel

- Anders Gustafsson (Sysop)
The Aaland Islands (N60 E20)

Discover the Novell forums at http://forums.novell.com

Novell does not monitor these forums officially.
Enhancement requests for all Novell products may be made at
http://support.novell.com/enhancement

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: iFolder 3.7 on openSUSE 11.1

I got the client to load by doing the following:

searching for & deleting all -sharp references in YAST - Software Management
Adding a new repository of Index of /pub/mono/download-stable/openSUSE_11.0
Adding back all the -sharp programs I had previously deleted.
I had to uninstall ifolder 3.6 & simias first before installing the new ifolder 3.7 & simias RPM's, rpm -U did not work.

I have not tested connectivity to the iFolder server yet but it goes through the right motions (I've yet to upgrade to oessp1 so that's the next job on the list).

Dave
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: iFolder 3.7 on openSUSE 11.1

nanathlor;1708591 wrote:
I got the client to load by doing the following:

searching for & deleting all -sharp references in YAST - Software Management
Adding a new repository of Index of /pub/mono/download-stable/openSUSE_11.0
Adding back all the -sharp programs I had previously deleted.
I had to uninstall ifolder 3.6 & simias first before installing the new ifolder 3.7 & simias RPM's, rpm -U did not work.

I have not tested connectivity to the iFolder server yet but it goes through the right motions (I've yet to upgrade to oessp1 so that's the next job on the list).

Dave


I test your suggestions... and it's works, 3.7 installation and server connectivity works... Thanks 😉


Happy new year !!!
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.