Anonymous_User Absent Member.
Absent Member.
2452 views

iFolder Client & NAT

I have looked quite a bit for this answer, but I haven't really found
the exact issue for my setup (or understood it if I did find it).

I am setting up a testbed server running NW6.5 using iFolder 2.1. I
have a single NIC, private ip 10.1.1.8. I am NAT'ed behind a Linksys
router connected to a cable modem. All NAT is handled by the router.

I created a subdomain on a hosted web server, and then set up
redirection on the server to get DNS to point to the IP of the cable
modem. I opened up ports 80, 636, 443, and 389 on the Linksys. I can
access the web server fine, Net Storage, Virtual Office, the whole 9
yards both internally and externally. I can also access iFolder using
the client internally, but not externally. Externally, I get an error -105.

I have iFolder Apache conf files listening on 10.1.1.8 port 80, Console
1 shows openldap as 10.1.1.8 and ifolder server as 10.1.1.8. The host
file on the NW 6.5 server shows 10.1.1.8 as my.sub.domain, same as the
subdomain I created and redirected.

I am set up this way to test because it is similar to what will be in
production when we get the bugs worked out, static IP NAT'ed off behind
a Pix 501 with static routes set for iFolder, VO, and Groupwise.

Am I missing something obvious here? None of the TID's that I have
looked at seem to have resolved the issue.

Thanks!
Labels (1)
0 Likes
4 Replies
Anonymous_User Absent Member.
Absent Member.

Re: iFolder Client & NAT

Nns,
> I can also access iFolder using
> the client internally, but not externally. Externally, I get an error -105.
>

For this to work, you need to use DNS names and not IP addresses throughout in
the iFolder config and have them resolve correctly on the inside and outside.

- Anders Gustafsson, Engineer, CNE6, ASE
NSC Volunteer Sysop
Pedago, The Aaland Islands (N60 E20)

Novell does not monitor these forums officially.
Enhancement requests for all Novell products may be made at
http://support.novell.com/enhancement

Using VA 5.51 build 315 on Windows 2000 build 2195

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: iFolder Client & NAT

Anders Gustafsson wrote:
> Nns,
>> I can also access iFolder using
>> the client internally, but not externally. Externally, I get an error -105.
>>

> For this to work, you need to use DNS names and not IP addresses throughout in
> the iFolder config and have them resolve correctly on the inside and outside.
>
> - Anders Gustafsson, Engineer, CNE6, ASE
> NSC Volunteer Sysop
> Pedago, The Aaland Islands (N60 E20)
>
> Novell does not monitor these forums officially.
> Enhancement requests for all Novell products may be made at
> http://support.novell.com/enhancement
>
> Using VA 5.51 build 315 on Windows 2000 build 2195
>

Anders, will the host file on the server work to handle that or will I
actually need to configure DNS on the server? Also, will I need to redo
the config files and C1 stuff to use the host name instead of the IP?

I appreciate your help!
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: iFolder Client & NAT

Nns,
> Anders, will the host file on the server work to handle that or will I
> actually need to configure DNS on the server?


I do not think that would work. You could have the internal in the HOSTS
file and external in DNS shough.

Also, will I need to redo
> the config files and C1 stuff to use the host name instead of the IP?
>

Yes, just change them. There is a TID that describes the procedure.


- Anders Gustafsson, Engineer, CNE6, ASE
NSC Volunteer Sysop
Pedago, The Aaland Islands (N60 E20)

Novell does not monitor these forums officially.
Enhancement requests for all Novell products may be made at
http://support.novell.com/enhancement

Using VA 5.51 build 315 on Windows 2000 build 2195

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: iFolder Client & NAT

Anders Gustafsson wrote:
> Nns,
>> Anders, will the host file on the server work to handle that or will I
>> actually need to configure DNS on the server?

>
> I do not think that would work. You could have the internal in the HOSTS
> file and external in DNS shough.
>
> Also, will I need to redo
>> the config files and C1 stuff to use the host name instead of the IP?
>>

> Yes, just change them. There is a TID that describes the procedure.
>
>
> - Anders Gustafsson, Engineer, CNE6, ASE
> NSC Volunteer Sysop
> Pedago, The Aaland Islands (N60 E20)
>
> Novell does not monitor these forums officially.
> Enhancement requests for all Novell products may be made at
> http://support.novell.com/enhancement
>
> Using VA 5.51 build 315 on Windows 2000 build 2195
>

Anders, just a quick update -

I went ahead and rebuilt the server and had the same problem. Then, a
light slowly came on. I was unable to hit from the remote site I am
setting this up for (I log in via VPN and terminal services) although
everything looked good. We have a Barracuda spyware firewall in place.
Lo and behold, when I exempted the IP address of the terminal server I
fired right up, synched files, whole 9 yards. Otherwise it would
connect, accept the passphrase, and then disconnect.

I will pursue this with Barracuda and post any response back.
Obviously, there is something they need to tweak or add to the allowed
application list.

Thanks!
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.