warper2 Outstanding Contributor.
Outstanding Contributor.
311 views

kanaka

Ok first post in these new forums. I like the old ones better.

Ok latest version of kanaka plugin installed. This is on Mojave new machine.

The issue we are seeing is that installs fine but when you go to the directory

services on the mac it does not display Kanaka any longer. So how the 

heck are we suppose to configure this now. 

This plugin is missing now also on existing macs that are upgraded from

10.13.16 to 10.14.6 don't have the plugin listed any longer, but the do 

continue to be able to login with new accounts with kanaka. How amd

I suppose to configure or make any changes? 

I don't care who's fault it is. Just need a fix.

Thanks

Labels (1)
0 Likes
6 Replies
greiner Honored Contributor.
Honored Contributor.

Betreff: kanaka

I have no Problem with kanaka with all osx Version, also work on osx 10.15 beta

it works very fine without new configuration!

0 Likes
warper2 Outstanding Contributor.
Outstanding Contributor.

Betreff: kanaka

Sorry that does not solve my problem.

0 Likes
bkuhlmann Trusted Contributor.
Trusted Contributor.

Betreff: kanaka

Hi,

same problems here. We did an update to our mac pools and the plugin still logs the user on but does not map any drives.

So we install the client as well (the client is working fine) to get the mappings.

The users have to log in twice.

I did open an SR because of the behaviour and MF told me:

It's an apple fault we are waiting for apple to correct it.

So now we are waiting...

Regards

Bettina

0 Likes
warper2 Outstanding Contributor.
Outstanding Contributor.

Betreff: kanaka

Glad someone at least is seeing the same issue. Thank you for responding. Did they give you an idea where the issue is?
0 Likes
greiner Honored Contributor.
Honored Contributor.

Betreff: kanaka

No problem by me, i use kanaka client 3.0.1 and have osx version 10.15 Beta (19A512f) and i see all mounted Storage on NSS-Volumes and other!
Can you show us a screenshot, so that is possible to see your issue?
Thanks
0 Likes
warper2 Outstanding Contributor.
Outstanding Contributor.

Betreff: kanaka

Ok I figured out a resolution for this. 

If you have an existing system setup like on an older version or even that was 

upgraded to Mojave. You can grab the following file on the working system

and copy it to the same location on the new Mojave machine. Make sure

you set the ownership correctly on the new system to be root:wheel. 

You will need root access to accomplish this.

/Library/Preferences/DirectoryService/Kanaka.plist

I have also since tested oil the latest Public beta of Catalina and it works

there just fine and adds the system pref as well. Never get the system

pref at all on Mojave.

 

I have don't this twice now and has worked.

Good luck

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.