Anonymous_User Absent Member.
Absent Member.
756 views

libgcc

Ok, so I went through the GMS 2014r2 upgrade, all seemed to go well.
Having a couple issues now though.

I added GMS updates to be mirrored via my SMT server and mirrored them.

When I checked my SMT server, my GMS server listed with an unknown
status. When I tried to remove my GMS server from SMT and add it back,
I cannot, I get errors:

Start the registration now? [y/n] y
/usr/bin/suse_register -i -L /root/.suse_register.log
/usr/bin/zypper: error while loading shared libraries: libgcc_s.so.1:
cannot open shared object file: No such file or directory

Ignored(127)
Query products failed: /usr/bin/zypper: error while loading shared
libraries: libgcc_s.so.1: cannot open shared object file: No such file
or directory (157)
Query products failed: /usr/bin/zypper: error while loading shared
libraries: libgcc_s.so.1: cannot open shared object file: No such file
or directory (157)
Query products failed: /usr/bin/zypper: error while loading shared
libraries: libgcc_s.so.1: cannot open shared object file: No such file
or directory (157)


So I went to check something in yast on my GMS box, and I get the
errors:

libgcc_s.so.1 => not found
libgcc_s.so.1 => not found
libgcc_s.so.1 => not found
warning: the ncurses frontend is installed but does not work
package yast2-gtk is not installed
Something is wrong with the YaST user interface.

What's the best way to get this working properly again? I'm guessing I
need to install the rpm that contains libgcc, but not sure where to go
next.

--
Stevo
Labels (2)
0 Likes
5 Replies
Knowledge Partner
Knowledge Partner

Re: libgcc

Stevo;2417912 wrote:
Ok, so I went through the GMS 2014r2 upgrade, all seemed to go well.
Having a couple issues now though.

I added GMS updates to be mirrored via my SMT server and mirrored them.

When I checked my SMT server, my GMS server listed with an unknown
status. When I tried to remove my GMS server from SMT and add it back,
I cannot, I get errors:

Start the registration now? [y/n] y
/usr/bin/suse_register -i -L /root/.suse_register.log
/usr/bin/zypper: error while loading shared libraries: libgcc_s.so.1:
cannot open shared object file: No such file or directory

Ignored(127)
Query products failed: /usr/bin/zypper: error while loading shared
libraries: libgcc_s.so.1: cannot open shared object file: No such file
or directory (157)
Query products failed: /usr/bin/zypper: error while loading shared
libraries: libgcc_s.so.1: cannot open shared object file: No such file
or directory (157)
Query products failed: /usr/bin/zypper: error while loading shared
libraries: libgcc_s.so.1: cannot open shared object file: No such file
or directory (157)


So I went to check something in yast on my GMS box, and I get the
errors:

libgcc_s.so.1 => not found
libgcc_s.so.1 => not found
libgcc_s.so.1 => not found
warning: the ncurses frontend is installed but does not work
package yast2-gtk is not installed
Something is wrong with the YaST user interface.

What's the best way to get this working properly again? I'm guessing I
need to install the rpm that contains libgcc, but not sure where to go
next.

--
Stevo


Seems very similar to this: https://forums.suse.com/showthread.php?6682-Yast-not-working-after-upgrade-to-SLES11-sp4-%28from-sp3%29

Thomas
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: libgcc

thsundel sounds like they 'said':

> Seems very similar to this:
>

https://forums.suse.com/showthread.php?6682-Yast-not-working-after-upgrade-to-SLES11-sp4-%28from-sp3%29
>
> Thomas


So my response to thsundel's comment is...

It does, but I cannot get the libgcc package from sles11sp3 to install
on my GMS server. When I try I get failed dependency errors.

--
Stevo
0 Likes
Knowledge Partner
Knowledge Partner

Re: libgcc

On 26/01/2016 15:10, Stevo wrote:

> It does, but I cannot get the libgcc package from sles11sp3 to install
> on my GMS server. When I try I get failed dependency errors.


And your GMS server is running SLES11 SP3 ... ? What does "cat
/etc/*release" output?

HTH.
--
Simon
Micro Focus (Novell/NetIQ) Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: libgcc

Simon Flood sounds like they 'said':

> And your GMS server is running SLES11 SP3 ... ? What does "cat
> /etc/*release" output?
>
> HTH.


So my response to Simon's comment is...

SUSE Linux Enterprise Server 11 (x86_64)
VERSION = 11
PATCHLEVEL = 3

--
Stevo
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: libgcc - update

YAY!!! Got it working!

Had to get the correct 2 rpms for libgcc_s, and they installed, yast
working, gms up and running.

These two were needed, and when I tried they installed.

libgcc_s1-32bit-4.7.2_20130108-0.19.3.x86_64.rpm
libgcc_s1-4.7.2_20130108-0.19.3.x86_64.rpm


--
Stevo
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.