barramundi Absent Member.
Absent Member.
2939 views

libsmdr.so.0 is needed by novell-sms

Dear all:

When I try to install novell-sms, it gives me the following message:


error: Failed dependencies:
libsmdr.so.0 is needed by novell-sms-1.1.7-0.8.i586
libsmsut.so.0 is needed by novell-sms-1.1.7-0.8.i586

I googled and couldn't find those packages that contains those libraries, anyone knows what they are? Any help is appreciated, thanks.

barramundi
Labels (2)
0 Likes
11 Replies
Anonymous_User Absent Member.
Absent Member.

Re: libsmdr.so.0 is needed by novell-sms

You need novell-sms-interface-libs-<version>.i586.rpm. It should be on your OES DVD or whatever you are using to install OES.

Oza

>>> On 2/1/2011 at 09:06 AM, in message

<barramundi.4ogodz@no-mx.forums.novell.com>,
barramundi<barramundi@no-mx.forums.novell.com> wrote:

> Dear all:
>
> When I try to install novell-sms, it gives me the following message:
>
>
> error: Failed dependencies:
> libsmdr.so.0 is needed by novell-sms-1.1.7-0.8.i586
> libsmsut.so.0 is needed by novell-sms-1.1.7-0.8.i586
>
> I googled and couldn't find those packages that contains those
> libraries, anyone knows what they are? Any help is appreciated,
> thanks.
>
> barramundi


0 Likes
barramundi Absent Member.
Absent Member.

Re: libsmdr.so.0 is needed by novell-sms

Thanks for the reply.

I only found novell-sms-interface-libs for x84_64 bits but not for i586 rpm, and the error message is the same.


Oza;2070581 wrote:
You need novell-sms-interface-libs-<version>.i586.rpm. It should be on your OES DVD or whatever you are using to install OES.

Oza

>>> On 2/1/2011 at 09:06 AM, in message

<barramundi.4ogodz@no-mx.forums.novell.com>,
barramundi<barramundi@no-mx.forums.novell.com> wrote:

> Dear all:
>
> When I try to install novell-sms, it gives me the following message:
>
>
> error: Failed dependencies:
> libsmdr.so.0 is needed by novell-sms-1.1.7-0.8.i586
> libsmsut.so.0 is needed by novell-sms-1.1.7-0.8.i586
>
> I googled and couldn't find those packages that contains those
> libraries, anyone knows what they are? Any help is appreciated,
> thanks.
>
> barramundi
0 Likes
barramundi Absent Member.
Absent Member.

Re: libsmdr.so.0 is needed by novell-sms

Sorry, let me clarify my problem.

1. My OS is SLES10 and I am trying to install OES 2 SP2 packages
2. I could only find novell-sms..i586.rpm but not for x86_64 rpm
3. I tried to install novell-sms i586 rpm with novell-sms-interface-libs-1.1.7-0.8.x86_64.rpm and the error message tells me that I need libsmdr and libsmsut
4. I could only find novell-sms-interface-libs for x86_64 but not for i586

Thanks.

barramundi
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: libsmdr.so.0 is needed by novell-sms

look for the "novell-sms-interface-libs-32bit-<version>.x86_64" RPM on x86_64 architecture...

Oza

>>> On 2/1/2011 at 11:36 AM, in message

<barramundi.4ogvc1@no-mx.forums.novell.com>,
barramundi<barramundi@no-mx.forums.novell.com> wrote:

> Sorry, let me clarify my problem.
>
> 1. My OS is SLES10 and I am trying to install OES 2 SP2 packages
> 2. I could only find novell-sms..i586.rpm but not for x86_64 rpm
> 3. I tried to install novell-sms i586 rpm with
> novell-sms-interface-libs-1.1.7-0.8.x86_64.rpm and the error message
> tells me that I need libsmdr and libsmsut
> 4. I could only find novell-sms-interface-libs for x86_64 but not for
> i586
>
> Thanks.
>
> barramundi


0 Likes
barramundi Absent Member.
Absent Member.

Re: libsmdr.so.0 is needed by novell-sms

It still gives me the same error message 😞


Oza;2070591 wrote:
look for the "novell-sms-interface-libs-32bit-<version>.x86_64" RPM on x86_64 architecture...

Oza

>>> On 2/1/2011 at 11:36 AM, in message

<barramundi.4ogvc1@no-mx.forums.novell.com>,
barramundi<barramundi@no-mx.forums.novell.com> wrote:

> Sorry, let me clarify my problem.
>
> 1. My OS is SLES10 and I am trying to install OES 2 SP2 packages
> 2. I could only find novell-sms..i586.rpm but not for x86_64 rpm
> 3. I tried to install novell-sms i586 rpm with
> novell-sms-interface-libs-1.1.7-0.8.x86_64.rpm and the error message
> tells me that I need libsmdr and libsmsut
> 4. I could only find novell-sms-interface-libs for x86_64 but not for
> i586
>
> Thanks.
>
> barramundi
0 Likes
Knowledge Partner
Knowledge Partner

Re: libsmdr.so.0 is needed by novell-sms

On 01/02/2011 06:06, barramundi wrote:

> Sorry, let me clarify my problem.
>
> 1. My OS is SLES10 and I am trying to install OES 2 SP2 packages


How are you trying to install OES2 SP2 packages?

OES2 SP2 is an add-on product for SLES10 SP3 (if you don't have that
version then post what version you do have) and you can't just install a
random RPM from the media. When OES2 SP2 has been added to a SLES10 SP3
system you then get to install various OES components which will then
correctly handle all dependencies, etc.

HTH.
--
Simon
Novell Knowledge Partner (NKP)

------------------------------------------------------------------------
Do you work with Novell technologies at a university, college or school?
If so, your campus could benefit from joining the Novell Technology
Transfer Partner (TTP) program. See novell.com/ttp for more details.
------------------------------------------------------------------------
0 Likes
barramundi Absent Member.
Absent Member.

Re: libsmdr.so.0 is needed by novell-sms

Yes, it is SLES 10 SP3 and I am trying to install the package manually.


smflood;2072013 wrote:
On 01/02/2011 06:06, barramundi wrote:

> Sorry, let me clarify my problem.
>
> 1. My OS is SLES10 and I am trying to install OES 2 SP2 packages


How are you trying to install OES2 SP2 packages?

OES2 SP2 is an add-on product for SLES10 SP3 (if you don't have that
version then post what version you do have) and you can't just install a
random RPM from the media. When OES2 SP2 has been added to a SLES10 SP3
system you then get to install various OES components which will then
correctly handle all dependencies, etc.

HTH.
--
Simon
Novell Knowledge Partner (NKP)

------------------------------------------------------------------------
Do you work with Novell technologies at a university, college or school?
If so, your campus could benefit from joining the Novell Technology
Transfer Partner (TTP) program. See novell.com/ttp for more details.
------------------------------------------------------------------------
0 Likes
Knowledge Partner
Knowledge Partner

Re: libsmdr.so.0 is needed by novell-sms

On 09/02/2011 09:06, barramundi wrote:

> Yes, it is SLES 10 SP3 and I am trying to install the package manually.


Well there's your answer - that is not supported and will not work.

If you want to install OES2 components then you will need to add OES2
(SP2 or SP3 in this case to match your SLES version) as an add-on and
then install complete components. Oh and you would need a license if
you want to receive updates.

HTH.
--
Simon
Novell Knowledge Partner (NKP)

------------------------------------------------------------------------
Do you work with Novell technologies at a university, college or school?
If so, your campus could benefit from joining the Novell Technology
Transfer Partner (TTP) program. See novell.com/ttp for more details.
------------------------------------------------------------------------
0 Likes
whenz1 Absent Member.
Absent Member.

Re: libsmdr.so.0 is needed by novell-sms

I've came across the same issue when I tried to install SEP sesam, which requires SMS modules to backup OES2 / Netware infrastructure.
On the groupwise medium kit you will find the needed rpm's to install without installing OES2 components (I'm not 100% sure, but I think it's on the 2nd CD).

kr, Werner
0 Likes
barramundi Absent Member.
Absent Member.

Re: libsmdr.so.0 is needed by novell-sms

Thanks for the reply.

Are you saying that I can't install the package manually? Any idea how I should go about it?

I'm kind of new to this OES thing. Thanks a lot.

barramundi

smflood;2073975 wrote:
On 09/02/2011 09:06, barramundi wrote:

> Yes, it is SLES 10 SP3 and I am trying to install the package manually.


Well there's your answer - that is not supported and will not work.

If you want to install OES2 components then you will need to add OES2
(SP2 or SP3 in this case to match your SLES version) as an add-on and
then install complete components. Oh and you would need a license if
you want to receive updates.

HTH.
--
Simon
Novell Knowledge Partner (NKP)

------------------------------------------------------------------------
Do you work with Novell technologies at a university, college or school?
If so, your campus could benefit from joining the Novell Technology
Transfer Partner (TTP) program. See novell.com/ttp for more details.
------------------------------------------------------------------------
0 Likes
barramundi Absent Member.
Absent Member.

Re: libsmdr.so.0 is needed by novell-sms

Hi, everyone

I finally found a way to install this thing quickly, just in case anyone doesn't know how:

1. open yast
2. setup the "Installation Source" to the source file directory of the operating system you have installed, in my case, it's SLES10
3. setup the "Add-on product" tothe "suse" directory from the OES2 CD
4. Do a search on the rpm you want to install
5. Choose from the list of the rpm you want to install
6. Accept all the dependencies installation

It worked like a charm to me.

Regards,
barramundi


barramundi;2074279 wrote:
Thanks for the reply.

Are you saying that I can't install the package manually? Any idea how I should go about it?

I'm kind of new to this OES thing. Thanks a lot.

barramundi
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.