Anonymous_User Absent Member.
Absent Member.
966 views

login script quit working after 6.5 move

We just upgraded to 6.5.3 servers. My acct. (user id) is at the root of
the organization and has admin rights. I have three organization units.
Since the switch took place, I am unable to get drives G, L, and R mapped
any longer. That part of the login script does not work any longer. I
have the exact same login script for an OU under my Organization and it
works fine for those users yet. It always had worked before the move to
6.5 and new servers. I have told it to display errors and PAUSE but
nothing shows up for errors. Any help would be appreciated. I still am a
member of the HSFACULTY group. Container login script below with section
not working noted.

NO_DEFAULT
;MAP DISPLAY OFF
;MAP ERRORS OFF
;MAP INS S1:=COUGAR-1/SYS:PUBLIC
MAP F:=COUGAR-1/SYS:
MAP I:=COUGAR-1/DATA_APPS:
;MAP ROOT T:=ELEM/SYS:
MAP ROOT H:=COUGAR-1/DATA_APPS:home\%LOGIN_NAME

REM *** THE FOLLOWING SECTION IS NOT WORKING ****
IF MEMBER OF "HSFACULTY" THEN
MAP ROOT G:=COUGAR-1/DATA_APPS:winschl\gradebooks\HS\%LOGIN_NAME
MAP ROOT L:=COUGAR-1/DATA_APPS:winschl\lessons\HS\%LOGIN_NAME
MAP ROOT R:=COUGAR-1/DATA_APPS:winschl\~rosters
End
REM *** END OF SECTION NOT WORKING *****

REM ****** Client Updates ACU Begin ************
REM *****MAP ROOT m:=COUGAR-1/SYS:public\clients\win95\IBM_ENU
If OS = "WIN98" THEN
WRITE "Updating your Novell Client Win98"
#\\cougar-1\sys\public\clients\win95\ibm_enu\acu.exe
IF "%ERROR_LEVEL" = "1" THEN BEGIN
EXIT
END
END
If OS = "WINNT" THEN
WRITE "Updating your Novell Client XP"
#\\cougar-1\sys\public\clients\winnt\i386\acu.exe
IF "%ERROR_LEVEL" = "1" THEN BEGIN
EXIT
END
END

Labels (2)
0 Likes
2 Replies
Anonymous_User Absent Member.
Absent Member.

Re: login script quit working after 6.5 move

For all of your MAP commands you need to supply the context and volume
object names, not the bindery volume syntax you have used.

http://support.novell.com/cgi-bin/search/searchtid.cgi?/2908904.htm

You might also check into licensing; You should have an NLS_LSP object
for each 6.5 server, in its container. A 6.5 server license object
should be in the same container as the server object(s), or above that
in the tree, and not assigned to any server. If non-MLA, a 6.5 user
(conn) license needs to be in the same container as the user objects, or
above that in the tree, and not assigned to any server. Make sure the
two license types are successfully being consumed.
--
Andrew C Taubman
Novell Support Forums Volunteer SysOp
http://support.novell.com/forums
(Sorry, support is not provided via e-mail)

Opinions expressed above are not
necessarily those of Novell Inc.
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: login script quit working after 6.5 move

Thank you. I added the full context info to the "member of group" line
and it worked great.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.