Highlighted
vimalkumar_v Absent Member.
Absent Member.
2086 views

missing /boot, but system boots okay..

Hi all,
I have a problem with an OES2 system. The system boots fine, but the contents of /boot are missing after system start up.Originally, the systems were managed by LVM. To setup NSS, EVMS was installed and configured to manage the NSS partition. Because of various errors cropping up and thinking it might be the conflicts between LVM and EVMS, I made a mistake of making EVMS the volume manager of the local harddisk and the SAN. I tried to revert back to the original state(LVM for local disk and EVMS for SAN) by removing all references to /dev/evms in /etc/fstab. But now /boot went missing. /boot is an ext2 partition and is not in an lvm group. Any suggestions as to what is going wrong? Here are some details

#mount
/dev/system/root on / type reiserfs (rw,acl,user_xattr)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
debugfs on /sys/kernel/debug type debugfs (rw)
udev on /dev type tmpfs (rw)
devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
/dev/mapper/system-var on /var type reiserfs (rw,acl,user_xattr)
securityfs on /sys/kernel/security type securityfs (rw)
nfsd on /proc/fs/nfsd type nfsd (rw)
adminfs on /admin type adminfs (rw)



#/etc/fstab
/dev/system/root / reiserfs acl,user_xattr 1 1
/dev/cciss/c0d0p1 /boot ext2 acl,user_xattr 1 2
/dev/system/var /var reiserfs acl,user_xattr 1 2
/dev/system/swap swap swap defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0



mount /boot produces the following output
mount: /dev/cciss/c0d0p1 already mounted or /boot busy

umount and umount -l /boot and then mount yields the same error.


#snippets from /var/log/boot.msg

<5>Kernel command line: root=/dev/evms/lvm2/system/root vga=0x317 resume=/dev
/evms/lvm2/system/swap splash=verbose

Activating swap-devices in /etc/fstab...
doneStarting udevd done
Loading required kernel modules
doneActivating device mapper...
done
Starting MD Raid done
Waiting for udev to settle...
Scanning for LVM volume groups...
Reading all physical volumes. This may take a while...
Found volume group "system" using metadata type lvm2
Found volume group "san" using metadata type lvm2
Activating LVM volume groups...
3 logical volume(s) in volume group "system" now active
1 logical volume(s) in volume group "san" now active
done
Checking file systems...
fsck 1.38 (30-Jun-2005)
/dev/cciss/c0d0p1: clean, 39/18072 files, 10852/72260 blocks
Reiserfs super block in block 16 on 0xfd0b of format 3.6 with standard journal
Blocks (total/free): 5242880/4394725 by 4096 bytes
Filesystem is clean
Replaying journal:
Replaying journal: Done.

Reiserfs journal '/dev/system/var' in blocks [18..8211]: 0 transactions replayed
Checking internal tree.. ^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H
/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|
^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^Hfinished
donedone
Mounting local file systems...
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
debugfs on /sys/kernel/debug type debugfs (rw)
udev on /dev type tmpfs (rw)
devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
mount: /dev/cciss/c0d0p1 already mounted or /boot busy
/dev/mapper/system-var on /var type reiserfs (rw,acl,user_xattr)
failedLoading AppArmor module done
Mounting securityfs on /sys/kernel/security done
Loading AppArmor profiles done
Setting up the hardware clockdone


Thanks,
Vimal

Labels (2)
Tags (4)
0 Likes
1 Reply
Anonymous_User Absent Member.
Absent Member.

Re: missing /boot, but system boots okay..

vimalkumar,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your problem been resolved? If not, you might try one of the following options:

- Visit http://support.novell.com and search the knowledgebase and/or check all
the other self support options and support programs available.
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.novell.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://support.novell.com/forums/faq_general.html

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your Novell Product Support Forums Team
http://support.novell.com/forums/

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.