Highlighted
Absent Member.
Absent Member.
896 views

mount command not working on startup

This is on a paravirt oes 11 sp 1 server has a NFS server running on it. The NFS server is used to communicate with a NAS device for backup storage purposes. The mount command is issued via the /etc/init.d/boot.local which has the following as the command:

mount -t nfs ipaddress:/mnt/array1/datastore /backup

exit 0

The command works once the machine is booted and full operable, but fails to mount the NAS volume during the startup. I don’t even know which log to look in to see if there is an error that might help me diagnosis what to do. I would appreciate any help that anyone would give me.
Labels (2)
0 Likes
5 Replies
Highlighted
Knowledge Partner
Knowledge Partner

Re: mount command not working on startup

Is the command in there even being executed on startup? If not, try
putting the commands in /etc/init.d/after.local instead.

Good luck.
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: mount command not working on startup

There isn't a after.local script in /etc/init.d. Is there another option? Do you know where I can look to see if the mount is being ran or not or if there is an error at the command?
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: mount command not working on startup

Anything in /var/log/messages ?

Just a thought!

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: mount command not working on startup

On 04/12/2013 01:46 PM, jmcg wrote:>
> There isn't a after.local script in /etc/init.d. Is there another
> option? Do you know where I can look to see if the mount is being ran
> or not or if there is an error at the command?


Not by default, no, but that's something you can change. Let us know how
it goes.

Good luck.

0 Likes
Absent Member.
Absent Member.

Re: mount command not working on startup

It is normal for there to be no "after.local" file in /etc/init.d/. But create it yourself, and it will get used.

You may also want to include the option "-o _netdev" in your mount command, which will cause it to wait in the background if the network hasn't finished initializing yet on this system.

Normally people do these mounts (nfs mounts during boot) from /etc/fstab. I'm not sure your reason for avoiding that. But if it was just because the network wasn't fully initialized at the time that fstab is read / acted upon, then maybe _netdev there would solve it there, too.

Darcy
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.