LarryResch Absent Member.
Absent Member.
1821 views

named database not updating

I am using OES2015 SP1 for dhcp and dns. When using the dnsdhcp console, I can add hosts and they show up in directory, but the named database for the domain is not updated and the added host can not be resolved. I have restarted novell-named service and even gave it 48 hours, but still not able to resolve.
Labels (1)
0 Likes
6 Replies
Knowledge Partner
Knowledge Partner

Re: named database not updating

In article <LarryResch.7se29c@no-mx.forums.microfocus.com>, LarryResch
wrote:
> When using the dnsdhcp console,
> I can add hosts and they show up in directory, but the named database
> for the domain is not updated and the added host can not be resolved. I
> have restarted novell-named service and even gave it 48 hours, but still
> not able to resolve.


What named database are you looking at? eDirectory is the database for
this DNS server, and you should be able to see the entries under iManager,
View Object view, Browse tab to the zone container.

How are you testing resolution? Caching and forgotten static entries can
get in the way if you are using a regular client. I've found using a
targeted one like http://www.nirsoft.net/utils/dns_records_viewer.html
helps nail things solidly.

Is this a single server tree or do you have multiples? If Multiples, are
the servers all talking together properly
either way, make sure that eDir is basically happy with the basic health
check commands on the server that should show no errors.
ndsrepair -T
ndsrepair -E
ndsrepair -C -Ad -A



Andy of
http://KonecnyConsulting.ca in Toronto
Knowledge Partner
http://forums.novell.com/member.php/75037-konecnya
If you find a post helpful and are logged in the Web interface, please
show your appreciation by clicking on the star below. Thanks!

___
Andy of Konecny Consulting in Toronto
Knowledge Partner Profile
If you find a post helpful, click the Like button below. Thanks!
0 Likes
LarryResch Absent Member.
Absent Member.

Re: named database not updating

konecnya;2448636 wrote:
In article <LarryResch.7se29c@no-mx.forums.microfocus.com>, LarryResch
wrote:
> When using the dnsdhcp console,
> I can add hosts and they show up in directory, but the named database
> for the domain is not updated and the added host can not be resolved. I
> have restarted novell-named service and even gave it 48 hours, but still
> not able to resolve.


What named database are you looking at? eDirectory is the database for
this DNS server, and you should be able to see the entries under iManager,
View Object view, Browse tab to the zone container.

How are you testing resolution? Caching and forgotten static entries can
get in the way if you are using a regular client. I've found using a
targeted one like http://www.nirsoft.net/utils/dns_records_viewer.html
helps nail things solidly.

Is this a single server tree or do you have multiples? If Multiples, are
the servers all talking together properly
either way, make sure that eDir is basically happy with the basic health
check commands on the server that should show no errors.
ndsrepair -T
ndsrepair -E
ndsrepair -C -Ad -A



Andy of
http://KonecnyConsulting.ca in Toronto
Knowledge Partner
http://forums.novell.com/member.php/75037-konecnya
If you find a post helpful and are logged in the Web interface, please
show your appreciation by clicking on the star below. Thanks!


The database file I am referring to is in in /etc/opt/novell/named. The host is in eDirectory, but if it is not in that database file, doing an nslookup does not return anything but an error. This file is updated on my one DNS server, but on my primary server, it is not updated.

-L
0 Likes
mdallair Absent Member.
Absent Member.

Re: named database not updating

LarryResch;2448662 wrote:
The database file I am referring to is in in /etc/opt/novell/named. The host is in eDirectory, but if it is not in that database file, doing an nslookup does not return anything but an error. This file is updated on my one DNS server, but on my primary server, it is not updated.

-L


Hi,

Make sure you have incremented the serial number value in the soa Information tab of the zone. After doing this a restart of the dns daemon novell-named should correct you problem. If not you should check the common proxy configuration for the dns service because the service could not get the info from the ldap server.

Hope this help

Martin Dallaire
0 Likes
Knowledge Partner
Knowledge Partner

Re: named database not updating

In article <LarryResch.7sezlb@no-mx.forums.microfocus.com>, LarryResch
wrote:
> The database file I am referring to is in in /etc/opt/novell/named. The
> host is in eDirectory, but if it is not in that database file, doing an
> nslookup does not return anything but an error. This file is updated on
> my one DNS server, but on my primary server, it is not updated.


Ah yes, that file is a part of the process, it is rare enough to need to
look at it that I forget it is there. Yes, if the data isn't getting
written down to the that file, then there is a problem.
Martin's suggestions have a good chance of helping, but in case they
don't, lets check the basics.
Which version of the DNS/DHCP console are you running? Its easy enough to
miss updating it and be using an old one (opps, as an example I see I'm
behind on this system)
It sounds like you have multiple DNS servers in your tree, which are you
connecting to to make your edits? Does changing which server you are
connected make a difference?
As I mentioned before, make sure eDirectory is healthy, if it isn't
synchronizing, then any edits you make connected to one system won't
propagate to the other(s).
With multiple DNS servers, the domainzone.tld.db files should normally be
identical. Do you see all the DNS servers set as 'Authoritative DNS
Servers' when you look in the zone's attributes tab in DNS/DHCP Console?


Andy of
http://KonecnyConsulting.ca in Toronto
Knowledge Partner
http://forums.novell.com/member.php/75037-konecnya
If you find a post helpful and are logged in the Web interface, please
show your appreciation by clicking on the star below. Thanks!

___
Andy of Konecny Consulting in Toronto
Knowledge Partner Profile
If you find a post helpful, click the Like button below. Thanks!
0 Likes
Knowledge Partner
Knowledge Partner

Re: named database not updating

Hi.

Please check /var/log/messages and /var/opt/novell/log/named.run when
starting novell-named. I strongly suspect your DNS can't login to eDir
and as such can't read the current data.

Am 16.01.2017 um 13:26 schrieb LarryResch:
>
> konecnya;2448636 Wrote:
>> In article <LarryResch.7se29c@no-mx.forums.microfocus.com>, LarryResch
>> wrote:
>>> When using the dnsdhcp console,
>>> I can add hosts and they show up in directory, but the named database
>>> for the domain is not updated and the added host can not be resolved.

>> I
>>> have restarted novell-named service and even gave it 48 hours, but

>> still
>>> not able to resolve.

>>
>> What named database are you looking at? eDirectory is the database for
>> this DNS server, and you should be able to see the entries under
>> iManager,
>> View Object view, Browse tab to the zone container.
>>
>> How are you testing resolution? Caching and forgotten static entries can
>> get in the way if you are using a regular client. I've found using a
>> targeted one like http://www.nirsoft.net/utils/dns_records_viewer.html
>> helps nail things solidly.
>>
>> Is this a single server tree or do you have multiples? If Multiples, are
>> the servers all talking together properly
>> either way, make sure that eDir is basically happy with the basic health
>> check commands on the server that should show no errors.
>> ndsrepair -T
>> ndsrepair -E
>> ndsrepair -C -Ad -A
>>
>>
>>
>> Andy of
>> http://KonecnyConsulting.ca in Toronto
>> Knowledge Partner
>> http://forums.novell.com/member.php/75037-konecnya
>> If you find a post helpful and are logged in the Web interface, please
>> show your appreciation by clicking on the star below. Thanks!

>
> The database file I am referring to is in in /etc/opt/novell/named. The
> host is in eDirectory, but if it is not in that database file, doing an
> nslookup does not return anything but an error. This file is updated on
> my one DNS server, but on my primary server, it is not updated.
>
> -L
>
>



--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
0 Likes
LarryResch Absent Member.
Absent Member.

Re: named database not updating

Thanks for the replies - I'll check on it next time I'm at the site and post what I find out.

-L
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.