Big news! The community will be moving to a new platform April 21. Read more.
Big news! The community will be moving to a new platform April 21. Read more.
Absent Member.
Absent Member.
3273 views

ncpcon mount failure reason = 17

Hi
Receiving the following error when trying to mount a volume that is part of a cluster pool resource (oes2lx cluster):

>>
++ IP_ADDR=/etc/ha.d/resource.d/IPaddr2
++ FILE_SYSTEM=/etc/ha.d/resource.d/Filesystem
++ OCF_DIR=/usr/lib/ocf/resource.d/heartbeat
+ exit_on_error nss /poolact=SBDATA
+ nss /poolact=SBDATA
+ rc=0
+ '[' '!' 0 -eq 0 ']'
+ return 0
+ exit_on_error ncpcon mount SBDATA=252
+ ncpcon mount SBDATA=252
... Executing " mount SBDATA=252"

The following volume were not mounted.
SBDATA: failure reason = 17
No volume were mounted.
<<

This happens if we try the command manually also.
Looking in nsscon we can see that the SBDATA pool is active (pools) and the SBDATA volume is Not Active (volumes)
We can manually activate it will nss /volumeactivate=SBDATA but cannot see the volume from a client when browsing either the cluster resource or cluster node

Similarly we can get the volume mounted using nssmu->volumes, highlight and [F7] but again can't see it from a client...
This is presumably becasue the ncpcon mount is not occuring and so ncp is not making the volume available/visible?

I have tried looking up "failure reason = 17", but have not been able to find anything...

Any suggestions as to what this error is referring to? I'm guessing either the eDirectory volume object or some local or cached info on the Linux cluster node...

Thanks
David
Labels (2)
0 Likes
3 Replies
Absent Member.
Absent Member.

Update:
Still no idea what ncpcon mount failure reason = 17 is, but a full reset of the cluster (cluster down; rcnovell-ncs stop; init 6 on all nodes) and it seems OK!
0 Likes
Absent Member.
Absent Member.

I observed this when the NSS volume was configured not to be accessed from ncp which is normally done when configured for shadow volume (Dynamic Storage Technology) but shadow relationship has been removed/broken and not valid anymore. If this is the case, try removing/ clearing those entry from /etc/opt/novell/ncp2nss.conf and ncpserv.conf and restart edirectory.Then try remounting it.
0 Likes
Absent Member.
Absent Member.

I received the message "failure reason = 17" when loading an NSS Volume Cluster Resource. What I found was that were duplicate volume ID's in the cluster resource load scripts.

For example:
exit_on_error ncpcon mount /opt=ns=unix VOL03=225
exit_on_error ncpcon mount /opt=ns=unix VOL12=225

This caused problems when both resources were trying to load on the same server. To resolve this, I made sure the volume ID's in the load scripts were unique. Migrate the resources so the changes take effect. Now, the error is gone and resoruces migrate as expected to.

Thanks,
Scott
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.