chas1 Absent Member.
Absent Member.
1824 views

nss volume does not mount automatically at boot time

I have upgraded from OES 2014 to 2018 which is running groupwise (prior to this upgrade). I now find that the nss volume does not mount automatically at boot time although when I run nssmu the volume is visible but requires me to mount it.

Anyone got any ideas how to overcome this problem.

Regards

ChasR.
Labels (2)
0 Likes
6 Replies
Knowledge Partner
Knowledge Partner

Re: nss volume does not mount automatically at boot time

chas;2472393 wrote:
I have upgraded from OES 2014 to 2018 which is running groupwise (prior to this upgrade). I now find that the nss volume does not mount automatically at boot time although when I run nssmu the volume is visible but requires me to mount it.

Anyone got any ideas how to overcome this problem.

Regards

ChasR.


I'd probably look at the /var/log/messages and see what may show up during boot time.

I've had very rare instances where eDir/LDAP isn't up fully by the time NSS fires up and NSS uses namcd, which uses LUM, which used LDAP, and if that's not working, then nss won't start properly.

Typically though the logging will give some explanation if that's the case.

At least in OES 2011 and below (I'm assuming 2015/2018 still make use of LDAP/LUM in that case for NSS).
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: nss volume does not mount automatically at boot time

Hi Chas

Yes, there is a bug, it wont load if ns=anyNamespace is used in /etc/fstab,
than you will see an 20801 error in /var/log/messages (It's reported with
SR101133622801 as bug)
You can mount it with nssmu w/o problem, may be with ncpcon mount Volume,
too (not yet tested)

If you delete ns-Part, volume will load at boot with Long-namespace.

regards
Markus

"

0 Likes
chas1 Absent Member.
Absent Member.

Re: nss volume does not mount automatically at boot time

Thanks,
I need it to load automatically, as groupwise post and domain are on this volume, and it needs to be mounted before groupwise can function. OK if someone is there, but should the server require re-booting, then manual intervention is necessary. Will wait until this problem is addressed at a later date.

Thanks for your feedback

ChasR.
0 Likes
Gerd Woelfel Contributor.
Contributor.

Re: nss volume does not mount automatically at boot time

i have the same problem, too.
tried to fix this within /etc/init.d/after.local adding the following:

nss /VolumeActivate='my-volumes-name'

most of the time it works, but if ndsd needed a little bit more time to activate eDirectory i have to run nss /VolumeActivate=VOL1 manually.

I wait for the fix, too. Wondering how Micro Focus can release OES2018 with this bug!
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: nss volume does not mount automatically at boot time

Hi

If namespace Long is sufficient, than you can change entry in /etc/fstab

from
VolumeName /media/nss/VolumeName nssvol noauto,rw,name=VolumeName
ns=anyNamespace 0 0
to
VolumeName /media/nss/VolumeName nssvol noauto,rw,name=VolumeName 0 0

than it should mount on startup

regards
Markus


0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: nss volume does not mount automatically at boot time

Hi
Done some tests with an own "service", the (still using init...) script is
starting after nss. As this is the dependency, it should load every time ...

~ # cat /etc/init.d/novell-nss-mount
#!/bin/sh
#
### BEGIN INIT INFO
# Provides: novell-nss-mount
# Required-Start: $network $remote_fs
# Should-Start: ndsd namcd novell-nss nss
# Required-Stop: $network $remote_fs
# Should-Stop: ndsd namcd novell-nss nss
# Default-Start: 3 5
### END INIT INFO

case "$1" in
start)
nss /VolumeActivate='VOLX'
nss /VolumeActivate='VOLY'
;;
stop)
;;
esac

Enable it on boot:
~ # chkconfig novell-nss-mount on


If you have services (like GroupWise) with dependeny of mounted volumes, you
have to add them to the service-start-script

~ # cat /etc/init.d/grpwise
#!/bin/bash
#set -x
set -f
### BEGIN INIT INFO
# Provides: grpwise
# Required-Start: $network $remote_fs
# Should-Start: ndsd namcd novell-nss nss novell-nss-mount
# Required-Stop: $network $remote_fs
# Should-Stop: ndsd namcd novell-nss nss
# Default-Start: 3 5
# Default-Stop: 0 1 2 6
# Short-Description: Novell GroupWise Agents
# Description: Start Novell GroupWise Agents
### END INIT INFO

.....


May be you can use this as a workaround

regards
Markus

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.