UPDATE! The community will be go into read-only on April 19, 8am Pacific in preparation for migration on April 21. Read more.
UPDATE! The community will be go into read-only on April 19, 8am Pacific in preparation for migration on April 21.Read more.
Absent Member.
Absent Member.
1156 views

oes2 sp2 Linux edirectory 6038 error

Hello all, I have an oes2 sp2 linux server, with edirectory on it and several replicas, that boots healthy, but recently is stateing the edirectory error 6038. I rebooted the server several times and all seems healthy except the edirectory. I did find some threads via google, that suggested this might be a space issue, but i ran the a df from connant line, and over 50% of my drive is still empty. I am displaying all thge symptons that are explained in this thread:
forums.novell.com - novell.support.open-enterprise-server.linux.administration - Re: NDSD fails to stay running - Put.hk Newsgroup Reader

Many suggest the that local edir database is correupt, and even though the pid is running, edirectory is indeed NOT running as explained in the above thread, and there seems to be no way to repair the database. In the Netware days, one could reboot the server with the switch: -ndb, and then run a local repair...is there anything equivalent in Oes2 Sp2, or does anyone have any suggestions on how to fix this. I am open to ideas and would be very greatful, and the edir error are stacking up....

Thanks.
Labels (2)
0 Likes
2 Replies
Absent Member.
Absent Member.

There is a -NDB equivalent in the Linux world, see TID 3586091 .

Andrew C Taubman (Sorry, support is not provided via e-mail) Opinions expressed above are not necessarily those of Micro Focus.
0 Likes
Absent Member.
Absent Member.

Yes, Thanks ataubman, I found a TID last night that had the command:
rcndsd start -ndb

I ran this on my OES2 SP2 server, and indeed it brought up the edirectory, without connecting to the DIB, I was then able to run:
ndsrepair -R -Ad

With error -6038, you cannot run ANY dsrepair commands, until you bring up edirectory, without connecting to the DIB. Anyways, I ran the above command, and it started to cleanup and repair the Database, afterabout 3 runs, I had 0 errors, AND ithen did a:
rcndsd stop
rcndsd start

and VOILA! Edirectory came up perfectly, and started syncing with the other servers again! I was so happy!
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.