UPDATE! The community will be go into read-only on April 19, 8am Pacific in preparation for migration on April 21. Read more.
UPDATE! The community will be go into read-only on April 19, 8am Pacific in preparation for migration on April 21.Read more.
Absent Member.
Absent Member.
1274 views

resolv.conf - Only root can see

SLES 9 SP3 OES Servers. I noticed some third party apps that use a local Linux user were not being able to resolve host names.

I noticed that on some servers, the /etcresolv.conf file had rw r r rights, a user was able to lookup host names. However, on some other servers, the /etc/resolv.conf only had rw r rights. Since /etc/resolv.conf was invisible to normal users, they were unable to lookup host names. Using chmod 644 instalntly resolved this issue.

Just curious why some servers restricted the resolv.conf, while other servers had normal file rights.
Labels (2)
0 Likes
2 Replies
Knowledge Partner Knowledge Partner
Knowledge Partner

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Wild guess... some piece of software incorrectly changed the permissions
on that file. I've never seen that file with permissions other than 644
(rw-r--r--) and anything else doesn't really make sense to me unless it's
444, which doesn't really add much since 'root' owns things anyway. As
this is an OES 1 system perhaps it was an old bug with that product. I'll
ask around and if I find something similar I'll post back but I've never
heard of that with any distro.

Good luck.





sburmann wrote:
> SLES 9 SP3 OES Servers. I noticed some third party apps that use a
> local Linux user were not being able to resolve host names.
>
> I noticed that on some servers, the /etcresolv.conf file had rw r r
> rights, a user was able to lookup host names. However, on some other
> servers, the /etc/resolv.conf only had rw r rights. Since
> /etc/resolv.conf was invisible to normal users, they were unable to
> lookup host names. Using chmod 644 instalntly resolved this issue.
>
> Just curious why some servers restricted the resolv.conf, while other
> servers had normal file rights.
>
>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQIcBAEBAgAGBQJK3Ir7AAoJEF+XTK08PnB5VvkP/j5/R+HG+elmyVo1JPPkPn5T
wHhDDEuMNCGaHJtozHx3GQqLcm9KsWVwtS2/A4M6SBQI3SO0rd+jqLy4m+jgsWuT
RXI0Gr8dCMqphS5Ze4fefh1iTMnRFDFBRGlMkFQwW2aMCyNcUXbSl8piZuYdDHuO
1GRRhzb+54kgxSFDBW5g/0W67Ml9Xb5KUAjZmvx0dvqG2j6DLJSLcWfhosHjIkZR
LpxjLvcdVz1jJ3Cbv8MNlTX0lFLomz2l5DsPH5Gox35KHJ8NgOpPS/uix6v5hrFN
a/GKZRrt5CQAIiHEx8St6xNzHUGkTkwuuHjg69ngdMZDXCg6+GZFUboLgzNT04Gt
N9AMYevfSCpnPCYY3Gcrgm8Gw5WpgE2iriFhW2N0qsy0pYb5KuV5vBmPjN5ldBBW
i1Q/PO0fdWWzgJItl7t9tlLZ0Lt5/YuB7/fH8lP9nefzak+JIWwCFwCsRLBcp8Bt
OTrXGzRkeOLcrncKFZwEiIZWTCH76v300IJxGUQOR5Mq8/DpBDjXJU5EF29MZaBZ
o6264IP92FyFYytUyOG9aokvncDWp7d2lxpP/mD5nS6xl5HIG0tUF1Uk/oxPlDMy
j+4B91Rij4Zf45Qb6HMm5/1MhsIuPwxDVVMlCa5hnYZWW34yvX1mEcBiun+RzLyu
0J9XB0liiFB95DUpRRfo
=H5AB
-----END PGP SIGNATURE-----
0 Likes
Fleet Admiral
Fleet Admiral

sburmann,

another wild guess ... in yast / security and users / security settings you can define the file permissions on the fifth page to paranoid. That also might result in those settings.

Rainer
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.