afiore Absent Member.
Absent Member.
1390 views

sles 10.2/oes2sp1 update problems, 3 servers

Good Morning,

I am working on upgrading 3 servers from SLES 10.2/OES2 sp1 to SLES 10.3/OES2 sp2, and I am having slightly different problems with each.

Server 1, I began the migration and thought it completed, but it looks like it only updated the OES portion, or did not finish the SLES portion, or maybe in just not subscribed to all the correct channels.

When I run rug pd -i , it shows I have installed:

i | OPEN_ENTERPRISE_SERVER_SP2
i | SUSE_SLES_SP3
i | SUSE-Linux-Enterprise-Server-SP3-migration

At this point, I don't think the migration package should be there, but I'm not sure. I did not select it in the prior updates as the update directions say. I only selected the move-to-oes2-sp2-migration update. I also don't know what happens through the update procedure.

When I run rug ca , all I get is:

Yes | SLES10-SP3-Online
Yes | OES2-SP2-Pool
Yes | OES2-SP2-Updates

and the server thinks it has no updates to get. Anyway, I'm not quite sure what's going on.

Server 2, I have run the move-to-oes2-sp2 update and it is installed, but I have not gone any further because it is not showing any SLES10-SP3 channels installed and I don't want to end up in the same situation as the first server with only a partial install.

While following directions from the beginning, under "Preparatory Process" (tid 7004963) When I run the command:

rug lu -t patch sles10-sp2-updates oes2-sp1-updates

I get an: ERROR: ose2-sp1-updates is not a valid catalog

But I'm not sure if this is irrevelvent due to already running the move-to-oes2-sp2 patch.

This entire process of subscribing to channels and doing these updates has got me totally frustrated. I've been reading TIDs and forums for a week now and I'm getting nowhere fast.

I got Server 3 to finish the migration. I had just finished doing the latest updates, and on the reboot, I lost the NIC. I am working on that particular problem in a diffrent post, and with HP (may be a hardware issue) so we can forget about that one for now.

Thank you for any help, I hope there is enough information in here to get this started.

Tony
Labels (2)
0 Likes
4 Replies
utman Absent Member.
Absent Member.

Re: sles 10.2/oes2sp1 update problems, 3 servers

I would recommend using the CD/DVD update method.


Novell Documentation
0 Likes
afiore Absent Member.
Absent Member.

Re: sles 10.2/oes2sp1 update problems, 3 servers

Good Morning,

Server 1 was repaired by following TID 7000219 After following the TID, the Migrate to SLES 10.2 patch was removed and the proper channels were being received. I was able to do the last 91 updates and finish the migration. This server is now showing SLES 10.3 & OES2 SP2.

Server 3 was finally repaired by doing a clean install of SLES 10.3 & OES2 SP2. HP support was not getting us anywhere. This is still a mistery as to what happened to the NIC, but is was deffinitely software related.

I am still working on Server 2. TID 7000219 did not help this one.

Tony
0 Likes
Brunold Rainer Absent Member.
Absent Member.

Re: sles 10.2/oes2sp1 update problems, 3 servers

Tony,

regarding Server 3 - I had a strange problem on a SLES 11 server a few weeks ago where I installed the latest version of the HP Proliant support pack. After rebooting the server had no network and after maybe half an hour or so I recognized that the HP agents made a downgrade of the Broadcom network driver. that downgraded module didn't work with the current kernel version. I don't know why they did the downgrade, but after removing that HP package and back on the SLES driver, the system was back online. So maybe you also had a problem just with the network driver ...

regarding Server 2 - can you post the output of the following commands that we get an idea on what your systems currently see from the online update channels ?

# rug sl
# rug ca

Another side note ... when I would have more then one server to upgrade, I would download the SLES 10 SP3 and OES 2 SP2 installations media local to a server and share that for the update of the other server via nfs, http or ftp. Then there is not that much downloaded from the internet nad a local source might always be more stable then a internet source.

Rainer
0 Likes
Highlighted
afiore Absent Member.
Absent Member.

Re: sles 10.2/oes2sp1 update problems, 3 servers

Hello Again Rainer,

I have not used any of the proliant support packs since moving to Linux. I haven't learned to install them yet (or just haven't got around to it). I will eventually get to that.

As for server 2, a strange thing happened. I had been working with my local paid support, who was able to get the subscriptions correct and finally show all the updates. I can't say exactly what fixed it whereas we tried quite a few things. But anyway, even though we could now see all the updates, they would not do through due to a dependancy conflict with product-oes2-sp2 patch. So while we were looking into that, I got brave and did all the other updates, which made everything work ok, except the product identification was incorrect. Monday morning, I was verifying all the information on the dependency error while getting ready for the support call. When I ran the product-oes2-sp2 patch to verify the dependency error, it finally went through, and everything was good. Computers ... who knows ?

The only wierd thing now is the server shows both installed products as add-ons instead of SLES 10.3 being installed as the base install. see below:

dslxweb:~ # rug products

S | Name | Version | Category
--+----------------------------+---------+---------
| SUSE_SLES_SP3 | 10.3-1 | base
i | OPEN_ENTERPRISE_SERVER_SP2 | 2.0.2-0 | add-on
i | SUSE_SLES_SP3 | 10.3-0 | add-on

So if I could figure out how to get that little i up to the top line and the bottm line to disappear, I'd be good. But my support help says it's not a big deal.

But it's also driving me nuts ! I hate little discrepancies.

Sorry for the long story ...

Tony
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.