Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
Anonymous_User Absent Member.
Absent Member.
652 views

sles11sp3 and apache

Trying to update my web server (running sles11sp2, oes11sp1, and GW
webaccess also) to sles11sp3
/ oes11sp2.

Get an error in the packages:

novell-nrm-2.0.3-0.109.5 requires apache2-mod_php53, but the
requirement cannot be provided.

apache2-mod_php53-5.3.x are uninstallable

Resolution options are:

1. Uninstall apache2-mod_php5-5.2.14-0.7.30.50.1 and uninstall a bunch
of php5 modules

2. Uninstall novell-ncpserv-nrm-2.0.5-12.42.45.2

3. Keep obsolete novell-nrm-2.0.2-297.305.304.1

4. Break novell-nrm-2.0.3-0.109.5


Whatever resolution option I look to try, it causes other errors that
require a whole nother set of resolutions.

Server is sles11sp2 / oes11sp1 that I have kept up to date via SMT.
Only running apache / tomcat, and Groupwise webaccess and web calendar
publishing.

Suggestions?

--
Stevo
Labels (2)
0 Likes
2 Replies
Anonymous_User Absent Member.
Absent Member.

Re: sles11sp3 and apache

Hello Stevo,

I suggest to upgrade to php53 from SLES11SP2 first with a commandline
like this (all on one line!):

zypper search -t package -i php5 | grep php5 | cut -f3 -d' ' | \
sed -e "s,php5,php53,g" | xargs zypper in --dry-run

With the --dry-run at the end it actually does nothing, it just tests
the install. Note that a few php5.2 packages have no php5.3 counterpart
(packages like php5-hash I vaguely remember), these packages are
integrated in the main package now.
Before really updating, check the list of enabled modules in the YAST
webserver configuration, you probably have to enable at least the php
module again after the update. Making a backup copy of the /etc/apache2/
and /etc/php5/ directories cannot hurt, too.

Now run the above commandline again with the --dry-run removed. AFAIR
zypper will just warn about non-existing packages and install the rest
plus any needed dependencies. Afterwards check/update your webserver and
php5 (php5.ini, etc) configuration, then restart the webserver. There
might be some minor problems lurking on the way, I last did this about a
year ago.

Updating to SLES11SP3/OES11SP2 should be fine from this point onwards.

Franz

Am 2014-05-14 18:24, schrieb Stevo:
> Trying to update my web server (running sles11sp2, oes11sp1, and GW
> webaccess also) to sles11sp3
> / oes11sp2.
>
> Get an error in the packages:
>
> novell-nrm-2.0.3-0.109.5 requires apache2-mod_php53, but the
> requirement cannot be provided.
>
> apache2-mod_php53-5.3.x are uninstallable
>
> Resolution options are:
>
> 1. Uninstall apache2-mod_php5-5.2.14-0.7.30.50.1 and uninstall a bunch
> of php5 modules
>
> 2. Uninstall novell-ncpserv-nrm-2.0.5-12.42.45.2
>
> 3. Keep obsolete novell-nrm-2.0.2-297.305.304.1
>
> 4. Break novell-nrm-2.0.3-0.109.5
>
>
> Whatever resolution option I look to try, it causes other errors that
> require a whole nother set of resolutions.
>
> Server is sles11sp2 / oes11sp1 that I have kept up to date via SMT.
> Only running apache / tomcat, and Groupwise webaccess and web calendar
> publishing.
>
> Suggestions?
>


0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: sles11sp3 and apache

Thanks for the help! 🙂


--
Stevo
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.