Big news! The community will be moving to a new platform April 21. Read more.
Big news! The community will be moving to a new platform April 21. Read more.

Restore silent login feature, but disabled by default

Idea ID 2858700

Restore silent login feature, but disabled by default

Somewhere in a 2018 release of SiteScope the silent login feature was deprecated. We did not discover this until we upgraded from an older 10.x version to 2020.05. This is a feature our IT Operations Center users accessed on a regular basis, and is a feature still supported in APM.

Our use case is for users pulling a URL from a SiteScope event CMA that takes them directly to the monitor. From there they exercise the monitor for current state, and can view history to see when the monitor reported an error and for how long. This was done directly from the event URL in Chrome, or for the Java UI as a copy-paste to IE.

We have four separate SiteScope environments, including one in a tightly reserved subnet where LDAP is not a direct option. The silent login embedded in the URL made the user experience seamless for each environment.

We have enabled LDAP in the three environments, but that now requires any user to have to log in to each SiS environment, lasting only a day. For the reserved environment we have a team-level login. This adds additional complexity and time for operators who are busy engaging any incoming events.

Meanwhile, we have an embedded APM dashboard, and users have the option of viewing specific APM objects via the silent login feature still supported in APM.

We do agree that the silent login feature should not be enabled by default, but we feel that so long as the feature is supported in APM it should also be supported in SiteScope. The code still seems to exist given that the continued embedded silent login credentials do not generate any noticeable errors...they just now push the user to the login screen.

Speaking to that, when users click a drilldown link and are instead challenged with a login, the successful login does not continue to the drilldown but to the top level view. The user has to close the window or tab and click the same drilldown link again, now relying on their authenticated session to deliver them to the expected drilldown.

So, in summary, please restore the silent login feature to SiteScope, disabled by default but available for use.

 

Thanks!

sh

Tags (2)
1 Comment
Captain Captain
Captain

Submitted as an enhancement request, too, for now. Why isn't SiteScope listed as a product under the Idea Exchange?

The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.