uCMDB (RTSM) REST API is not working

uCMDB (RTSM) REST API is not working

uCMDB (RTSM) REST API is not working when run on the GW locally.
 

On an OBM 2020.05 with separate GWs and DPS trying to use the uCMDB (RTSM) REST API on the OBM GW server itself does not work.

The URL https://localhost:8443/rest-api/authenticate

Returns RESPONSE:

Error: Server returned nothing (no headers, no data).

On OBM 2020.05 the uCDMB runs only on the DPS so the RTSM REST API must be used against the DPS or on the DPS servers itself. In case it gives an error: “SSL peer certificate or SSH remote key was not ok” make sure to disable validation of certificates on the REST client used.
It is important to mention that the RTSM REST API does not support LDAP authentication but only local OMi users. One should use only local users.

Micro Focus Software Support
The views expressed in my contributions are my own and do not necessarily reflect the views and strategy of Micro Focus.

Labels (1)

DISCLAIMER:

Some content on Community Tips & Information pages is not officially supported by Micro Focus. Please refer to our Terms of Use for more detail.
Top Contributors
Version history
Revision #:
1 of 1
Last update:
‎2020-10-16 15:05
Updated by:
 
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.