Highlighted
Super Contributor.
Super Contributor.
713 views

Customizing Reports Error: An error has occurred: No ReportEngine instance exists for the token.

I am attempting to customize the existing SM Operations reports, in order to provide a specific set of metrics per server. The SHR Template BIAR on HP Live Network does not include a report that I can leverage, and the idea of jumping into CDE is scary at best. I've never had a good experience with CDE.

So, after clicking on the Edit button in the existing report, I get this error in InfoView:

An error has occurred: No ReportEngine instance exists for the token.

Any ideas?

Best Regards,

~ Michael Stollaire
Labels (1)
0 Likes
7 Replies
Highlighted
Outstanding Contributor.
Outstanding Contributor.

Stop and Start all servers. If thats not possible then stop and start Web-Intelligence processing server.

0 Likes
Highlighted
Super Contributor.
Super Contributor.

After restarting the BO servers, and verifying they all came up Enabled and Running, now, I don't even get the error any longer. Now, I get a blank grey screen.

Best Regards,

~ Michael Stollaire
0 Likes
Highlighted
Outstanding Contributor.
Outstanding Contributor.

Hi Mike 

it might be because of jvm version in your local machine. please use jvm 1.7 version than 1.8, so that we can modify the report.

Regards

krishna Rao

0 Likes
Highlighted
Super Contributor.
Super Contributor.

That error needs to be written up as a KB and/or inserted into the Troubleshooting Guide for sure.

You were correct:

java version "1.8.0_92"
Java(TM) SE Runtime Environment (build 1.8.0_92-b31)
Java HotSpot(TM) 64-Bit Server VM (build 25.92-b31, mixed mode)

I will try with 1.7x a little later. Thanks!

Best Regards,

~ Michael Stollaire
0 Likes
Highlighted
Super Contributor.
Super Contributor.

So, I ran this directly on the SHR server, v.1.7 java and get the exact same error when editing the report.

Also, with just 5-10 servers selected I get the attached error.

All BO servers are running and enabled and WEBI services are running and enabled.

Best Regards,

~ Michael Stollaire
0 Likes
Highlighted
Outstanding Contributor.
Outstanding Contributor.

HI Mike,

i didn't know about this error, but this error is not related to our original issue. with problems in editing template report, why can't you use existing OOTB report,  copy and rename the original report and edit that report with the required metrics. Hope you have edited the Business objects universe layer to add the additional metrics to appear for report creation.

0 Likes
Highlighted
Super Contributor.
Super Contributor.

Sorry for the delayed response, as somehow I missed this. Let me give it a try, and I will certainly let you know what happens.

Best Regards,

~ Michael Stollaire
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.