Cadet 3rd Class Cadet 3rd Class
Cadet 3rd Class
1129 views

Getting handshake exception error when configuring URL monitor

URL: https://xyz.unix.dvn:443/nnm/, host:xyz.unix.dvn, port: 443, UsingProxy: false, isHTTPS(SSL): true, javax.net.ssl.SSLHandshakeException: Received fatal alert: handshake_failure, currentRetry: 0

I tried to configure URL monitor, but getting handshake error. I have imported all the related certificates in both the tools. I have even tried enabling winlet but nothing works.

It would be great if anyone can help me on this.

Labels (1)
0 Likes
1 Reply
Micro Focus Expert
Micro Focus Expert

Hi,

What version of SiteScope are you using?  Older versions do not support TLS v1.1 & 1.2 protocols, and it's quite common for web servers to not allow older protocols (e.g. TLS1.0 and SSL versions), which would cause a handshake failure.  The openssl tool could be useful here if you can run it on your SiteScope server*:

   openssl s_client -connect xyz.unix.dvn:443

This will check if you can establish a connection from the SiteScope server to the remote site.  Then you can specify a particular protocol by apending one of the following to the openssl command:

 -tls1_2
 -tls1_1
 -tls1
 -ssl3

* openssl is usually available on Linux by default, but not on Windows.  If it's a VM, then it might be present in VM Ware tools - search for openssl.exe.

Regards,
Tim

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.