Big news! The community will be moving to a new platform April 21. Read more.
Big news! The community will be moving to a new platform April 21. Read more.
Absent Member.
Absent Member.
7033 views

Monitoring Weblogic JMX with Sitescope

Hi!
I have some problems with weblogic 10.3 monitoring using sitescope jmx : failed to connect.
I try many way for monitoring and all failed, i'm lost so i'll take any idea 🙂

I have follow this different tuto i've found here :
-http://90kts.com/blog/2008/monitoring-weblogic-using-jmx-in-sitescope/
-http://www.performanceengineer.com/blog/monitoring-weblogic-using-jmx/

i've provided :
- IIOP username/password
- jmx remote port...

i try with jconsole and it's work but only in local 😞
if i try on another serveur it doesn't work.

Port are not blocked by a firewall but i think it could be a security rules which explain this problem.

So i don't know what to do.

Thank you for your help

Labels (2)
0 Likes
8 Replies
Absent Member.
Absent Member.

This was one painful thing to set up. But I was able to configure it successfully.

Follow steps below:

1. Add the following entry Dcom.sun.CORBA.transport.ORBTCPReadTimeouts=10:60000:500:10 to HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Services/SiteScope/ServiceParam

2. Enable IIOP. I made sure the username/password for IIOP was the same as what you used to loginto Weblogic console (Just to make things easy).

3. Remove weblogic.jar and add wlfullclient.jar (Google for this file and you will get a link to download) under Sitescope Directory (C:\SiteScope\java\lib\ext) as well as Java Directory (C:\Program Files\Java\jdk1.6.0_11\lib\wlfullclient.jar)

4. Set classpath to include wlfullclient.jar. In XP go to Control Panel\System\Advanced TAB\Environment Variables. Select CLASSPATH under System variables frame and add C:\Program Files\Java\jdk1.6.0_11\lib\wlfullclient.jar

5. Restart the machine.

URL to specify in Weblogix JMX monitor should be something like this :

service:jmx:iiop:///jndi/iiop://:/weblogic.management.mbeanservers.runtime
where should be the same as MACHINE NAME for the WL server you are trying to monitor and

- is the LISTEN PORT. These can be retrieved under Environment --> Servers and clicking on the respective server link to be monitored.

Have fun configuring!
0 Likes
Absent Member.
Absent Member.

Hi
I have the same problem. I did all of the steps that are mentioned in previous replay but unfortunaltly I got this message again: (org.omg.CORBA.NO_PERMISSION: vmcid: 0x0 minor code: 0 completed: No). I use weblogic 10.3 and sitescope 9.5 and Port are not blocked by a firewall.
If my version of weblogic and sitescope cause this problem?
Thank you for your help
0 Likes
Absent Member.. Absent Member..
Absent Member..

follow these steps..

a. A monitor account on WebLogic server with â monitoringâ level.

b. Enable Anonymous Admin Lookup

c. SiteScope relies on the IIOP protocol to talk to the WL server. In order to get remote access with JMX via IIOP, enable IIOP lookup on admin as well as all managed servers.


d. And then set and user id and password for the â IIOP userâ on admin as well as all managed servers. Use the same ID and password you created on step a for monitoring account.

You must make sure that the username and password is >= 8 digits, otherwise the CORBA connection will fail when using SiteScope. You also need to restart all the servers including admin.

2. Prerequisite on SiteScope side:
a. Increase the ORB timeout by modifying the registry key as following.
-Dcom.sun.management.jmxremote=true -Dcom.sun.management.jmxremote.port=27676 -Dcom.sun.management.jmxremote.authenticate=false -Dcom.sun.management.jmxremote.ssl=false -server -Xmx1280m -Xms512m -Xmn320m -Xrs -XX:+UseParNewGC -XX:+UseConcMarkSweepGC -XX:MaxPermSize=128m -XX:+HeapDumpOnOutOfMemoryError -showversion -Dcom.sun.CORBA.transport.ORBTCPReadTimeouts=100:60000:180000:20 -Dcatalina.home="C:\SiteScope\Tomcat" -Dflipper.param.file=..\conf\flipperSiteScope.properties -Dtopaz.home=.. -Djavax.xml.parsers.DocumentBuilderFactory=com.sun.org.apache.xerces.internal.jaxp.DocumentBuilderFactoryImpl -DSiteScope=true -cp "C:\SiteScope\Tomcat\bin\bootstrap.jar" org.apache.catalina.startup.Bootstrap start

b. Modify master.config
i. "_disableExtraClassPathExecutor=true"

-Ashish
0 Likes
Admiral
Admiral

Hi Guys

 

 I hve a similar problem with Timeout SiteSCope version 10.14 and WL version is 10.3.4

 When i try to execute the jconsole through command line by giving the Extra timeout value

 

jconsole -J-Dcom.sun.CORBA.transport.ORBTCPReadTimeouts=10:30000:500:10

 

I am able to connect tp the WL and retrieve the Mbean counters

 

I added the Timeout value to the SiteScope registry ,Restrated the Sitescope and then launched the jconsole i am getting the same timeout value

 

Can anyone help on this matter ?

 

HP Product support is saying that WL 10.3.4 is not supported by 10.14 and even SiteSscope 11.X  but i can still use WL Solution template .I do hv the WL solution template , I am not able to understand if they say WL 10.3.4 how come WL will support the same ?

 

Please help me on this

 

Regards

Bilal Aman

 

0 Likes
Admiral
Admiral

i was able to solve it

0 Likes
Fleet Admiral
Fleet Admiral

Then do post the solution Aman. I am sure it helps lot many people out their.

 

--Sujith

Close the thread if your issue is resolved to make the thread meaningful and complete. Do show gratitude to people who helped you by assigning points.
0 Likes
Admiral
Admiral

Sujith

 

I resolved the issue all by myself , after doing trial and error method  Problem was the Timeout Value  in the registry value  was either too small or too large

 

The Value which worked for me  is

-Dcom.sun.CORBA.transport.ORBTCPReadTimeouts=10:30000:500:10

 

How do we close this thread ?

 

Regards

Bilal Aman

0 Likes
Absent Member.
Absent Member.

Thanks to this thread, and others (below) I was able to get a jconsole JMX connection to the WebLogic server to work when it ran on the WebLogic server. But as soon as I tried the same thing from the SiteScope server with a JMX URL of:

  service:jmx:iiop:///jndi/iiop://{WebLogicServerName}:7001/weblogic.management.mbeanservers.runtime

it would fail with a CORBA error:


  "WARNING: "IOP00410201: (COMM_FAILURE) Connection failure: socketType: IIOP_CLEAR_TEXT; hostname: localhost; port: 7001"

Which makes no sense, since I was NOT running jconsole from "hostname: localhost". I tried all the workarounds for this (e.g. changing the /etc/hosts file on the WebLogic server) but nothing worked.

The solution, for me, was to add a new WebLogic "Channel" for IIOP using a different port (7991) than the WebLogic default (7001). Then the JMX URL of:

    service:jmx:iiop:///jndi/iiop://{WebLogicServerName}:7991/weblogic.management.mbeanservers.runtime

 

worked perfectly.

 

Other sources of help:

https://forums.oracle.com/forums/thread.jspa?threadID=1056748&tstart=75
http://magictrevor.wordpress.com/2010/03/18/monitoring-weblogic-10-3-1-with-sitescope-10-10-via-jmx/
http://90kts.com/2008/02/28/monitoring-weblogic-using-jmx-in-sitescope/
http://www.kobatera.com/blog/posts/performance-engineering/using-sitescope-to-monitor-weblogic-103-12
http://weblogicfordummies.blogspot.com/2010/02/monitoring-jvm-sunjdk.html


 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.