Big news! The community will be moving to a new platform April 21. Read more.
Big news! The community will be moving to a new platform April 21. Read more.
Lieutenant
Lieutenant
113 views

OBR: content pack dependency error

Hi All,

 

I am trying to Install APM & SA content pack but I constantly prompting with error package manager check for dependency failed for:

 

I have tried literally everything but accept SA_core_Content pack & CORE_EUM nothing else is getting installed. I have also installed one by one as suggested in Doc but nothing seems to work even I have restarted the server as well as checked the DB connectivity all are working as expected.

 

Attached is the log and screenshot.

 

 

Labels (2)
5 Replies

I get an error when viewing the image, and the log too. I need to know what your packagemanager log has in it in $PMDB_HOME\log or %PMDB_HOME%log, depending on if you are running OBR on Linux or Windows. What version are you on and what OS platform have you deployed to? Please provide the contents of:

 

BSMRversion.prp

Hotfixversion.prp

One directory up from PMDB_HOME. Thanks!

0 Likes
Lieutenant
Lieutenant

Hi Michael,

It is typical installation where all component is in single linux system. OBR version is 10.40. OS linux -redhat 7.3 Maipo

Since it is in linux ODBC connection is not required as it automatically takes care.(Read several other forum topic)

There is one thing as I was facing the issue from lots many days. I have uninstalled all the content pack and try to reinstall but that is also failing only CORE_Domain pack is getting installed in default section. Rest 2 are also showing error dependency error.

 

Thanks for replying!!!

0 Likes

That was my next question. Did the core domain elements get installed with no issues? I still need to see the logs and a screen shot of the Content Pack deployment from the OBR Admin UI to comment further. Thanks!

Tags (4)
0 Likes
Lieutenant
Lieutenant

Yes core domain got installed without any issue.

Please find the attached screen & CP page screen shot. In cp page installation failed reason is package dependence.

0 Likes

Question:

 

Are you executing the installation, etc. via root/administrator privileges?

 

In the package manager log, you will see the commands being executed, and can execute them as root/administrator at the command line.


Test one, and reply back with the result? Thanks!

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.