Ensign Ensign
Ensign
385 views

OMW agent 12 failure on Windows 2008 MS Exchange 2010 server

Jump to solution

Hello all.

We're using HPOMW 9 to monitor many Windows 2008 Exchange 2010 servers.

We are unable to install the OMW agent 12 on one particular Win 2008 Exchange 2010 server.

When deploying the agent from the HPOMW management server, the deployment fails with  "(PMD1240) Cannot deploy package 'Operations-agent' to node <node name>. The agent API returned the following errors: (depl-81) Unable to deploy 'OVO-Agent.xml' to node <node name>. Exeinst failed (depl-385) Command 'oasetup.exe -install -configure <node name> -non_int -no_instnotify -force -minprecheck ' failed with the return code '10008' on the node <node name>"

We tried to install the agent locally using the local administrator account and other domain admin accounts but it keeps failing with the same error:

MSI (s) (04:14) [16:02:23:914]: Product: HP Shared Component -- Error 1406.Could not write value BuildNumber to key \SOFTWARE\Hewlett-Packard\HP OpenView\{C3084B86-9527-42C5-8432-5A295F686671}. System error . Verify that you have sufficient access to that key, or contact your support personnel.

The accounts mentioned have write access to the registry so this error is very confusing.

We have used the oacleanall_Windows_X64 script to completely remove the agent from this Win 2008 Exchange 2010 server but we still get the same outcome for both remote and local agent installation.

We even tried a reboot of the Win 2008 Exchange 2010 server.

Nothing is working.

 

Does anyone have a suggestion for fixing this and successfully installing the agent on this Win 2008 Exchange 2010 server?

 

Any help would really be appreciated.

 

Thanks all.

 

 

Labels (1)
0 Likes
1 Solution

Accepted Solutions
Ensign Ensign
Ensign

This issue was due to a corrupt registry key HKEY_LOCAL_MACHINE\SOFTWARE\Hewlett-Packard.

We removed and re-created this key on the Exchange server and the agent install completed successfully.

Thanks.

View solution in original post

0 Likes
3 Replies
Commodore
Commodore

Hello Tom,


I hope you’re having a good day.

My name is Adolfo Alvarado from OMW team and I have been assigned to assist your forum- Product Technical Question: OMW agent 12 failure on Windows 2008 MS Exchange 2010 server Could you please check the following solution:

https://softwaresupport.hpe.com/group/softwaresupport/search-result/-/facetsearch/document/KM1297597


Any questions or doubts please let me know


Best Regards

Ensign Ensign
Ensign

Hello Adolfo.

 

Thanks for the knowledge article link but this is not a certificate issue - there are no pending certificate requests.

Please let me know if you have any other suggestions.

Thanks again.

0 Likes
Ensign Ensign
Ensign

This issue was due to a corrupt registry key HKEY_LOCAL_MACHINE\SOFTWARE\Hewlett-Packard.

We removed and re-created this key on the Exchange server and the agent install completed successfully.

Thanks.

View solution in original post

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.