Admiral Admiral
Admiral
443 views

OMi 10.63 - opr-node -list_nodes throws the error

Hi Experts,

OMi 10.63 running on RHEL servers, 2 GW's and 1 DPS. Managing some 5000 nodes running OA 12 agents.

Getting the below error while executing the opr-node.sh -list_nodes command on GW and DPS servers.

Can you help to correct the error below:

# /opt/HP/BSM/opr/bin/opr-node.sh -username admin -password xxxx -list_nodes
[Fatal Error] :147349:38: Attribute name "qualified" associated with an element type "fully" must be followed by the ' = ' character.
org.xml.sax.SAXParseException; lineNumber: 147349; columnNumber: 38; Attribute name "qualified" associated with an element type "fully" must be followed by the ' = ' character.
        at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1239)
        at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(SAXParserImpl.java:643)
        at groovy.util.XmlSlurper.parse(XmlSlurper.java:207)
        at groovy.util.XmlSlurper.parse(XmlSlurper.java:244)
        at groovy.util.XmlSlurper$parse.call(Unknown Source)
        at org.codehaus.groovy.runtime.callsite.CallSiteArray.defaultCall(CallSiteArray.java:48)
        at org.codehaus.groovy.runtime.callsite.AbstractCallSite.call(AbstractCallSite.java:113)
        at org.codehaus.groovy.runtime.callsite.AbstractCallSite.call(AbstractCallSite.java:125)
        at com.hp.opr.config.cli.OprNode.getNodesWs(OprNode.groovy:1283)
        at com.hp.opr.config.cli.OprNode.getNodesWs(OprNode.groovy:1250)
        at com.hp.opr.config.cli.OprNode.listNodes(OprNode.groovy:819)
        at com.hp.opr.config.cli.OprNode.performSpecificRequest(OprNode.groovy:687)
        at com.hp.opr.cliutils.api.WebTool.performRequest(WebTool.java:1503)
        at com.hp.opr.config.cli.OprNode.main(OprNode.groovy:178)
ERROR:  Operation failed

Thanks,

Ram.

Labels (1)
0 Likes
3 Replies
Micro Focus Expert
Micro Focus Expert

Hello Ram,

I hope you are doing well,

Quick question, by any chance this is an OMi configured in FIPS mode?

Regards,

Edward Campos Monge.
Customer Support Engineer




If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the STAR at the bottom left of the post and show your appreciation.”
0 Likes
Admiral Admiral
Admiral

Hi Edward,

Nope, OMi is running on normal mode. I have searched if there is any special attribute called "qualified" for the CI type "Node", but didnt see anything like that.

“CI Type Manager” ->  ConfigurationItem -> InfrastructureElement -> Node

Thanks,

Ram.

0 Likes
Admiral Admiral
Admiral

Issue is resolved.

Thanks,

Ram.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.