UPDATE! The community will be go into read-only on April 19, 8am Pacific in preparation for migration on April 21. Read more.
UPDATE! The community will be go into read-only on April 19, 8am Pacific in preparation for migration on April 21.Read more.
Cadet 2nd Class Cadet 2nd Class
Cadet 2nd Class
1062 views

Oracle R12 application fails to run in BPM 9.03

Jump to solution

Hi Guys,

 

We were using BPM 8.05 and recently upgraded to 9.03 since the citrix scritps were not running properly. After this upgrade the Oracl R12 application fails to run.

 

LR 11.03

BPM 9.03

protocol used - Oracle Web application 11i ( GUI recording)

 

I get the error " Merial PTM Inquiry link not found" -- this is the link that opens other links which in turn opens oracle forms.

 

please let me know if any body have similar issue. script used to run fine in BPM 8.05.

 

 

Thanks,

Mallesh

Labels (1)
Tags (1)
0 Likes
1 Solution

Accepted Solutions
Cadet 2nd Class Cadet 2nd Class
Cadet 2nd Class

The issue is resolved after installing the patch for HP BPM 9.03.

 

patch link: http://support.openview.hp.com/selfsolve/document/FID/DOCUMENTUM_BACBPM_00043

 

thanks Sujith, for all your help. closing the post.

 

Thanks,

Mallesh

View solution in original post

0 Likes
8 Replies
Fleet Admiral
Fleet Admiral

Is the script failig constantly from all BPM's? Did you go through the application workflow manually on BPM? Is the script running fine on vugen?

 

--Sujith

Close the thread if your issue is resolved to make the thread meaningful and complete. Do show gratitude to people who helped you by assigning points.
0 Likes
Cadet 2nd Class Cadet 2nd Class
Cadet 2nd Class

the script runs fine in VuGen. it fails only in BPM. I didnt understand what you meant by " Did you go through the application workflow manually on BPM", I did try invoking it manually.

 

Thanks,

Mallesh

0 Likes
Fleet Admiral
Fleet Admiral

I meant do all the steps what script is doing on BPM where script is failing and ensure that link is appearing. Is the script failing continuously.

 

--Sujith

Close the thread if your issue is resolved to make the thread meaningful and complete. Do show gratitude to people who helped you by assigning points.
0 Likes
Cadet 2nd Class Cadet 2nd Class
Cadet 2nd Class

the link appears all the times - i have tried this manually and also the script runs fine in LR 11.03.

 

the script fails everytime it runs from BPM.

 

Thanks,

mallesh

0 Likes
Fleet Admiral
Fleet Admiral

 As you are saying the link is apearing manually, it rules out application issue. Can youn install vugen on any of the BPM's where the script is failing and replay the script with "extended log" option and share the result. As the recording is at GUI level, screen resolution also matters. Try chaning the screen resolution to 1024*768 or 1280*1024 or 800*600 and check in BPM. Suggest you to undeploy and redeploy the script again to BPM.

 

Also, it would be more helpful if you paste the piece of code where the error is occuring. Last but not the least, BPM 9.03 should be run with specific user which has local admin priveleges for all protocols except web based protocol.

 

--Sujith

Close the thread if your issue is resolved to make the thread meaningful and complete. Do show gratitude to people who helped you by assigning points.
0 Likes
Cadet 2nd Class Cadet 2nd Class
Cadet 2nd Class

Hi,

 

the script runs fine in LR installed in BPM PC.

 

This is the code it fails at. The script will click this link just after login. I have also added a text check after login to make sure it is logging in. 

 

    web_text_link("Merial PTM Inquiry",
        "Snapshot=t5.inf",
        DESCRIPTION,
        "Text=Merial PTM Inquiry",
        LAST);

 

Thanks,

Mallesh

0 Likes
Fleet Admiral
Fleet Admiral

What about the other things I suggested in my previous post. Did you try them?

 

--Sujith

Close the thread if your issue is resolved to make the thread meaningful and complete. Do show gratitude to people who helped you by assigning points.
0 Likes
Cadet 2nd Class Cadet 2nd Class
Cadet 2nd Class

The issue is resolved after installing the patch for HP BPM 9.03.

 

patch link: http://support.openview.hp.com/selfsolve/document/FID/DOCUMENTUM_BACBPM_00043

 

thanks Sujith, for all your help. closing the post.

 

Thanks,

Mallesh

View solution in original post

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.