Highlighted
Absent Member.
Absent Member.
188 views

SAPGUI connection error

Hello,

I have a SAPGUI script running on BAC from three different worldwide locations. Everything should be fine, but I'm getting some errors (maybe 10% of total) at seemingly random times:

Action.c(9) Error: Failed to open new connection to server '-XXX' Snapshot Info [MSH 0 0 1]
Action.c(9) Error: Failed to get active window
Action.c(9) Error: Failed to find SapGui component by ID
Action.c(9) Error: Failed to get the status bar text
Action.c(9) Error: Failed to get active window

When I run this from my laptop the script works every time. When run remotely at the BAC agent machine I can replicate this.

Other [very similar] SAPGUI scripts running on the same servers work perfectly. I searched the forum and found that someone had had the same problem but his solution was related to user accounts and the script didn't work at all, the most puzzling thing here is the randomness and the small but continuing number of errors.

Could there be some problem with multiple sessions from multiple locations interfering with each other and the target system etc?

Thanks in advance.
0 Likes
1 Reply
Highlighted
Absent Member.
Absent Member.

Were you able to resolve this issue with SAP GUI, i am getting the same issue as of right now, using LR 9.5
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.