Highlighted
Established Member..
Established Member..
3903 views

Vugen 11, Citrix 12 and IE8

Hi I have recently installed HP Vugen 11 including patch 1 and patch 2. I am trying to record an application hosted on a xenapp 6 citrix server using the citrix 12 web client, withing IE8.

Outside of Vugen the application launches fine. However when recording, no events are recorded after clicking on the application within the citrix farm, and the application fails to launch.

I have no experience of recording citrix applications so maybe I am doing something wrong. I have selected a multi protocol script, with HTTP/HTTPS, and Citrix as the protocol, am I missing something else?
Labels (1)
0 Likes
10 Replies
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Try to record with citrix ica protocol
Cheers!

Nvr Blame a day in ur life....... Good day gives "happiness" & Bad day gives "experience" ......
0 Likes
Highlighted
Established Member..
Established Member..

Hi Parkar, we are not using the ICA client. We are using Xenapp6 Nfuse, with the citrix web client, as this is how the application is accessed by our end user. We are also including the ICA protocol with HTTP/HTTPS multiprotocol script but this isn't helping either.
0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Hello Ben,
The Protocal selected is fine, there is one patch for recording the applications on IE8, please get that installed your issue will be solved.
please find the details of the patch below,

Patch Name: LRVUG_00006
Description: Vugen SA Support IE8 recording
Product: LoadRunner
Operating System: windows
Date Released: 10/27/2010

With Regards
Vinay N
0 Likes
Highlighted
Absent Member.
Absent Member.

Hi,

I believe that the patch mentioned is for LR9.5. LR11 supports IE8.

Just check the LoadRunner readme file, if your Citrix server and client versions are supported by LR.

Also, with Citrix NFuse, there are certain things you may have to consider.
The attached KB article talks about that.

Archana
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Patch LRVUG_00006 is for VuGen 9.52, not for VuGen 11 that supports IE8 out-of-the-box.

From VuGen guide:

VuGen supports all Citrix clients with the exception of versions 8.00, version 6.30.1060 and earlier, and ***Citrix Web clients***.
0 Likes
Highlighted
Established Member..
Established Member..

Hi thanks for the response. As far as I can tell I only installed the citrix web client v12 there is no ICA client. The extensive document you sent through appears to realate to an ICA client. I was told by our citrix administrators they don't use ICA client anymore. I am not sure of all teh terminology as this is not my area, however they are using Xenapp 6 server and the web client to connect not sure if this type of connection is then called nfuse or not, I am a bit confused by it all to be honest. All I know is that the applicaiton and citrix client launch fine in the browser outside of Vugen, and as far as I know I have the latest version of vugen with patches applied so it should support it in my opinion.
0 Likes
Highlighted
Absent Member.
Absent Member.

I have the same problem.  I'm using Vugen 11 patch 2, Xenapp plugin client 11.0 and IE7.

 

Internet Explorer disappears during a Multi protocol Citrix and HTTP/HTML recording as soon as the Citrix ICA client is launched. I can see IE downloads launch.ica and then closes. After that nothing happens.

 

I have installed the patch - Enable_Citrix_API.reg

 

I can record with single protocol - Citrix ICA only.  Our citrix admin is upgrading to Xenapp 6 (currently Xenapp 5) and would be great if I can get the recording working via Citrix web.

 

 

 

 

0 Likes
Highlighted
New Member.

turn off firewall and DEP and have a try.
DEP is Data Execution Prevetion.
0 Likes
Highlighted
Absent Member.
Absent Member.

DEP has turned off previously.

 

I found the root cause.  McAfee antivirus buffer overflow protection blocked iexplore.exe from executing.  Once iexplore.exe is included in the BOP exclusion list, LR works fine with Citrix web.

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

I am also facing the same problem. I am using HP VU Gen 11 with 4th patch.

With Citrix Client version 12.1 and also xenApp version 6. I am trying to record a single protocol script .

When i begin the recording, all i am getting is ICA Client window with "Unsupported Function" written in it.

 

if anyone has a solution to this, please help me..

 

Thanks in Advance

 

Nikunj Rathi

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.