Big news! The community will be moving to a new platform April 21. Read more.
Big news! The community will be moving to a new platform April 21. Read more.
Commodore Commodore
Commodore
93 views

marble service issue

Hi Experts,

We have Standalone OBM 10.70 Windows setup with remote DB ( MS SQL ) . Dashboard service is not starting and here are the related logs i see :

 

CMDB Operation Internal Error: class com.mercury.topaz.cmdb.shared.tql.exception.FuseException : Could not be initialized since the limit [3000] of maximum initialized patterns has been exceeded by [3094] from [90] !!!! : operation TQLScheduler operation: start patterns request
at com.mercury.topaz.cmdb.shared.manage.operation.impl.AbstractCommonOperation$OperationExecuteFlowTrackingCommand.execute(AbstractCommonOperation.java:114)
at com.mercury.topaz.cmdb.shared.manage.operation.impl.AbstractCommonOperation$OperationExecuteFlowTrackingCommand.execute(AbstractCommonOperation.java:60)
at com.mercury.topaz.cmdb.shared.manage.flowmanagement.api.FlowManager.execute(FlowManager.java:227)
at com.mercury.topaz.cmdb.shared.manage.operation.flow.OperationInFlowDefaultExecutor.execute(OperationInFlowDefaultExecutor.java:23)
at com.mercury.topaz.cmdb.shared.manage.operation.impl.AbstractCommonOperation.execute(AbstractCommonOperation.java:158)
... 80 more
Caused by: com.mercury.topaz.cmdb.shared.tql.exception.FuseException: [ErrorCode [190] Could not initialize pattern since the limit of maximum initialized pattern has been exceeded!!!]
Could not be initialized since the limit [3000] of maximum initialized patterns has been exceeded by [3094] from [90] !!!!
at com.mercury.topaz.cmdb.server.tql.newscheduler.internal.gates.InitializedPatternsFuse.setCurrentValue(InitializedPatternsFuse.java:30)
at com.mercury.topaz.cmdb.server.tql.newscheduler.internal.gates.InitializedPatternsFuse.setCurrentValue(InitializedPatternsFuse.java:24)
at com.mercury.topaz.cmdb.server.tql.newscheduler.internal.gate

 

Product: Operations Bridge Manager
Version: 10.70
Build: 007.001
OfficialRelease: 2018.05
OfficialBuild: 10.70.007.001

0 Likes
1 Reply
Micro Focus Expert
Micro Focus Expert

You can increase that fuse from CMDB local client > Administration > infrastructure settings.
Filter by name and search for "TQL Initialized count".
Please note that you have 3094 TQLs and the default value is 3000. I suggest to increase deployment level instead of increasing fuse value. Another option is to check why do you have so many TQLs and delete unused TQLs, or if you are using many Perspective based views switch to Pattern views.
Let me know if you need more info.
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.