UPDATE! The community will be go into read-only on April 19, 8am Pacific in preparation for migration on April 21. Read more.
UPDATE! The community will be go into read-only on April 19, 8am Pacific in preparation for migration on April 21.Read more.
Vice Admiral
Vice Admiral
518 views

node name as message group

Dear Experts, I'm trying to use <$node_name> in an SNMP monitoring policy. But when message is received message group is empty. kindly tell me how to diagnose and resolve this.

Regards,
Kaleem Ullah
0 Likes
4 Replies
Absent Member.. Absent Member..
Absent Member..

Hello,

In SNMP interceptor policies, you can include the variable <$MSG_NODE_NAME> as a part of the message key.
0 Likes
Vice Admiral
Vice Admiral

Hi TamNP,

I am already using the same variable but it is not reflected in resulted messages. 

Regards,
Kaleem Ullah
0 Likes
Absent Member.. Absent Member..
Absent Member..

Hi BTO,

For configuring SNMP policy, could you review it in details by referring to Online Help page 871

0 Likes
Absent Member.. Absent Member..
Absent Member..

Hi Kaleem ,

 

Besides try TAMNP's suggestion, Please note that if you do not configure SNMP then the OS information for the node will not be discovered automatically when adding W2K8 R2 and W2K8 R2 Core nodes and you will need to enter the details manually

 
-  On Management Server
 
Install SNMP service and do following configuration

 a. Go to Start-> Run type services.msc
 b. Go to SNMP Service -> right click->properties
 c. Add community Name "public" with READ ONLY Community rights
 SEE SPECIAL NOTE BELOW
 d. Select the option "Accept SNMP packets from any host"
 
-  Agent
 
1. Install the snmp service on the node
2. Do the following changes in registry.
 a. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SNMP\Parameters\ValidCommunities
  – Focus on the public KEY. Double click and set Value Data to 4.
  – If the public KEY does not exist, create a public key with Data Type as REG_DWORD and set Value Data to 4.
 b. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SNMP\Parameters\ValidCommunities
  – Focus on the EnableAuthenticationTraps key, and set Value Data to 4.
  – If EnableAuthenticationTraps KEY does not exist, create an "EnableAuthenticationTraps" key with REG_DWORD and set Value Data to 4.
  c. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SNMP\Parameters\PermittedManagers
  - Remove the key with value "localhost" to accept snmp packets from all source.
3. Restart the machine --> shutdown /r

 
 
Hope this help
 
Regards,
 
HAZARD
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.