ALERT! The community will be read-only starting on April 19, 8am Pacific as the migration begins. Read more for important details.
ALERT! The community will be read-only starting on April 19, 8am Pacific as the migration begins.Read more for important details.
Absent Member.. Absent Member..
Absent Member..
173 views

opcswitchhbp - How to use?

Jump to solution

Hi all,

 

just switched on heartbeat-polling for all agents via opchbp -start -all. At the end of the confirmation list I received this msg:

 

'Error opcswitchhbp(21936) : Node usqrtpl0296.internal.unicreditgroup.eu is not in the node bank. (OpC50-91)'

 

The interesting topic here is NOT that the node doesn't exist in the node bank (because a colleague just had deleted it in that moment) BUT the reported command, which I never saw before.

 

In general I'm looking for a command which allows me to change the 'Heartbeat Polling Type' and to switch-on the 'Agent Sends Alive Packets' via command-line. Maybe its the 'opcswitchhbp' or anything else?

 

So does anyone know a CLI command for the above HB switches and/or any details about opcswitchhbp?

 

Thanks

Rolf

 

Labels (1)
0 Likes
1 Solution

Accepted Solutions
Micro Focus Expert
Micro Focus Expert

Hi Rolf,

 

please check the options in the opchbp command:

 

 

 opchbp [ -help ] |
       [ -start | -stop | -interval <interval> <node-specification> ] |
       [ -set {nopolling|rpconly|normal} <node-specification> ] |
       [ -agentsendsalivepackets {enable|disable} <node-specification> ]
        <node-specification> = -all | {-nodegrp <group>}... | <node>...

 

To enable/disable the Agent sends alive pleasue use the option -agentsendsalivepackets

 

The opcswitchhbp command may be an internal command/subroutine used by opchbp . YOu should use the opchbp command for changes.

 

Hope this helps

Marc

 

If you liked it I appreciate a thumb-up click, if it solves it, please mark it below with "Accept as Solution" - thanks!

View solution in original post

0 Likes
1 Reply
Micro Focus Expert
Micro Focus Expert

Hi Rolf,

 

please check the options in the opchbp command:

 

 

 opchbp [ -help ] |
       [ -start | -stop | -interval <interval> <node-specification> ] |
       [ -set {nopolling|rpconly|normal} <node-specification> ] |
       [ -agentsendsalivepackets {enable|disable} <node-specification> ]
        <node-specification> = -all | {-nodegrp <group>}... | <node>...

 

To enable/disable the Agent sends alive pleasue use the option -agentsendsalivepackets

 

The opcswitchhbp command may be an internal command/subroutine used by opchbp . YOu should use the opchbp command for changes.

 

Hope this helps

Marc

 

If you liked it I appreciate a thumb-up click, if it solves it, please mark it below with "Accept as Solution" - thanks!

View solution in original post

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.