Highlighted
Honored Contributor.
Honored Contributor.
510 views

policy parameters and perl processing

Jump to solution

I'm struggling with the parameter customization for a SystemInfo policy. It seems parameters that are specified during assignment are not passed to the perl within the threshold measurement policy. I've enabled debug and get the trace messages where I've added a dump of values that come from:

$CIFSSpaceUtilCriticalThreshold = $OVOSystem->ParameterGetNum("CIFSSpaceUtilCriticalThreshold","%%CIFSSpaceUtilCriticalThreshold%%");
$Session->Value("CIFSSpaceUtilCriticalThreshold", $CIFSSpaceUtilCriticalThreshold);

But the values shown in trace messages are from default parameter values and not the ones used during assigment. I.'e  For mentioned parameter I get: 65535

while parameter value specified during policiy assigment is

65535,/home/public=98

 

I've checked the xml files within /var/opt/OV/datafiles/policies/monitortmpl/ and they do contained the customised params as in:

<values>

<parameter>

<name>CIFSSpaceUtilCriticalThreshold</name>

<value>65535,/home/public=65535</value>

</parameter>

</values>

 

server is: OMi 10.01 IP6 and agent is 11.14.014

 

Any ideas?

Labels (1)
0 Likes
1 Solution

Accepted Solutions
Highlighted
Honored Contributor.
Honored Contributor.

I have resolved this now. 

Problem is that while Sys_LinuxCifsUtilizationMonitor should in theory support per filesystem thresholds via parameters(format: default,fs1=thr1,fs2=thr2 ), the out of the box policy uses threshold parameters of type numeric so it will just accept a simple number. I have changed the parameter type to String but haven't modified the script to use ParameterGetString instead of ParameterGetNum. There was no error, but policy only worked with the first threshold ignoring custom filesystem threshold after comma.

This is a bug that affects even the freshly released Systeminfo policies (probably not just this one policy).

Feel free to raise an issue with the support.

View solution in original post

0 Likes
6 Replies
Highlighted
Absent Member.
Absent Member.

Hi,

Could you please specify what SystemInfo policy are you referring?
Also it comes from OMi?

Regards,

David E. Padilla Morales | SW Technical Support Consultant.

Operation Manager i

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.

0 Likes
Highlighted
Honored Contributor.
Honored Contributor.

Hi David,

this is Sys_LinuxCifsUtilizationMonitor.

0 Likes
Highlighted
Honored Contributor.
Honored Contributor.

Just wondering .. multiple policies in SI use parameters with the same variable names

i.e.

Sys_FileSystemUtilizationMonitor

Sys_LinuxCifsUtilizationMonitor

Sys_LinuxNfsUtilizationMonitor

all use

SpaceUtilCriticalThreshold

Policies then typically do

$Session->Value("SpaceUtilCriticalThreshold", $SpaceUtilCriticalThreshold);

Would there not be a conflict?

0 Likes
Highlighted
Absent Member.
Absent Member.

Hi,

The policy threshold is determined in OMi UI, please check the screenshots, also check with "ovpolicy -list" that the policy version deployed in the node is the same that you modified. Additionaly we normally deploy Aspects not only policies.


Regards,
David E. Padilla Morales | SW Technical Support Consultant.
Operation Manager i
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.

0 Likes
Highlighted
Honored Contributor.
Honored Contributor.

The policy is deployed within aspect "Remote Disk Space Utilization". Aspect version is 1.104, just like he policy version. However

ovpolicy - list gives:

monitor "Sys_LinuxCifsUtilizationMonitor" enabled 0001.0105
monitortmpl "Sys_LinuxCifsUtilizationMonitor" enabled 0001.0104

No sure what you mean by

"The policy threshold is determined in OMi UI".

Thresholds are evaluated by perl script. Screenshots show default parameter definitions.

0 Likes
Highlighted
Honored Contributor.
Honored Contributor.

I have resolved this now. 

Problem is that while Sys_LinuxCifsUtilizationMonitor should in theory support per filesystem thresholds via parameters(format: default,fs1=thr1,fs2=thr2 ), the out of the box policy uses threshold parameters of type numeric so it will just accept a simple number. I have changed the parameter type to String but haven't modified the script to use ParameterGetString instead of ParameterGetNum. There was no error, but policy only worked with the first threshold ignoring custom filesystem threshold after comma.

This is a bug that affects even the freshly released Systeminfo policies (probably not just this one policy).

Feel free to raise an issue with the support.

View solution in original post

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.