Gavrilo
Visitor.
387 views

Installing Content Pack through ContentManager - HTTPS error

Hi

Env:

OMi 10.10.028 (HTTPS enabled in configuration step of install) on RH 6.5

I have the following problem:

I have a simple installation script (run locally) for self-developed Management Pack that uploads both packages, rtsm via opr-jmxClient (works) and content pack via ContentManager where I get:

The presented certificate from the server is not known.

Subject : CN=hostname_of_server, O=Hewlett Packard Enterprise, C=US
Issuer : CN=OMi Certification Authority, O=Hewlett Packard Enterprise, C=US
Fingerprint(SHA1): 9B:20:43:76:2B:94:57:0E:F1:48:5B:4A:63:40:B5:B3:E3:72:53:3D
ERROR: IO error. Reason: SSLPeerUnverifiedException: peer not authenticated.
ERROR: IO error. Reason: SSLPeerUnverifiedException: peer not authenticated.

Exact command is:

$TOPAZ_HOME/bin/ContentManager.sh -username admin -password password -import /tmp/cp.zip

Also tried appending -ssl option and -port 443 (separetly) to the end and of the command but with no luck.

If I run the original command on a same server with no HTTPS enabled it works.

Output of /opt/HP/BSM/bin/opr-cert-mgmt.sh -list :

All certificates in inventory:

- OMi Webserver CA Certificate: Subject: CN=OMi Certification Authority, O=Hewlett Packard Enterprise, C=US; Expires: Sat Feb 07 16:29:36 CET 2026

What is the issue here?

Thank you for your help!

Tags (1)
0 Likes
2 Replies
Contributor.. boey007 Contributor..
Contributor..

Re: Installing Content Pack through ContentManager - HTTPS error

Hi,

I am getting the exact same error in my environment. Did you get a fix for this ?

Regards,

Craig

0 Likes
Gavrilo
Visitor.

Re: Installing Content Pack through ContentManager - HTTPS error

Hi!

Are you calling ContentManager.sh from a script? If yes, first try running command from CLI if it works. When you have HTTPS configured you will be prompted to accept certificate in command line. Our problem was because we redirected output of the ContentManager.sh script and we didn't get the prompt to accept the certificate. Without redirection it works ok.

I hope it helps.

Regards

G

 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.