Having problems with your account or logging in?
A lot of changes are happening in the community right now. Some may affect you. READ MORE HERE
Arvarox Frequent Contributor.
Frequent Contributor.
232 views

(OBM GW) Unable to start MercuryAS, ERROR - Failed to retrieve server-state from JbossCl

Hello everyone!
I had a problem installing OBM GB from OBM_2018.11_for_Linux.
I have:
test1 - OBM GW
test2 - OBM DPS
OS - Centos 7
DB - PostgreSQL (embedded DBMS)

Installation Algorithm:
1. Install DPS
2. Install GW
3. Configure DPS
4. Configure GW
5. Run DPS
6. Start GW
Installation was carried out according to the manual and with default values for Distributed deployment.
The first 5 steps are completed without errors. When starting the GW (run_hpbsm restart) i see next error in jboss_admin.log:


[Nanny-WatchDog-2] (JbossCli.java:116) ERROR - Failed to retrieve server-state from JbossCli

com.hp.bsm.platform.jboss.admin.ConfigurationException: JBoss cli error: {
"outcome" => "failed",
"failure-description" => "System boot is in process; execution of remote management operations is not currently available"

Searching the forum led me to the next page:
https://community.softwaregrp.com/t5/Operations-Manager-i-User/OMi-Support-Tip-Unable-to-start-MercuryAS-ERROR-Failed-to/m-p/1648473#M8324

The situation is similar, but the proposed solution for GW does not work for me. Any idea what to look for?

Installation was carried out according to the manual and with default values for Distributed deployment.

Here is another mistake on this issue:

locationsManager.log

2019-02-15 14:39:29,548 [Location notification registration] ERROR LocationsNotificationsAdapter.registerLoop(87) - registration of listener Locations model fixer for customer1 for customer 1 failed, will retry afetr 60 seconds
com.hp.ucmdb.api.CommunicationException: java.net.ConnectException: Connection refused (Connection refused)
at com.hp.ucmdb.api.UcmdbServiceFactory.createHttpServiceProviderFactory(UcmdbServiceFactory.java:185)
at com.hp.ucmdb.api.UcmdbServiceFactory.getHttpServiceProviderFactory(UcmdbServiceFactory.java:139)
at com.hp.ucmdb.api.UcmdbServiceFactory.getHttpServiceProvider(UcmdbServiceFactory.java:132)
at com.hp.ucmdb.api.UcmdbServiceFactory.getServiceProvider(UcmdbServiceFactory.java:123)
at com.hp.ucmdb.api.UcmdbServiceFactory.getServiceProvider(UcmdbServiceFactory.java:102)
at com.hp.bsm.platform.sdk.pool.UcmdbSdkPool.getProvider(UcmdbSdkPool.java:207)
at com.hp.bsm.platform.sdk.pool.UcmdbSdkPool.createUcmdbService(UcmdbSdkPool.java:183)
at com.hp.bsm.platform.sdk.pool.UcmdbSdkPool.getServiceNew(UcmdbSdkPool.java:152)
at com.hp.bsm.platform.sdk.pool.UcmdbSdkPool.getService(UcmdbSdkPool.java:125)
at com.hp.bsm.platform.sdk.pool.UcmdbSdkPool.getService(UcmdbSdkPool.java:228)
at com.hp.bsm.platform.locationsManager.utils.ModelConnection.connectToModel(ModelConnection.java:31)
at com.hp.bsm.platform.locationsManager.logic.model.notifications.LocationsNotificationsAdapter.register(LocationsNotificationsAdapter.java:55)
at com.hp.bsm.platform.locationsManager.logic.model.notifications.LocationsNotificationsAdapter.registerLoop(LocationsNotificationsAdapter.java:84)
at com.hp.bsm.platform.locationsManager.logic.model.notifications.LocationsNotificationsAdapter$1.run(LocationsNotificationsAdapter.java:70)
Caused by: java.net.ConnectException: Connection refused (Connection refused)
at java.net.PlainSocketImpl.socketConnect(Native Method)
at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350)
at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206)
at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188)
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
at java.net.Socket.connect(Socket.java:589)
at java.net.Socket.connect(Socket.java:538)
at sun.net.NetworkClient.doConnect(NetworkClient.java:180)
at sun.net.www.http.HttpClient.openServer(HttpClient.java:463)
at sun.net.www.http.HttpClient.openServer(HttpClient.java:558)
at sun.net.www.http.HttpClient.<init>(HttpClient.java:242)
at sun.net.www.http.HttpClient.New(HttpClient.java:339)
at sun.net.www.http.HttpClient.New(HttpClient.java:357)
at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(HttpURLConnection.java:1220)
at sun.net.www.protocol.http.HttpURLConnection.plainConnect0(HttpURLConnection.java:1156)
at sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:1050)
at sun.net.www.protocol.http.HttpURLConnection.connect(HttpURLConnection.java:984)
at com.hp.ucmdb.api.UcmdbServiceFactory.submitHTTPRequest(UcmdbServiceFactory.java:212)
at com.hp.ucmdb.api.UcmdbServiceFactory.connect(UcmdbServiceFactory.java:197)
at com.hp.ucmdb.api.UcmdbServiceFactory.createHttpServiceProviderFactory(UcmdbServiceFactory.java:174)
... 13 more

0 Likes
3 Replies
Misaq Acclaimed Contributor.
Acclaimed Contributor.

Re: (OBM GW) Unable to start MercuryAS, ERROR - Failed to retrieve server-state from JbossCl

Just to verify configuration. you can try following:

  • make sure DPS is fully available using status page or cli.
  • make sure connectivity is working between both boxes.
  • start GW with a different command (not restart may be start or something else)
  • check on GW status homepage.
  • Make sure firewall and permissions are valid for both servers.
0 Likes
Arvarox Frequent Contributor.
Frequent Contributor.

Re: (OBM GW) Unable to start MercuryAS, ERROR - Failed to retrieve server-state from JbossCl

Hi, Misaq!
I am glad that you are interested in my question.

  • bsmstatus.sh & opr-status.py & opr-support-utils.sh say RUNNING/STARTED for all components (on DPS)
  • ping & tracert & telnet connects to both sides
  • I tried stopall/start or reboot or reboot/sopall/start
  • I was only able to log into DPS:29000 , I can’t access GW from webinterface
  • Firewalld stop&disabled
0 Likes
Micro Focus Contributor
Micro Focus Contributor

Re: (OBM GW) Unable to start MercuryAS, ERROR - Failed to retrieve server-state from JbossCl

My OBM GW in Windows was getting this error until I  turned-off Firewall in Settings.  It worked after turning it off and rebooting.  Make sure to the server is listening to port 443 if running secure https.


C:\Windows\system32>netstat -bona | find "443"
TCP 0.0.0.0:443 0.0.0.0:0 LISTENING 1292
TCP [::]:443 [::]:0 LISTENING 1292

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.