UPDATE! The community will be go into read-only on April 19, 8am Pacific in preparation for migration on April 21. Read more.
UPDATE! The community will be go into read-only on April 19, 8am Pacific in preparation for migration on April 21.Read more.

upgrading tomcat due to security issues

Idea ID 2860998

upgrading tomcat due to security issues

0 Votes

Hi,

how could we do an update of tomcat to the latest version ? We are running 2020.02 build 39, I can see that the next version 2020.08 will lift it up from 9.0.22 only to 9.0.37, witch is rather old (actual version is 9.0.43).

I think we will see this quite often, as the versioning of tomcat is quite fast.

So, how to do only an update of tomcat ?

Thanks in advance

Holger

 

1 Comment
Micro Focus Frequent Contributor
Micro Focus Frequent Contributor
Status changed to: Declined

Hi Holger,

Thanks for raising this request.

Tomcat is an essential part of the product architecture and is coupled with all the major components. At the moment we can't provide any clean method to upgrade Tomcat outside of the official development cycle.

The only solution for now is to upgrade OO to the latest version, which will always have either the latest Tomcat version at the moment of the release, or at least a version that is very close to the latest one.

The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.