Super Contributor.. OltreXR4 Super Contributor..
Super Contributor..
327 views

CSA 4.7 and OO 10.60 Password Provider Strange behaviour in debug mode.

Hi,

I have an issue that I have double checked, I know, it has not any reason to be, but I have tried on purpose several times.

I have run a CSA flow as normal request, it failed, from Studio I have fixed the problem and run in debug mode of course connected with Central.

It failed for authentication problem of the provider.

Double checked the password in the provider definition, it was ok.

Set the password as static property inside the flow and it worked from Debug

Remove the password from the static property, use the password from get provider properties as usual, create the CP and import into Central and it worked!

So it seems that when you run CSA flows in Debug mode also if you run them in Central the provider password is not managed correctly, but only in Debug.

Any one have the same experience?

Thanks for any suggestion.

Mirco

 

Labels (2)
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.