Absent Member.. DBR Absent Member..
Absent Member..
136 views

Can't Install OO 10.20 on Linux Server

When I run the installer I am getting this error.

[root@aoxz4091 tzs]# ./installer-linux64.bin
decompressing...
invoking installer...
Exception in thread "main" java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons:
        no swt-pi-gtk-4234 in java.library.path
        no swt-pi-gtk in java.library.path
        Can't load library: /root/.swt/lib/linux/x86_64/libswt-pi-gtk-4234.so
        Can't load library: /root/.swt/lib/linux/x86_64/libswt-pi-gtk.so
        /root/.swt/lib/linux/x86_64/libswt-pi-gtk-4234.so: libXtst.so.6: cannot open shared object file: No such file or directory

 

Does java has to be installed first?  The directory and files exist.

 

Thanks,

Don

 

Labels (1)
0 Likes
2 Replies
Felipe_A_OO Absent Member.
Absent Member.

Re: Can't Install OO 10.20 on Linux Server

Hi there Don,

 

In order to trouble shoot this issue please make sure the installer is not corrupted, and the versions of db and OS are compatible with HPOO.

 

Also the issue is a missing GTK in the OS lib you can download the graphical package to run the installers, you will require those to show the installation wizard window (also make sure you have the global variables and the paths accessible by the installer).

 

To answer your question No, the HP OO software uses it own JAVA and it is installed in the proccess.

 

As a workaround, you can use the silent installer you can find the properties sample in the HP live network documentation: HP Operation Orchestration Documentation.

 

Regards,
Felipe Alvarado S|SW Technical Support Consultant.
Operation Orchestration
Hewlett-Packard (SSO Portal)


If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the STAR at the bottom left of the post and show your appreciation.
0 Likes
Absent Member.. DBR Absent Member..
Absent Member..

Re: Can't Install OO 10.20 on Linux Server

Felipe,

 

We installed libswt3-gtk2.x86_64 and got around the first error.  Now we are getting this error:

invoking installer...
Exception in thread "main" org.eclipse.swt.SWTError: No more handles [gtk_init_check() failed]

 

We can't find the eclipse version of the gtk2 RPM for RHEL 5.  Do you know if HP has it somewhere.  I also found this HP article KM00596734 that says you need to install Java 1.7 or greater and shows the exact error we are getting.  We installed java 1.7.0_09 and are still getting the error.

 

Thanks,

Don

 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.