Highlighted
Trusted Contributor.. Trusted Contributor..
Trusted Contributor..
192 views

Chat Ops integration with OO and slack - Failed authentication

Jump to solution

Hi everyone!

We're trying to deploy the integration between OO and Chat Ops using slack, but when trying to login in the hubot server it fails while using a valid username of OO. 

While checking the logs we see the following error:

ERROR Request error: { [Error: tunneling socket could not be established, statusCode=503
at ClientRequest.onConnect (/opt/microfocus/itom-maestro-oo-bot/scripts/hubot-oo/node_modules/tunnel-agent/index.js:166:19)
at Object.onceWrapper (events.js:277:13)
at ClientRequest.emit (events.js:189:13)
at Socket.socketOnData (_http_client.js:475:11)
at Socket.emit (events.js:189:13)
at addChunk (_stream_readable.js:284:12)
at readableAddChunk (_stream_readable.js:265:11)
at Socket.Readable.push (_stream_readable.js:220:10)
at TCP.onStreamRead [as onread] (internal/stream_base_commons.js:94:17)
] code: 'ECONNRESET' }
2019-11-01T00:04:51.335Z - info: Function authMethod getting error message: Error: System error

Did anybody else faced this problem?

 

Regards,

Labels (2)
Tags (3)
0 Likes
1 Solution

Accepted Solutions
Highlighted
Trusted Contributor.. Trusted Contributor..
Trusted Contributor..

Re: Chat Ops integration with OO and slack - Failed authentication

Jump to solution

For anyone wondering or having the same issue, we solve it,

 

The problem was that the Chat Ops Server couldn't comunicate with the OO Server due to the proxy.

 

We added the OO hostname in the parameter "no_proxy" located in the slack.env file.

 

Regards.

View solution in original post

0 Likes
1 Reply
Highlighted
Trusted Contributor.. Trusted Contributor..
Trusted Contributor..

Re: Chat Ops integration with OO and slack - Failed authentication

Jump to solution

For anyone wondering or having the same issue, we solve it,

 

The problem was that the Chat Ops Server couldn't comunicate with the OO Server due to the proxy.

 

We added the OO hostname in the parameter "no_proxy" located in the slack.env file.

 

Regards.

View solution in original post

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.